Missing LED-Notifications for some Android apps

REPRODUCIBILITY (% or how often): 80%
BUILD ID = OS VERSION (Settings > About product):
HARDWARE (XA2, Xperia 10…): XA2
REGRESSION: (compared to previous public release: Yes, No, ?): 3.4 NO


Notifications from Android apps are no longer displayed automatically since the update to 4.0.1. Regardless of whether the app is closed or running in the background. The application is activated in apps as “Allow background services to start when switched on”. Sometimes notifications appear with vibration but no sound. I can’t see a pattern.



  1. Install Android App with Notifications e.g. Blabber.im
  2. Mark App “Allow background services to start when switched on” in Apps Tab in Settings
  3. Trigger a Notification event
  4. No Notification was shown in events view.


If notifications from Android apps occur, they are displayed with the settings (sound + vibration) in the Events view.


No notification was shown. Sometimes a notification was displayed rondomly.


(Please ALWAYS attach relevant data such as logs, screenshots, etc…)
I’ve tried to solve it by reinstall Aliendalvik, but no luck. I played around with the AndroidNofication App from openrepos, but also no luck. The app chrashes when started a second time after make the settings.

(Sorry for bad english, i’m trying)

1 Like

There may be hiccups with some apps but generally speaking, the notifications are not broken.

The screenshot is from my XA2 running

Same here - Signal works consistently and I do recall seeing notifications from the android store.
Does this only happen with blabber?

Hey guys,
I also have difficulties with the android notification. In my case the LED doesn’t turn on with apps like elements. The message is received, the notification at the top of the screen appears for some seconds and disappears again. In the past (with sailfish 3.4x this problem was not existend).

I have already reported this issue for version… It is still not solved yet.


I’m getting no notification on Incoming calls via Telegram. Anyone else?

Sorry for late answer, I’m very busy these days.
I’ve watched it again for a while now.
I can confirm, notifications from Android apps are shown in eventsview.
My problem is, I don’t notice them because the phone isn’t always in front of me. It will appear in banners at the moment of the event. If I don’t look at the display at the moment, I will miss the notification. There is no sound and the LED does not flash. That was different with SFOS 3.x.x.
I missed many of my messages, because I am not one who constantly looks at the cell phone, I need sound and LEDs.
I will open a Ticked on Zendesk.

Greetings from Thüringen, daniel

did day give you any solution?

No, the problem continues. Or better again. I had a workaround from Jolla Support. The file /usr/share/lipstick/androidnotificationpriorities to supplement an entry for my messanger blabber.im. That worked. The upgrade has reversed the change to the file again.

1 Like

Perfect!!! This workaround works perfect! This is exactly what I’ve been looking for!

In /usr/share/lipstick/androidnotificationpriorities I added the lines
Delta Chat;chat,chat_exists

And voilà: The notification on the lock-screen and the LEDs work perfect!

Thank you very much for sharing!


Do you know how can I identify in which package my Android App is? I want nextcloud talk to add it to lipstick. Thank you!

Hey Calinutzzz,

after installing you can find the app package name here:

in case of Nextcloud talk it should be: com.nextcloud.client

So the whole entry should look like this:

Nextcloud Talk;chat,chat_exists

Please do not forget to restart your device to let this change take effect.

Please give feedback if it worked!

Good luck!


Thank you very much! That was it!!!

Thank you. I created the same topic 8 days before you and get an answer only here)))

But I have all notifications but haven’t sounded.

how is the step by step of this process? I will love to connect Molly with lipstick. thanks

I cant really rewrite the file. I dont know how to do it, eventhough I am in root through my PC

How would I do this kind of entry for the Tesla app? It would be nice to have notifications about running the alarm or if charging would have stopped.

Thanks for figuring this out! :slight_smile:

I guess that you have ssh working and are logged in in terminal, right?.

To get root access, you would have used

To edit the file, use vi. It is the predecessor to vim, but works well enough. Copy & paste the last entry and edit it with the commands available in vim. For me this is the fastest way.

The command would be: vi /usr/share/lipstick/androidnotificationpriorities.

Go to the end of file with [G], then add [a] two lines (with enter). Press [Esc] to finish edit mode, use the mouse to copy and paste the last lines, use [x] to delete single digits and input [i] to edit the last two lines so you have your entry fixed.

I hope that this helps.

1 Like

Something strange is happening.
I have another Phone and now the Sailfish Version is, and I did the same thing and it is not working :frowning: Could it be something wrong in the Android Nextcloud Talk App? I do not remember which version I used before.
Do you have any hint what can I check more?
Thank you!

I’m having the same issue with Home Assistant but there is no package name in /android_storage/Android/media

Can I reference the whatsapp package instead and use that?

To find the package name, I used top from a shell on SFOS and stress the UI of the targeted Android app while looking top output to catch the CPU consumer.
The package name is the command name (ie. the COM. column in top).