Mastodon apps not working

I installed Tooter and Tusky (FDroid) again on my 10 III and logged in, but authorisation was not possible. The same with the beta aarch64 from Storeman. So there is no decent Mastodon app for the 10 III at the moment?
On the XA2+ ( they both work.

I have the same problem on my X10 II running Trying to remove these folders changed nothing:

  • ~/.config/harbour-mattermost
  • ~/.local/share/harbour-mattermost

I got nothing launching it from the terminal.

Edit: I uninstalled it and installed again from OpenRepos and this was successful.

Thanks for your reply. I tried all three Tooter apps. Some could not be installed. The aarch64 app can be installed, but freezes when I want to log in. Removing and re-installing does not help.

Not only Tooter fails on my 10III, Tusky also. ‘Verification impossible. Are you blocking cookies?’ it says when I want to log in.
I have no adblocker on my device, so what is the cause?

Just to be clear, is the tooter that’s failing now: Tooter β - aarch64 | — Community Repository System ?

I just tested this version and auth works fine.

Oh it’s my fault. I missunderstood and mixed Mastodon and Mattermost…

I tried all versions available and they all fail, also Tusky (FDroid). I cannot log in on my 10III, but no problems on the XA2+.

It took 3 tries (one was a typo:) but I did get a login and the 64bit tooter works for me on the xperia 10ii as well. The login screen, is, I believe, still in an ‘old’ webview and it’s REALLY unresponsive on the xperia. I’ll take a look at the code and see if it is indeed the webview and ask adel to update or make a merge request. EDIT, yes, it’s an old SilicaWebView. I’ll look at it.

I found the problem, partly. The settings of the browser were: ‘tell sites not to follow me’. I switched that off. Now Tooter beta aarch64 works, understandable, but in Tusky I still cannot log in.

Indeed, the buttons are not very responsive. Yet I hope that Tooter can be maintained.

I’ve forked, will implement a newer login screen and try to coordinate with adel | — Community Repository System to keep that version at least ‘usable’. Have you tried posting? I’ve only logged in and checked my feed on but not posted…

1 Like

There is some real legacy to the login process in this app. It includes redirection over a third party which is, frankly, not something I want to use.

Thankfully @flypig demonstrated how to do oath against the mastodon apis here: Sailfish Community News, 2nd December, Developer Docs, WebAuth … Now to implement it with tooter toot, di toot. Or hope @flypig beats me too it :slight_smile:

In any case, the ‘modern’ WebView works and it’s a lot nicer rendering.


In case helpful, i’ve found the Fedilab app works for me for accessing Mastodon on my 10iii. But it doesn’t involve the OAuth workarounds that @flypig discussed. So I’d love to see some of these other options work out too :smiley:

Tooter b works fine for me on 10ii except for there is not much going on on Mastodon. Are there international users at all?

Depends on the instance :slight_smile: I lurk a bit on which is quite active. Which mastodon instance are you using?

You may not SEE the OAuth2 flow in practice, but it’s probably there :slight_smile: In any case the tooter b version (also with my changes ) works by using the credentials (as app id/secret) of a third party. You just don’t see that. That should be changed. I’m just not certain yet if the amber web auth solution requires making a new app for EACH instance of mastodon. That would be a pita, indeed. Tooter solves that, if I’m not mistaken, by acting as a proxy. But, since I believe they also only use on id/secret, it may be that you only need to create the app credentials once. I’m pestering @flypig (sorry!) in parallel to see if I’m on the right track.

1 Like

It works now on my 10III, but as far as Mastodon works. On all devices it is slow at the moment because of a huge number of new people who dislike Musk.

I chose the first instance google popped up with, or sth… I registered some time ago and only now recognised there were different instances at all, which are not always interconnected. Don’t know much about mine, though. Maybe I try’ll try another one.

It’s a bit of work but if you have a language preference at the start it narrows things down: