Loses cellular network (until restart)

When you lose cellular network, what is the symbol at top right? is it a dashed “triangle” or a diagonally dashed square?

dashed square on my XA2.
German locale, it told me no SIM-Card inside and it will not work till next reboot.
Could not reproduce this, happens once or twice a day only since the last two weeks.

do we know what is the meaning of that dashed square? I have an XA2 and its cellular connection is rock solid, however another device unofficially ported has some connection problems and that makes me feel that might be a problem with the device partially and the tuning SFOS sub-module handling? Is there anyway to monitor logs on that?

Bad news for me: The cellular connection on my XA2 has disappeared completely (without warning)
It still sees my sim, but makes no connection, and finds no networks

Any ideas?
Has anyone else had this?

( apart from a) the radio is dead; b) reflash android and see)

I’ve got a similar problem on my Xperia X. Seems to be related to multiple SSIDs with the same name. Only a reboot fixes it, the network restart options in the settings loads/hangs for a few minutes and finishes without fixing anything.

when you losemobile connection, please check.your imei id, is it still displayed in system settings about page?

I have already reverted it to Android (and it’s still not working). In android *#06# does show IMEI’s

try to dial ##7378423## it will give access to more diagnostics, go to service tests and check the status of your device modules.


There is no option for anything like cellular modem under service tests (android 8.0.0)
It does say LTE/UMTS/GSM in service info->modes

not an expert, it is important to have an imei otherwise there is no chance to connect to a mobile network, check if there are tests that detect the sim card, another option is to try a different sim card preferably with a different mobile network, maybe change location if coverage is not that good?

Depending on the location I’m in it is either the one or the other. Being outside my country st the moment I see a dashed triangle.
Using the Sailfish Utilities does not help. I really need to restart the phone for it to find the network again.

Thanks for the suggestions. I think my conclusion is that the radio is actually dead. I do have IMEI in Android, SIM works in another phone, and it does see the SIM and identify my carrier. I just get no networks in android or sfos.

Cellmon was written to try and help diagnose this issue.

See if cellmon gives you any clues

I noticed that Cellmon does not update when it loses the network, for long or short periods.
i.e. it appears that the software stack (OFONO) stops responding/returning callbacks when the signal drops out.
It should be responding and telling you that the status is unconnected, or that the signal is zero etc. Instead the values just don’t change, and no callbacks happen.

This tells me that there is a bug in OFONO. It may not be the root cause, but even if the root cause is (say) in the cellular modem, OFONO should still be responding to dbus, and returning callbacks.

I also noticed that signal often drops dramatically at the moment when it has changed 3G<->4G. Then after a little while the strength climbs up. If signal was weakish (e.g 30%) then immediately after the change it might be 10%, then climb back up again.
However that drop seems to make the signal drop out sometimes, and then OFONO stops responding.


I’m starting to have problems with this as well: the phone silently looses all contact with the network, but indicates no problem whatsoever. It’s not until I try to make a call myself, that I realize I’ve been disconnected (sometimes the whole day). Though BT and WiFi still might work, the phone should indicate that it has lost all cellular network contact. I’m on a 4,5 year old Xperia X with 4.3.

It’s 2022 and I’m having the same issue. It seems like it doesn’t help to report the bugs in this forum. Does anybody from Jolla sees it?

My phone is the xperia-xa2. After updating to 4.3.0,12 it worked fine. But after a while, it was not able to reach the cellular network anymore. It may have to do with this:
Upgrading to 4.3: How/why to remove the “ofono-alien-binder-plugin” package?
This tricks did not work for me:
Resetting oFono settings to make mobile data work
This is the only solution I found:
Reverting Xperia device to Android OS and reinstalling Sailfish OS
If somebody knows an easier way, I would like to read about it.

Happens in Android Too? After a reslash too?

It reminds me the GPS issue (which is not yet found out if SW and/or HW).
Antenna contacts are fragile and IMHO not really durable if one intends to carry the phone in the pocket.
They get smashed and dirty. Contact may become bad.
If the cell antenna is on the same board as the GPS antenna, this could be a reason.
Try to open, clean and fix. I’d be curious if someone else can confirm.

I have this same problem in my nokia x20 running android. Where I work there is basically no signal, and every time when I get to my car and signal is great it is still hibernating in no connection mode. Once I didn’t check the phone and it was still not connected the next morning. For that problem, flight mode switch doesn’t work - only "use sim card “off - on”. But that is probably irrelevant - just wanted to say that hey it’s not only sailfish issue.

Same with a very weak reception quality on my N900 years ago.
Cleaning the contacts between the motherboard and the antennas solved it.
Again, these reports don’t exclude SW issues but bring perspectives.

(Xperia 10 II) I have the same issue since I started with the suomenlina version, still have it in the latest update (Vanha Rauma version). When are they going to fix this? I am in places where everybody using the same carrier has a strong signal and my phone is just dead for phone calls and sms. I know WiFi is important, but I still need my phone for calls and texts. Unacceptable.