List of application affected by SailJail

This wiki aims to list all applications impacted by SailJail :

Name Repository Solved Issues
Passilic GitHub No
Advanced Camera GitHub No No access to SD card
Fernschreiber GitHub Yes
Defender GitHub No
File Browser GitHub No - need help Can no longer show most files [if I can’t fix it I’ll have to remove the app from Jolla store]
Sailtrix Gitlab Yes
Storeman GitHub Yes - Sandboxing is disabled in 0.3.0
Nextcloud Talk Codeberg Yes - v1.0.0-alpha11 Accounts can not be loaded
ThemeColor Gitlab Yes - 3.0 Some file accesses, may not work. Otherwise OK.
SyncDings GitHub Yes - Sandboxing is disabled
Kuri Gitlab Yes - Sandboxing disabled Sandboxing is disabled, fix released as 0.4.4, package available on OpenRepos
FoilAuth GitHub Yes - Sandboxing is disabled
Sailfish-Connect GitHub Yes - Sandboxing disabled Sandboxing is disabled, fix released as 0.6.2, package available on OpenRepos
QuayCentral GitHub Yes - Sandboxing disabled Sandboxing is disabled, fix released as 0.5.1, package available on OpenRepos.

List of apps working under SailJail, but with all default permissions :

Name Repository Updated Needed permission
Mattermost Gitlab No Internet; Documents; Pictures; Camera
Olive goes shoppin’ GitHub No
Podcatcher GitHub No Internet
Working Hours Tracker GitHub No
Quickddit GitHub No WebView; Internet
Forum SFOS GitHub Yes
Pure Maps GitHub No Internet
Fotokopierer Chisel Yes Camera; Documents; Pictures
Battery Buddy GitHub Yes SailJail is disabled
Fahrplan GitHub Yes Internet; Location implemented.

If you want to contribute and fix yourself with a pull request, here are some example from other projets :

Related documentation:

15 Likes

Just a quick note that:
Fahrplan you noted (heh, I was quicker).
Tidings was updated today (I had a long window for path migration).
Machines vs. Machines also (had forgotten!)
Moremahjong (had a failed path migration, moved to noarch anyway, updated)

I think the rest are ‘clean’. Ha, ha, ha. I mean, in serious need of refactoring and proper care.

1 Like

I just tested “Advanced camera” and SD card seems to be accessible with default permissions. Anyway, it is nicer to request just permissions that are really needed… https://github.com/piggz/harbour-advanced-camera/pull/130 cc @piggz

There’s no music player working fine in sfos 4.4, except jolla media player. Unplayer, QuasarMX and DeadBeef don’t work, and editing .desktop file don’t fix it

soon i’ll modify Mattermost for SailfJail …

Small issue selecting the databasefile of harbour-ownKeepass, only possible at sandbox accessible locations (for example Documents folder).Even though the application is running unsandboxed, it can’t find all folders @ home.

1 Like

UnPlayer, TaleFish & GPodder work for me. My media is on my sd-card, and GPodder downloads its own media, but it all does work for me.

1 Like

Did you edit desktop file? If I do it, app disappeared. That happens to me with unplayer, quasarmx and deadbeef. My music is in sdcard, so I can’t use these apps.

Ok, I was using symbolic links, I solved by using full path.

But DeadBeef doesn’t work. If I open a folder, and add it to the list, when I open the app again, the list is empty

No, I did not. I only edited the .desktop file for storeman.
My sd-card isn’t encrypted. That might be the issue?

1 Like

I don’t think so, my sdcard isn’t encrypted neither

Unplayer works just fine here.

1 Like

Gpsinfo does not work for me when launching it from the desktop icon. It works when launching it from a shell. I suppose this is related to SailJail?

Should be. Are you using the latest version ( 0.15.0-1)? It adds SailJail support.

Thanks, I just upgraded to 0.15.0-1 from openrepos, but it is still the same: Gps is active. “Time to First Fix” is counting seconds. “Satellites in use/view” shows “0 / 20” all other measurings just show a dash.
EDIT: I notice that the only permission that gpsinfo asks for is “Location”. I use suplpatcher, so I need Internet too, I guess?
I added “Internet” to the gpsinfo entry in /home/.system/var/lib/sailjail/settings/user-100000.settings
but no change.

QuasarMX Pro seems to work correctly for me, though, without any modifications to the desktop file.

1 Like

Thank you for your comment! Yep, I noticed that QuasarMx and Unplayer don’t access to my music folder because I was using symbolic links. I changed to the full path: /run/media/defaultuser/… (it’s in sdcard), and now it works fine.

1 Like

Suplpatcher only works through SIM data internet. It doesn’t work with wifi.

I am aware of that and I do indeed use SIM data internet.

Now you that you mention it, I´ve used /media/sdcard/<…>/** as my music folder and that works fine.

1 Like