Jolla Tablet: no wlan after update

After updating my jolla tablet to Kvarken there is no wlan connection anymore. The symbol stays gray. I can switch it on or off, reboot the tablet, nothing changes.
I red the release notes that there could be an issue with restarting the tablet too early. So i waited for about 2+ hours while the tablet was showing the jolla and intel logo but nothing happend. Finally i switched it of and on again. Since then i haven’t any wlan connection.
Any suggestions how i can reactivate wlan

1 Like

Perhaps update to the latest version connected to the mobile data or flash the latest version if it’s possible.

… quick reply but it’s a tablet. No mobile data. I tried with a hotspot on my phone, but it doesn’t work either.

I think i had some luck with turning WiFi off and on again… or maybe it was airplane mode.
Eventually after some reboots it should also come back. So make sure to take the opportunity and update - i think newer versions has at least a most-way fix of it.

thx, several reboots fixed it. Now moving from Kvarken to Verla!

It’s got worse! After the installation of Verla i waited 4 hours (i was extremely patient) for the device to boot. It was just showing the Jolla and Intel logo. No changes after 3 times rebooting. Obviously i’m now forced to try the recovery mode.
I’m wondering why a Jolla tablet with just a few apps from Jolla Store, no Android Apps (except F-Droid and not using it), no Apps from OpenRepos or Chum, nothing special at all isn’t able to run an OS update smoothly. Any further suggestions?


I also have problems to connect my jolla tablet to my WI-FI. In this case, I have to reboot the device with airplane mode enabled, turn off airplane mode and then, my tablet is connected to my WI-FI automatically. Other way to solve this is removing saved WI-FI connection and trying to connect it again. Definitely WI-FI connection isn’t working fine in the jolla tablet since a few updates ago.

1 Like

After 4 times trying to enter recovery mode the tablet started normally. Now the WLAN problem is back!
I’ll try some more reboots maybe the WiFI connection will work again.

The Jolla Tablet is, at this point, only held together by a few lines of bug-free code. Pretty much everything else is broken in at least two ways. WiFi not working is a very common issue and rebooting endlessly occasionally solves it. Other common problems are refusing to go past the boot logos (rebooting endlessly occasionally lets you through), as well as telling you you’ve used up all of your lock code attempts (and thus locking you out of the tablet) when you haven’t even entered the lock code yet. Screenshots haven’t worked at all for five years and counting. I also noticed that, somehow, the battery consumption has now become so horrific that it drains all the way from 100% to 0% in only six hours, with the screen turned off, no applications running and no synchronisation services active!
It looks like Jolla will never fix any more Jolla Tablet bugs, except by accident, like the GPS fix in 4.5. All we can do is keep rebooting, rebooting and rebooting until we get arthritis from holding the power button all day long, until we finally manage to get into a somewhat working system to install the latest update and again be disappointed that nothing was fixed and even more extreme bugs were added. Surely someone at Jolla must still have a Jolla Tablet they keep up to date… But logic dictates that when Sailfish 5.0 is released (presumably the next update, or the one after), Jolla will simultaneously drop support for the devices on older kernels - Jolla C, Jolla Tablet and Xperia X.

1 Like

So what would be the ‘Last Good’ OS version for the Tablet?

1 Like

thx for this eye.opening report! I own my tablet since Jan 23 and had the naive idea it would work like the Phone. I’ll stay with Verla for a while now to see how the device behaves!

… with 3.4 I had no issues at all. but I’m not a long term user!

1 Like

I’d say it all went downhill once the screenshots stopped working. The last version with working screenshots was… 2.0. More than six years ago.

Good to know they are tracking this bug :wink:


Okay having gone half-way through the update cycle from a factory-reset Tablet, I can confirm that Wifi seems to work fine-ish on releases:

  • (factory image)
  • (first stop release)

(… although it forgets the password between updates/reboots)

And connection problems first perceived on where it does not want to connect.

Sorry if this is old news, it 's new news to me :slight_smile:

(Also, it appears to change MAC address a lot which is annoying when you try to maintain a fixed-ip dhcp setup at your LAN.)

Situation seems to improve a little by adding to /etc/wpa_supplicant.conf:



Also, this can help with the random MAC phenomenon, apparently.


OK, I think I found a workaround for the “ever-changing MAC causes password prompts every time” issue.

Following the guide at connman docs, create a file named wifiprovisioned.config ("file names must not include other

characters than letters or numbers and must have a .config") which looks like below, and configure your most-used wifi networks there.

(Keys and SSIDs have been randomized, don’t bother noting them, and use your own values!)

Description=static wifi config


Name=FRITZ!Box 7530 HK



You can take some of the values from existing configs at $CONNMANDIR/wifi_AAAAAAAAAAAAA_BBBBBBBBBBBBB_managed_psk/settings files, but note that not all keywords are the same! Especially not the use of semicolons (settings) versus commas (this config) for multi-value keys.

Now place them in the connman config directory.
Depending on SFOS release, this can be either one of

  • /var/lib/connman
  • /home/.system/var/lib/connman
  • /home/$DEFAULTUSER/.local/share/system/privileged/connman.

For my tablet which is currently on 4.4, the latter seems to work OK.

Possibly /etc/connman/foo.conf can also work, I haven’t tried.

Note that the file contains “plain text” passwords and things, so make sure you set permissions 0600 root:root. One might even do 0400 and chattr +i to be sure it stays put.

It’s quite possible that the SFOS Setting UI option of “Add network manually” does much of the same thing, but I haven’t tried that either.