Jolla Store has no apps installed after upgrade to 3.4.0.24

REPRODUCIBILITY: Happened once directly after upgrade, so far…
BUILD ID = OS VERSION: 3.4.0.24
HARDWARE: Xperia X
UI LANGUAGE: EN-UK
REGRESSION: Yes

DESCRIPTION:

Upgrade from 3.3 (.0.16, I think?) to 3.4.0.24 went smoothly. After the reboot, I opened Jolla Store only to find I had no applications installed. The apps were there in the app grid, however; the ones I tried did launch.

Thinking there was some glitch with the reboot, maybe some post-install things leaving the phone in an inconsistent state, I tried to shut down the phone again.

Shutting down took something like half an hour: around 10 minutes of “Goodbye” and another 10-20 minutes with red LED and black screen.

The next (cold) boot went fine, Jolla Store now listed my apps, but Storeman didn’t open, except from the Terminal, and was refreshing repos forever.

PRECONDITIONS:

STEPS TO REPRODUCE:

A bit hard to tell, you know.

EXPECTED RESULT:

Complete OS upgrade installed.
Installed apps visible in Jolla Store.
Working Storeman.
Shutdown taking < 1 minute.

ACTUAL RESULT:

It seems upgrade was incomplete, as version --dup installed a bunch of stuff.
Jolla Store did not show installed apps
Storeman never finished refreshing any repos.
Shutdown took half an hour.

ADDITIONAL INFORMATION:

May be related to this (which was for 3.4.0.22):

I did
devel-su
version --dup
reboot
as suggested here : Update 3.4.0.24 not working good - Remote keyboard in AD, Jolla apps, browser only black surface

This installed several things. (Mostly Python related, I think.) Then, Storeman worked as expected.

I hope things work from now on.

No, that didn’t last. Jolla Store still comes up with no installed apps at times. There is a brief blue message bubble saying severe problem with app registry, or something similar.

The version --dup may or may not be related; at least it does nothing, so whatever was missing has now been installed.