Update not working good - Remote keyboard in AD, Jolla apps, browser only black surface

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product):
HARDWARE (Jolla1, Tablet, XA2,…): Xperia 10
REGRESSION: (compared to previous public release: Yes, No, ?):


The Remote Keyboard does not show up in my Android apps since Is there any help?

Since the upgrade, I cannot update the “documents” and “notes” apps. I have tried to delete them and now, I can’t install them.

Now I have tried to use the browser and all I see are black surfaces instead of the webpages.


Update to





(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

1 Like

Try this:

Restart the phone. Then open the terminal and:

version --dup

Did it install any new packages?
If not, and if the problem persists, then do

ssu lr

and show the result here.

It has installed a TON of packages. Thanks, now I could install notes and documents, but the problem in Android still remains.

In the Android settings > Languages > manage keyboards, The Remote Keyboards is greyed out and I can’t turn it on.

I have the same exact problem. Even phone calls are not working. When someone calls me, the call does not trigger on my phone.
I have run
version --dup

But nothing else to install. Documents and notes can’t be updated and black screen on browser.

What can I do?


Download 3.4.0 and flash it.

:frowning: :disappointed:

1 Like


I’m trying to reflash but I get this error:

Detected Linux
Searching device to flash…
Found H3113, baseband:1311-2845_50.1.A.13.83, bootloader:1310-0301_X_Boot_SDM630_LA1.0_O_123
Found 1 devices: CQ3000VJMW
Fastboot command: fastboot -s CQ3000VJMW
Your device firmware version identifier is 50.1.A.13.83
Flashing boot_a partition…
fastboot: error: cannot get boot partition size

I downloaded binary from sony:

latest one. Is that ok?

I’m stuck here. Any ideas?

I’m currently flashing the phone again with my VERY old Asus eeePC 901. (fingers crossed)
Don’t know how that will be possible once usb2 ports will have completely disappeared…
This is my first upgrade with problems in Sailfish since version 2. :frowning:
Lost some data but not too much as I did a backup some days ago. What I’ll miss the most are my gpx tracks… some were for me important as Inka Trail.
thanks @jovirkku

I had the same issue, that the screen went black if I used the keyboard. Removing OKBoard and switching the keyboard-layout did the trick for me.

The second part of the solution came from pille with deleting an external keyboard helper.

did you ever resolve this? I am getting the same error on initial install on I3123

What’s your fastboot version? (fastboot --version) For at least version 30 the flashing script doesn’t work as-is because you need to use flash:raw instead of flash for the boot partitions. You can try doing it manually by flashing each partition by itself:

fastboot flash:raw boot_a hybris-boot.img
fastboot flash:raw boot_b hybris-boot.img
fastboot flash userdata sailfish.img001
fastboot flash system_b fimage.img001
fastboot flash vendor_a vendor.img001
fastboot flash vendor_b vendor.img001
fastboot flash oem_a SW_binaries_for_Xperia_Android_8.1.6.4_r1_v17_nile.img