Fingerprint record lost randomly

systemctl stop sailfish-fpd && sleep 10 && systemctl start sailfish-fpd

seems that here I have to wait for a while between stopping and starting, but no need to restart twice

3 Likes

On my device, fingerprints dissapear within several hours after boot up (I don’t write ‘restart’ because there is no restart option in the interface, only turn off).

It seems that the bug will not be fixed, at least nothing has happened for many months.

So, what could be the best solution?

  • to turn off and then turn on the phone several times a day.
  • to forget about fingerprints and to unlock by security code.
  • not to lock the screen at all.

Have you tried systemctl stop sailfish-fpd && sleep 10 && systemctl start sailfish-fpd ?
Also, do they disappear from the settings fingerprint list or do they just don’t work any more?
Did you check if /var/lib/sailfish-fpd/templates/ directory still contains something?

You can activate this in Settings > developper settings

This depends on you own security/confort taste :–)

I can not say what is best for you. Of course you can always restart the phone but I do prefer first this as I have developer mode enabled.

Perhaps someone could write a small patch or app to trigger the sequence, but it needs root access, so it needs more programming.

To summarize if you do not have developer mode enabled, then best is restart. If you have developer mode enabled, you can try the solution in the terminal after login as root (devel-su)

Have been without issues for a long time but just now my prints where lost again.
Had to run the restart sailfish-fpd twice as usual. I had planed to try the start/stop with some sleep but forgot.

There surely is a way to launch a script at boot like through the links in /etc/rc5.d/ on a linux box. The only question is how?
Please sailmasters, a tip?

On my XA2+ in 4.2 I can download fingerprints but unlocking with fingerprint never worked, not once.

I am sorry not to understand:

Do you mean record new fingerprints or copy the concerned files?

Sorry, I meant adding a fingerprint. I just followed the menu in settings. Maybe you can explain how it works and why it doesn’t work on my device? The code functions well.

I alas couldn’t explain as I am not a pro and also, causes can be multiple.
Hard to diagnose like this ‘on the fly’.

Though, to automate the restarting of the fpd service, you can make a script for this that auto starts at boot.
I had nice answers from members for my boot script in the thread here below.
You could easily adapt it to your needs:

However, I have no idea yet of how could this influence the system; battery consumption, for example.

Why do you want to run the script on boot?
That’s the only time you don’t need it, running it on a timer would be better. Or if the service is visibly failed like suggested before - changing the restart criteria. (I did not look into that further)

(EDIT: deleted to post as “reply”)
Yes. I was not clear. I meant: run a script which would mostly sleep and sometimes, restart the service. Script started at boot, automatically.

That’s the wrong way to do it - look for systemd timers instead.

Oh…ok, thanks, I’ll do some more searchings. Thanks.

Hi ric9k, thank you for your detailed answer!

I may only guess how I can try this. I really would like just to use the OS, simply out of the box. But it seems it is impossible, I already have had a lot of pain while installing necessary applications, not always successfully. For example, a native app QuasarMX simply failled to be installed.

Both. Sometimes I shut down the phone, turn it on, and all my three fingerprints are here. Today, I did this twice (fingerprints dissapear within one hour, shame), and in both cases I saw nothing in the Device lock menu.

Amazing. I would never have guessed to find an interface feature in the Developer tools section.

And again a rhetorical question: why is the reset button unavailable by default? Especially when users need to reboot the device daily to recover fingerprints.

Honestly, I did not expect so much pain from such a mature OS. I struggle at every step, from pasting phone numbers from the clipboard into Contacts to rebooting the device…

Love can’t be argued, I’m afraid.
I prefer 1000 times SFos than any dominant Os, despite the issues. But that’s very personal.
I began using Linux in like 1995 or something. So I was used to headaches… and finally cool results.

So… I regret not knowing how to help. :worried:

1 Like

still no permanent fix for this? Still exist on my XII 4.4.0.58

Its getting really anoying when it gets lost 1 time per week. And then when you cant put more fingerprints. Reeboting many times because rebooting once fingerprint doesnt come visible.

Removing all 5 and phone is good again for a couple of months.Then the circle starts over.

Would be fun to know it related to phone, sensor ot OS.

7 Likes

Indeed it gets annoying when it happens every now and then and at most even multiple times a day. Hopefully, we could really get some improvement on the matter.

Agree - I have to restart the fingerprint daemon from the command line as root:

systemctl stop sailfish-fpd && sleep 20 && systemctl start sailfish-fpd

Thanks everyone here for all of the useful feedback and workarounds for this issue. Inspired by your suggestions, we’re adding a button to the Utilities in the Settings app that will restart the fingerprint service, to help work around this issue in case you hit it.

It’ll take a while for the change to filter through to a release, but we’ll also be trying to address the underlying issue in the meantime.

8 Likes