Fingerprint record lost randomly

REPRODUCIBILITY (% or how often): 50
BUILD ID = OS VERSION (Settings > About product): 4.1.0.23
HARDWARE (XA2, Xperia 10…): Xperia 10 ii dual
UI LANGUAGE: English
REGRESSION: (compared to previous public release: Yes, No, ?):

DESCRIPTION:

Sometimes fingerprint unlock not working, the fingerprint record is lost, need to recreate. After a few moment later, the fingerprint in device lock show 3 records, but i remember there is only 1 after I recreated

PRECONDITIONS:

STEPS TO REPRODUCE:

EXPECTED RESULT:

ACTUAL RESULT:

ADDITIONAL INFORMATION:

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

11 Likes

Can confirm, just had it happen to me.
After trying to add back my 3 primary fingers, the 3rd/6th one could not be stored, and after that the first 3 that were gone had re-appeared making it a total of 5.

Had it not just been in the management menu, it would have been manageable (heh), but as stated above, it affects the ability to unlock as well.

3 Likes

I can confirm this from my own experience. All of a sudden, the fingerprint of my index finger disappeared. I then deposited the fingerprint of my thumb. And all of a sudden both fingerprints were available. But just now they are both gone again. Even a reboot did not bring them back. I have now added my thumbprint again.
Edit: Now I have all my 4 earlier added fingerprints back. Is there a way to display the already recognized fingerprints in the “Device lock” dialog again?

3 Likes

The same thing happened to me.
Just like the other.

3 Likes

Just chiming in to say it also happened to me. So far, luckily only once. Is everyone experiencing this problem using the Xperia 10 II?

3 Likes

Thanks for the report. This is in our internal bug tracker as well.

4 Likes

Any ideas for workarounds or manual reset?
I seem to have lost my 3 first fingerprints permanently, and then ran with 2 for a while… but now nothing works (and it is out of space, or rather saying that it can’t read).

So far either trying to add a new fingerprint, or reboot, or reboot + trying to add a new fingerprint has always worked for me.

1 Like

Shutdown+boot made them come back, i had only been rebooting.

1 Like

found in an old topic: Fingerprint sensor stops working after adding fingerprint - together.jolla.com

systemctl restart sailfish-fpd

and my fingerprints are back :-), without an reboot

5 Likes

Thanks!
I thought i tried that… but it does indeed work.
Now i can turn locking on again without going mad. :slight_smile:

It doesn’t work for me, I need to restart my phone.
I can’t believe that this issue happens to Xperia 10 II as same as happened to my old Xperia X, I hope that Jolla fix it, it’s very annoying

I had it happen yesterday again, and the fpd restart didn’t do help. But a second fpd restart did. Reboots fixing it hasn’t been 100% for me either, so thinking it is similar.

Hi,

This happened to me 5 times as well on Xperia 10 II dual. I’ve been trying to reproduce the issue since the first incident. This first happened on 4.1.0.23 for 2 times, and 3 since updating to 4.1.0.24.

At first I just blindly add those back and in the 3rd time I’ve experienced the problem and tried to register fingers I’ve got the “Cannot add more fingerprints” or something along those lines, after reboot I’ve saw 5 registered fingerprints, previous reboots didn’t fixed the issue for me…

Not sure if it will help much, but I’ve somewhat managed to get down to the following sequence with which for the 5th time it took a week to make the phone “loose” the saved fingerprints then suddenly get them.

  1. Fail to unlock the phone with the registered fingerprints until it only allows passcode (this may need to be repeated, for the 4th time it took 5-6 of this screen, for the 5th one it was only 2)
  2. Check if fingerprint has been removed from the saved list. (sometimes reboot brought them back).
  3. Add new fingerprints.
  4. Use the phone until it stops accepting fingerprints again (this should happen without reaching the “too many attempts” screen)
  5. Check if duplicate fingerprints show up, if not reboot until they do.
  6. Remove the duplicate entries.

This did work for me, after I noticed the background window asking for the security code.
After that my fingerprint list where populated again.
Still no clue to when they disappear though.

OK, i restarted it like 5 times in a row and it worked!

2 Likes

Isn’t that only a temporary remedy?

If you mean adding new fingerprints when they disappear, then yes.

What I wanted to highlight is that you can and will get back the first saved set of fingerprints without reboot if new ones are added. Though, they cause problems later (step 4).

1 Like

It would be great if the issue could be solved at all. Fingerprint unlocking works only a few hours after re-activating it on my 10 ii.