[changelog] Pallas-Yllästunturi 3.4.0

This post contains the detailed changelog entries of Sailfish OS update compared to

Since the log is too long for forum.sailfishos.org to understand (as html), we have attached it as a simple text file for you:

Changelog_from_3.3.0.16_to_3.4.0.24-FINAL.txt (258.8 KB) [Updated on 2020-10-08]

The corresponding release notes are here: [release notes] Pallas-Yllästunturi 3.4.0.


WOW, tldnr…
Tons of updates… I am very impressed… Keep on doing this good work.
It think the jolla team should keep on doing good an talk more about it!


Thanks for all your work. Update installed with no problems except I had to reinstate my fingerprints. The new user functionality is very nice.

1 Like

Just luv this. Wonderful.

Maybe I missed it in the changelog, but is the issue solved where the calendar from a Google account is not synchronized correctly? See also here --> https://together.jolla.com/question/226821/google-calendar-sync-fails/

So, cutes-js not restored. So, no quickfilebackup. So not for me.

1 Like

For me the Google calendar works. At least for now.

Very smooth install/upgrade! Had no patches installed and enough space on the system storage partition.

Still we can’t make albums in the Gallery. Maybe this can be added soon…

The option to allow untrusted software is unchecked, and even if I accept the terms, it remains unchecked. In addition, Storeman isn’t starting, because libsolv.so.0 isn’t found. libsolv0 is installed, but provides libsolv.so.1.

As mentioned in another thread, login via ssh, uninstall Storeman, reinstall Storeman and it should start again:

ssh nemo@sailfish
pkcon remove harbour-storeman
pkcon install harbour-storeman
1 Like

Thanks, that worked! Just had to do a pkcon refresh as well before it could find any packages. I’ll try to be better at searching the forum next time.

Anyone tried updating via ssu?


ssu release
version --dup

But didn’t work. Says No Distribution Upgrade Available.

I’ve always updated that way, as my phone doesn’t detect new versions via the UI

Thanks for this! Absolutely amazing work and there are so many changes.

Issues I have found so far:

  • Update forgot my Wifi networks. (maybe it’s good to clear it time to time, but it’s inconvenient)
  • Android:
    • closed apps get black background on the desktop and no app image (when you press “back” in Whatsapp to close it for example). They had transparent background and the app icon before.
    • orientation lock isn’t synced to the Android (at least when aliendalvik is online). Though, this has not worked for me ever.

Things that do work, which I verified for my self:

  • In contrary to @0xb I didn’t need to setup fingerprints again. They don’t work for the first lock screen after bootup, but I think that was a feature.
  • Google calendar works now (didn’t work before the update).
  • Browser: seems to work faster than before. Thanks for this! At least some sites work better than before (I assume the JS engine got an update). Some GDPR cookie banners were unfunctional before :frowning: - Thanks for this so much :heart:
  • Android: I tested most apps I use and they seem to still work
  • optional install: Google Play Services, e.g., notifications, seem to still work nicely (my install instructions for those who are willing to lose privacy for better integration for some apps).

p.s. would it be possible to add support for a second squashfs image for the aliendalvik? I’m not yet sure if that would be even possible, probably not. It would be amazing if there was a way to make the Google Play Services an installable package, instead of modifying the official image. Would make it easier for not-so-techy people to get that working too.


The Alien Dalvik Changelog seems historic due to the new package names it dragged in all changes ever made to Alien Dalvik I assume.
Makes it a bit harder to see what really changed.
Hopefully the release notes will be a bit more clear on this.

1 Like

Storeman does not start after update. Anybody experiencing a similar issue?

Seperate topic for storeman already, better check and post there.


1 Like

Android support is not functioning, whatsapp, Firefox etc. are not launching. Xperia X…

No issues with 3.30

That’s no task for SailfishOS. It is a task for Whatsapp & Co. to create working apps - w/o blocker against aliens.

Thanks for the nice update please note though -

  • [Python3] Drop sqlite to ease up bootstrapping.
  • [python3] Package sqlite in a separated package.

The python sqlite change is major and breaks a ton of apps while not allowing us to fix it with dependencies or notifying us ahead of time.


I don’t think it’s up to Android software to be updated and keep running when the android emulation changes on Sailfish.

Anyway, hte functionality was restored in my case by manually installing/removing/re-installing (already uninstalled aliendalvik control)