[changelog] Pallas-Yllästunturi 3.4.0

For me
mobile -> Google: works
Google -> mobile: fails

I have a fresh flashed 3.3 updated to 3.4.

same or me:
mobile > Google: works
Google > mobile; fails
edit event on mobile: Event disappears on mobile, changes shown on Google
edit event on Google: still ot syncing to mobile
flashed fresh from 3.3 to 3.4.0.22

1 Like

There seems to some issue with patches which causes the screen to blank after activation.

On a freshly flashed system:

I installed Patch Manager but no patches.
Installed “Battery Overlay”

On activation of Battery Overlay, the screen blanked.
On reboot, Patch Manager autostarted Battery Overlay and blanked screen

Did you solve this issue. I have this also with a fresh upgrade to 3.4. I cannot install OpenRepos as it is missing libsolv.so.0

Yes, the Storeman problem was solved, see this post.

Error when reinstalling Storeman after remove: nothing provides libsolv.so.1 (Sfos 3.3.0.16)

Check this, please: [instruction] Storeman does not start on SFOS 3.4

(and it is not recommended to discuss issues under a changelog post)

1 Like

Do a pkcon refresh, that will solve the issue.

My problem was specifically with “overlay” apps, which make the device unusable because the screen is dark. The author of Battery overlay has placed a warning on OpenRepos for all his patches/overlay apps warning not to use on 3.4

This is a bug and it is reported AFAIK

I did. No success. Plus some useless characters.

Try downloading the rpm here https://openrepos.net/content/osetr/storeman and manually installing the rpm. That lists different builds for different Sailfish OS versions.

Apologies - I forgot to clean it up. Namely, Android App Support was split into components in a different way. While doing this, the version number of aliendalvik package was restarted from 1.0.0. For OBS, this appeared as a reversion although it was just a change in the version ID.

The new division:

  • aliendalvik is a meta package only there to get dependencies right
  • aliendalvik-system contains the system parts of Android App Support
  • aliendalvik-configs contains the configurations and scripts for Android 8 based Android App Support

The new packages, aliendalvik-system and aliendalvik-configs, appear in the last section of the changelog, under “Packages added”.

The corrected changelog of 3.4.0.22 has been added to this post.

7 Likes

The changelog from 3.3.0.16 to 3.4.0.24 published.

1 Like

Help sir, i recently reset my phone and am on 3.4 but cannot install google play store using the instructions on https://together.jolla.com/question/217178/baseport-8-for-x-if-its-only-about-flashing/ using the automated script but the terminal keeps telling me permission denied despite being root, how can i get around this. PS: im not using linux on my pc.

I used sfos-upgrade from OpenRepos via ssh. Worked for me.

I presume the link is wrong, as it doesn’t include instructions. However, my best guess is that you forgot to make a file executable as that returns “permission denied” too. (In details, Linux has three permission read, write and execute for owner, group and all. Being root just makes you owner in a sense, but if the owner doesn’t have execute permission, then they will still receive permission denied.

My own guide expects basic level of Linux skills, which is the reason I’m hoping to get this done as an installable app at some point. I hate when installation needs to run shell commands from the Internet, specially if the user doesn’t understand them.

Thank you for taking the time to reply sir.You are right i attached the wrong link, my bad. https://together.jolla.com/question/205890/howto-install-google-play-services-on-baseport-8-devices-from-the-phone-itself-tested-working/. I used the install open gapps script made to be run within the phone via x terminal.