Browser crashing a lot since update to 4.5 - playing YouTube

HARDWARE: Sony Xperia 10 III - xqbt52 - xqbt52 - - aarch64
UI LANGUAGE: Polski (user: pl_PL, os: pl_PL.utf8)
REGRESSION: yes (since: - aarch64)


The default SFOS browser has always been less stable than Firefox on Android for me, but problems were occasional. But since update to 4.5, the crashes have been so frequent, usage is extremely frustrating. This doesn’t seem to be related to missing codecs, that were fixed in the latest pointrelease, it has been crashing both before and after.
Even after I closed most tabs, cleared cache, turned off Android compatibility layer to make sure it is not the lack of memory. I can easily crash it with more than 1.5GB of free RAM on my 10 III. Only thing I haven’t tried yet is clearing cookies, but I don’t want to relog in to all websites. But I guess I could try that.
It happens with Twitter too, but the highest reproducibility rate I have with YouTube, so let’s focus on that.


  1. Play YouTube video
  2. When the video comes to the end, there is 70% chance it will crash for me
  3. Double tap to skip, or sometimes even using the bar at the bottom causes crashes too
    If I get an ad before video, it will crash at the end of the ad, and after I launch the browser again I will get another add, causing another crash…


  • Patchmanager: yes
  • OpenRepos: yes
  • Chum: yes
  • Other: none specified


Device Owner User: defaultuser
Home Encryption: enabled

the initial version of this bug report was created using Bugger 0.10.5

I’m wondering if it’s not the same issue as this one: Browser crashes on visit to website

1 Like

I often have the problem with YouTube that the browser crashes because of the advertising

I have no ads and it still crashes between videos sometimes.

1 Like

I’ve noticed that my browser frequently crashes on my 10iii device, which wasn’t the case with the previous release. Interestingly, I’ve not experienced similar crashes on my XZ3 device (which was community ported to SFOS 4.5) when visiting the same websites.

It seems like the issue might be specific to the 10iii, unfortunately.

1 Like

I get a ton of crashes, when trying to skip forward or backwards, random crashes when just playing it, crash at the beggining, and a lot on different websites. Above I just described the time when I am getting them 100% of the time. Hope it is one issue for all of them.


Browser crashes are much more frequent on 4.5 than ever before. I also get crashes of the Android support (as a whole) which wasn’t the case on earlier OS releases.

1 Like

Browser crashes often, mostly when reading text and scrolling it. If finger movement goes too slow and/or finger remains touching the screen, browser crashes with guaranty.

This bug remains since years and is often reported by many users and not fixed by Jolla, so I already lost any hope that Jolla ever will fix it.

Therefore my question - does anyone know what causes this bug? Is there an option to tweak something in the browser’s settings ? (also experimental) Is there an option to get influence to the apparently failing memory management of the browser?

It’s really annoying and it doesn’t help much that the browser does this and that a little bit better than before the update as long as the browser crashes in, say, 10 % of pages one wants to read peacefully but have always to fear will it crash in the next moment, or not yet, but then in 2 minutes…

This browser bugs are inacceptable, and because I see absolutely no hope that @Jolla will fix it, therefore my question to the community: What can one try himself to make it better?

Experiencing same problem, sometimes it crashes with other websites also. But more often with YouTube, especially when trying to fast-forward the video. @Jolla please fix! will almost always crash the browser before it even completes loading.

1 Like

Tested right now and loads quick and animation runs on Volla / after applying some tweaks described here:
My wishes of the next release: just fixup, e. g. the OOM-killer situations - #17 by Seven.of.nine

Disclaimer: I found this tweaks much more guessing that knowing what I really do, so no guarantee, do at own risk. Reports what came out and if it helps very welcome!

This is the complete list of tweaks:
Browser Tweaks Summary

Settings are in about:config, some of the apz settings look promising, like apz.touch_start_tolerance.

Please give these settings a try and report back what values you prefer.

apz.axis_lock.breakout_angle 0.392699 → 0.4
apz.axis_lock.breakout_threshold 0.03125 → 0.03
apz.axis_lock.direct_pan_angle 1.0472 → 1.05
apz.axis_lock.lock_angle 0.523599 → 0.53

apz.content_response_timeout 150

apz.pinch_lock* (3 settings, all original 0.03125) 0.05

apz.touch_start_tolerance 0.1 and remove the f - edit: 0.04

browser.cache.memory.capacity 2048

general.smoothScroll off
general.smoothScroll.* partly on → all off

ui.click_hold_context_menus off
ui.click_hold_context_menus.delay 300 or 200

apz.fling_accel_base_mult 1.125f Has ‘f’ !!
apz.fling_stopped_threshold 0.13f

device.sensors.motion.enabled off

service.settings.last_etag “longNumber” (with quotation marks)
while all other variables there have no quotation marks. → removed them,

apz.drag.enabled on → off
apz.drag.initial.enabled on → off
apz.drag.touch.enabled on → off
apz.enlarge_displayport_when_clipped on → off

accessibility.accesskeycausesactivation on → off
accessibility.browsewithcaret on → off
accessibility.browsewithcaret_shortcut.enabled on → off

dom.vibrator.enabled on → off
dom.vr.oculus.enabled on → off (don’t have a oculus VR)
dom.vr.oculus.invisible.enabled on → off
dom.vr.poseprediction.enabled on → off
dom.vr.require-gesture on → off

1 Like

that site works fine with me, the browser still crashing on some other sites tho.
ps 10iii with latest update, plain browser, no customisations.

Ok, I only did:

browser.cache.memory.capacity 2048
general.smoothScroll off
general.smoothScroll.* partly on → all off

And now it does not crash immediately. There are artifacts in the video rendering at the top of the page, but it does not crash. Hmmm.


Oh my, disabling smooth scroll makes scrolling so much better! It now behaves just like Firefox on Android, much less janky. Opening image in a new oage and viewing the image is not as broken anymore too.
Unfortunately with your settings, I can still crash it in a few seconds when I try to fast forward or go back by double tapping on Youtube.

1 Like

I tested and tried to verify and result was, that tapping on the timeline does nothing but dragging the pointer to the desired position works.

I believe it’s the same one. I’m not adding a new item for this in our internal tracker, but instead just link the old issue to this one.

1 Like

Hi, if I tap on a yt-link in Signal, the advertising is shown, but then the browser-app closes. Every time on, Xperia 10 III.

One recurring kaudit:

Jun 28 15:53:33 Phone22 kernel: (0)[183:kauditd]audit: type=1701 audit(1687960413.706:374): auid=100000 uid=100000 gid=100000 ses=1 pid=9444 comm=“codec_looper” exe="/usr/libexec/mapplauncherd/booster-browser" sig=11 res=1

and when it crashes (literally every video at some point, but mostly on changing from one to the next):

Jun 28 15:55:36 Phone22 kernel:  (7)[9795:mali-utility-wo][ION]ion_client_destroy:hdl=0000000027b2e2da,buf=00000000394556dc,sz=868352,ref=5,kmp=0, client=9769,disp=9769-0,dbg=gralloc
Jun 28 15:55:36 Phone22 kernel:  (7)[9795:mali-utility-wo][ION]ion_client_destroy:hdl=00000000aec188a8,buf=00000000c564d024,sz=868352,ref=5,kmp=0, client=9769,disp=9769-0,dbg=gralloc

But that seems device dependent to me. When I put the crashed browser back in focus I get a huge kworker dump that starts like this:

Jun 28 15:57:17 Phone22 kernel:  (4)[6737:kworker/u16:11][DDP/ddp_manager]--> check status on scenario primary_disp
Jun 28 15:57:17 Phone22 kernel:  (4)[6737:kworker/u16:11][DDP/dump]== DISP MMSYS_CONFIG ANALYSIS ==
Jun 28 15:57:17 Phone22 kernel:  (4)[6737:kworker/u16:11][DDP/dump]clock on modules:ovl0, ovl0_2L, disp_rsz0, rdma0, wdma0, color, ccorr, aal, gamma, dither, dsi0_mm(cg), smi_common(cg), smi_larb0(cg), smi_comm0(cg), smi_comm1(cg), dsi0_interface(cg), 

@vige is this kind of info of any utility? I fear it’s too mixed with device specific stuff.

That last one is irrelevant. It’s periodic. Running angelfish without errors I still see this in the background.

I’m not an expert in this area, so I have no idea. But I’ll forward the information anyway.