Bricked Xperia X after update to 3.4.0.24

Xperia X updated to 3.4.0.24 no early access, update stop saying “Sailfish could not be upgraded. please try again later.” After reboot… Sony logo and then 3 white flash screens and nothing more.

I havent patches or phonebook installed.

Its my main phone, what can i do?

Thanks.

1 Like

I’m having the same problem here on XA2. What I gathered so far is to SSH into the phone. But then what? What I tried so far: uninstall certain packages

  • pkcon search name [PACKAGE]
  • devel-su pkcon remove [PACKAGE]
    harbour-storeman removed OK
    aliendalvik-control showed two installs (!), first one removed easily, second one gives an error

On the Telegram group I found a comment from Andrew Branson:
You can boot into recovery mode. Then you can remove the aliendalvik-control-edge service or executable. that should fix it enough to be able to boot up normally. you’ll have to force uninstall aliendalvik-control with scripts disabled
because there’s an error in the uninstall script of 9.3.0-1. you might even have -1 and -2 installed together because of that.

On October 1, abranson posted how to uninstall in this thread:

devel-su
rpm -e --noscripts aliendalvik-control

Underneath, a post from M.R.I showing a script. After
pkcon update
a lot of things installed, and the phone is back alive

1 Like

Same here… I read too much info but is for average users.

I updated my post. Follow the thread mentioned. If you join the Telegram group Sailfish OS Fan Club, there are people most willing to help with specific problems.

Thank you for the tips but I have a problem entering to sshd

I enter to jolla recovery 2.0
Option 5) Run sshd
Type your devicelock code and press [ENTER] key:
(please note that the typed numbers won’t be shown for security reasons)
Device /dev/sailfish/home doesn’t exist or access denied.
Device /dev/sailfish/home doesn’t exist or access denied.
[OK] Code accepted.
Starting sshd on 10.42.66.66.
Login: xxxx
Password: xxxxxx

Press [Enter] to stop sshd…

Cant enter any command.

If use option 3) Shell

If you continue, this may void your warranty. Are you really SURE? [y/N] y
/dev/mmcblk0rpmb: read failed after 0 of 4096 at 0: Input/output error
2 logical volume(s) in volume group “sailfish” now active

Device /dev/sailfish/home doesn’t exist or access denied.

Type your devicelock code and press [ENTER] key:
(please note that the typed numbers won’t be shown for security reasons)
Device /dev/sailfish/home doesn’t exist or access denied.
Device /dev/sailfish/home doesn’t exist or access denied.
Device /dev/sailfish/home doesn’t exist or access denied.
[OK] Code accepted.
/ #

And no more, cant enter commands, any clue?

Hi,

for me it’s the same problem. After updating to the official Sailfish OS Pallas-Yllästunturi (3.4.) today my XA2 shows also 3 white flashing screens and nothing happens.

How can I resolve this and how can I connect via SSH into my phone than it doesn’t start?

Thanks.

Had the same issue with “Try again later”. Phone restartet and was not update, even after some retries. For me tool “sfos-upgrade” worked and the update finished successful.

I still cant use my phone, cant access to telegram so my hopes are this forum, it seems that it is a mistake that affects many people but all the fixes are explain for people that have a average use of linux terminal.

Maybe im stupid but i cant even connect to ssh.

OK I re-explain all…

I can boot into recovery mode, if you read the post up there I can get the recovery menu but sshd or shell doest response. Please I get out of ideas, some help ors welcome.

I have just updated my xperia X to 3.4.0.24 and after reboot I got black screen just a few seconds after system already booted. When arriving new messages their pop-ups displayed corrrectly though.
I connect to it through ssh (not from recovery but as usual ssh nemo@ip_addr) and remove storeman:
pkcon remove harbour-storeman
and it helps for me.

2 Likes

@bovus

So I dont need recovery mode?
Just with putty and nemo@ip adress?
How to know the ip adress?

1 Like

If you try to connect through WLAN, it is the IP given to the phone by the DHCP of the access point, or if you are trying the USB-cable, the default is 192.168.2.15

More info about this in at least these articles:
https://jolla.zendesk.com/hc/en-us/articles/202011863
https://jolla.zendesk.com/hc/en-us/articles/202004823

Phone dont boot, these links are for a phone that works.

Then recovery mode is your only option. Are you sure the phone doesn’t boot at all instead of booting, but the screen staying blank?

Screen is black but not turned off

happend to my xperia xa2 ultra too. phone is now bricked: it boots, shows the sony logo, screen blinks 2 times or so and then nothing, the phone stay black.

how do i get into this famous recovery mode everbody here talks about?

@strobovalo
You can find IP in your router config, like “device lists” or “dhcp settings”. Then connect to it by nemo username and password, you previously enabled in developer mode section and ssh.
If you cannot boot the phone or connect to it, your only option is to reset to defaults by recovery mode, could you try this?

@bovus

Yes i know my phone is bricked cant access to wlan, by the way is now with factory reset and 2.x version, los many things but at least works.

Thanks to all for help.