Beta VoLTE on the Xperia 10 III, disabled by default

You are not exactly on topic… but the answer is that you can’t. There appears to be no plans for the older devices.


Yesterday I noticed that VoLTE was enabled on my 10 III and I have not enabled it by running dbus-commands. Fortunately Elisa-FI works fine with VoLTE but I could not find a note from the release notes that it may be activated without user interaction.

Maybe you activated it using the UI, there is a button for it now.

Not very important seen the glitches that still need ironing but will there be a VoLTE icon ;-p


To check registration status, or for what?

That would be nice indeed.

1 Like

Who needs an icon, you notice if it works, when you call someone who also uses VoLTE you have no ringing tone, that indicates that everything is fine :laughing:


Oh that is why I don’t hear a ringtone sometimes haha good to know.

Yes, an icon shows you the status of a function. Like 4G or 3G which I think is quite handy. Some prefer to launch a terminal and send the commands to check on the status but I’m not one of them and thus I’d be happy with some kind of info. Why would we have a 4G and 3G icon if that wasn’t useful? Following the logic of what for even these two could be left out.

But as I said, the folks at Jolla have way more important stuff to do as to implement an icon for a feature that is in beta testing.

Sure an indicator would be nice. If you want to check the status you could install Netmon Volte checker from openrepos.

1 Like

I’d find a volte indicator useful. Maybe even more so on the incoming call notification. That way I could see if the device had fallen back to 2g before I answer. That service has degraded so badly that calls range from difficult to impossible to communicate anymore :frowning: If I knew before answering I could reject it and call back when I knew I’d be able to talk.

That said, I find I can slide the call notification over and peek at network status to see if it still says 4G while ringing. Not a perfect workaround, but it reduces my wife’s complaining about my ‘nerd phone’.


Isn’t it just better to let the regular technology indicator be visible then?

Girls and guys, the idea about the icon was just that, an idea. Some people like icons others don’t.


I don’t know if its the case with Xperia III too, but i realized, that with Xperia 10 II,
sometimes with Volte enabled, it is not possible to send a normal sms, if you deactivate Volte, it will work again. Maybe its just my provider, or a bug that would be great to solve. Thanks really much in advance! :slight_smile:

It can be a different issue, but I couldn’t send SMS messages at all (disabling VoLTE or visiting flight mode didn’t help), only reboot fixed it. X10III here with

On my 10 III it happens from time to time, I’d say at least once a week. What always helps is switching the network setting in Settings / Mobile network from “4G preferred” to “2G only” and then back. The SMS message gets sent instantly and then it keep working until “the next time”.

IIRC I tried that, too. That was the first time it happened to me.

Can someone from Jolla tell us if there VoLTE will ever be available on the Xperia 10 Plus?


if my provider (on paper) supports VoLTE but I can’t get it to activate on SailfishOS, is there any way I can fix this? Would be nice, because I fear my provider will shutdown 3G in 2024… :frowning:

Yes, there may be ways, but it depends on many factors including your provider’s configuration and the device you’re using.

The first thing is to check the VoLTE provider support page and see whether your provider is listed.

Some have additional instructions linked from there and in particular, many require you to follow the instructions on the filling in the gaps page.

I would say those are the two best places to check first.


Thank you for these hints!
But I don’t quite understand: on the one thread it gives a tutorial what to do when it doesn’t work but somehow this only applies to an Xperia 10 II. (which I don’t have). Is there also a way for the Xperia 10 III?

Because I checked with getprop persist.vendor.somc.cust.modem0 and mine (S139.1) is not in the list. I just don’t quite understand what I need to do next.