Before installing Sailfish

Hi all.

I want to try Sailfish OS. If it proves convincing, I’ll go for a licensed version. So I bought a compatible device: an XA2 Ultra (H3213) that has been preowned and factory reset.

My problem is it has Android 8.0.0 installed and I should be having Android 9.0 before installing Sailfish.
So my questions are:

How do I switch to Android 9.0? And I guess I better should make a backup before doing so; how do I do this?

Notes: my knowledge in Android is limited. I have more easily access to Linux PCs than Windows. As per instructions, (1.1.4 olf / SailfishX on Xperias · GitLab ), I did not set any network capabilities on the phone.

Thanks for reading

1 Like

Welcome!
Although being a linux user, I don’t know how to flash Android from it. Most people use Emma in Windows.
I wouldn’t say you need to backup if you did a factory reset and have no personal data into it as you can always reflash Android.

Here can you find the official instructions for installing from Linux:

Here is about the Windows flash tool for Android

If you unlock the bootloader, you will loose some DRM partitions that will not be recoverable.

You can find lots of informations if you search for “install SFOS”, “DRM”, and so on… in the forum search engine.

1 Like

1. Skip the Android update

  • It is not necessary to update your device to the latest version of Android. You can skip the update if prompted.
  • Both Android 9 and Android 8.1 are now okay as the starting point for installing Sailfish OS 3.2.0 and later releases. Do not update to Android 10 in case it is offered. You can see the Android version in Settings app > System > About Phone.

Update OTA, (Settings > Update)…

One reply for these 3 posts:

Hello @Levone1. Thanks for chiming in.
In settings>system>updates , it reads “android 8.0.0. system is up to date”. (in a foreign language, it’s approx translation)
I suppose it is related to the fact this phone actually has no connexion (either wifi or cell) as advised in point 1.1.4:

Choose No , Off , Cancel , Skip , Disable , Dismiss , Decline , Deny for really everything during the initial setup:
Google account, WLAN, Bluetooth, GPS, Mobile network, Sony support, device PIN and fingerprint

Should I enable wifi?

Hi @Bellini. Thanks for your answer.
Still, I found 2 docs. One saying it requires Android9.0, and the other one stated, like you, that 8.1 and 9.0 are OK.
But still, I have 8.0 installed, so I dont feel secure, doing so. Also, if something goes wrong and I’m asked what I did and say the fact I get an answer along the lines of “you didnt match the prerequisites. You’re in uncharted territory. Good luck”. I’d hate that so I will update at least to 8.1 but would prefer going to 9.0.

Hello @ric9k

Thanks a lot for the links and the backup information.
I’ll find a way to put a hand on a windows machine soon.

Depends of how important is privacy for you. This guide is more so oriented and the Jolla one is more standard but also works; Your call. If you care, I suppose it’d be better to follow @olf guide and flash instead of making an OTA upgrade.
In the other hand, if you later encounter problems into SF, it could be useful to know if everything was working before, under Android, as said in Jolla guide.
I personally didn’t test anything under android as I couldn’t wait to see SF in action. And all went well.

2 Likes

Reply above says that you can flash SF either from 8.1 or 9.0, but you’re on 8.0. Seems like you need to update. If you’re really worried about it, I guess you can manually flash ftf with Flashtool or Newflasher, but seems to me not mich to worry about by connecting to wifi for one system update and wiping everything …

2 Likes

thanks again, @ric9k and @Levone1

I switched wifi on a couple hours ago, but it still doesn’t show system update:
It states that my device has the latest updates, with a link to support.sonymobile.com/update which is clearly deprecated.

Do I need a google account to be able to update Android? (I dont, atm)

No, but the bootloader needs to be locked.

1 Like

I figured since you got it with Android on it, it probably was stll locked… OTA won’t work on unlocked bl. You could chexk with service menu, (I think it’s ##7378423## - then Service Info > Configuration > Rooting Status).

1 Like

Thank you @Attah and @Levone1

My boot loader indeed is unlocked. BTW, the number to dial is *#*#7378423#*#*

(Looks like the editor eats the star symbols. They need to be backslashed.)

Now in order to relock the phone I would need to flash the device according to:

New step: I connected the device to an adb capable PC.

The phone then displayed a “do you want to install Xperia Companion”. Do I want to?

adb already detects the device

No idea about that.
Blindly guessing, I’d bet for “no”. But you better duckduck it!

1 Like

It’s not going to help you lock bl, but it might do an update for you. You could try it out… Easiest thing to manual update is Androxyde Flashtool/Xperifirm.

1 Like

Thanks again @ric9k and @Levone1, that was not my smartest question about the companion: I thought it was a phone app. In fact as I still dont have a handy windows, I wont have that companion.

Updates: I tried to relock the bootloader from adb/fastboot but “fastboot oem lock” gave me a “remote: unknown command” error.

As I returned to roid (with fastboot reboot), I saw to my dismay that the phone is encrypted. Is this related to my fastboot error? How do I remove encryption?

I did a new factory reset; phone still encrypted. But I set language to english so my future descriptions will be more accurate.

Thanks to all those helping; I feel so unexperimented in this domain.

I don’t know exactly but try to search on the forum.
You can use the forum search engine but it doesn’t always find things.
I sometimes use the evil “don’t be evil” search engine with, e.g.this in the search box (with the quotes):

“fastboot oem lock” site:https://forum.sailfishos.org

It gave me:

I have no time to search further but hope it’ll help.

1 Like

How did you factory reset? Do you have TWRP? If so, you can choose ‘format data’ in wipe menu, and that will remove encryption, (or ask the person you bought it from what the password is).

Hi @Levone1

I did the reset from settings > system > reset.

I dont think I have TWRP installed. I’m currently searching for a way to give a definitive answer to that.

Edit : found this link about the recovery boot:

Looks like I need the unlock key that I didnt request yet.

Hello @ric9k

I don’t think about using site: in my searches. Good data you dug there.

In the 1st link, I see the guy has an “its already unlocked” error while I got a “you’re not allowed to” when he tries “fastboot oem unlock”.

I’m not sure I’m going in the right direction here as it might be easier to flash android9. Or should I go through a relocking beforehand?

Anyway, I will be getting a windows machine before the week ends. It should make things easier.

Thank you both for your unabated help