Relock bootloader failing - Xperia 10

I am trying to reinstall Android to give another life to a Xperia 10.
I successfully flashed back Android using the standard Emma tool, based on https://jolla.zendesk.com/hc/en-us/articles/115004283713-Reverting-Xperia-device-to-Android-OS-and-reinstalling-Sailfish-OS.
However, I do not see how to lock the bootloader again and so booting shows the evil message that the device cannot be trusted blah blah blah:

I had the impression that fastboot will be an easy mean to get to it.
→ ‘fastboot oem lock’ produces an error message
“FAILED (remote: ‘unknown command’)
fastboot: error: Command failed”
I tried ‘fastboot flashing lock’ and ‘fastboot oem relock’ but same error message. If I do ‘fastboot getvar all’, I can see all the detailed information of the device, so I guess there is some options which prevent relocking the device?
Strangely enough I did not have issues to unlock it back in the days :wink:

In Android, I have Developper mode enabled, USB debugging on. I cannot touch the button OEM unlock, it is greyed out (as it is already unlocked I guess)

Is there anyone seeing what I am not?
thanks :slight_smile:

according to xda, you can’t relock BL on xperia 10 mk1.

2 Likes

@remote thanks for the info.

Indeed it seems that according to [Q]How to lock bootloader on Xperia 10 plus ? | XDA Forums Xperia 10 devices cannot be locked again.
Not sure if this is true for all Xperia but seems to be the case for quite a large number of them :grimacing: