Android app requiring lock pin

Hello,

I just installed 4.2 on an Xperia 10 II with Alien Dalvik, and MicroG.

I put SAP Concur on it, and this Android app asks for a lock pin.

The Sailfish one is not detected, I can configure one on Android settings but it isn’t registered either.

Is there a way to fix this please ?

5 Likes

Are you on 4.2.0.21? On 4.2.0.19 lock code set in Android settings still worked but that broke for me in 4.2.0.21.

Optimally Android apps would detect that there is a lock code set in Sailfish…

On 4.2.0.21. If it worked on 4.2.0.19, there is still hope to have a quick fix then.

Not fixed in 4.3.0.12 sadly. I have an app from my health insurance that is not complaining anymore about root but is missing the device lock setting now

Still unable to set screen lock in 4.3.0.15

Encountered that bug on 4.4.0.64. It would be great to have a fix for this

Same here on Xperia 10 III (4.4.0.64) with Microsoft Authenticator.

If you are talking about Office 365 related MFA, it’s possible to use any other auth application, too, when configuring it in O365 account settings. If the company policy hasn’t disallowed that, or course.

Authenticator itself is no problem and works, but passwords need the right for device lock.

1 Like

At risk of derailing the thread: What passwords?
You are not making sense. First MS Authenticator is the problem, then it isn’t.

As @direc85 says, there are other, better, applications if you just need TOTP functionality. If that is not what you are after, say so.

Microsoft Auth has Support for passwords since some time now, I guess roundabout a year. So it’s not just the former Authenticator-only any more, it can show your passwords storefin Edge, payment Info and adresses.
So sorry for the confusion - what I wanted to say is that every function except the primary Authenticator function is blocked by the App itself cause of the missing device lock rights.

any news on that? Just encountered the same problem with my banking app - Code cant be set in Android security settings (Message after entering Pin:“screen lock has already been changed”) - and whatever i try it just says: screen lock: none.

Xperia 10 i - most recent Sailfish Version.

I have that problem too (4.4.0.64, Xperia 10III)
Vivaldi wants you to “set a devicelock first” to see the saved passwords.