Android 13 and SailfishOS on xperia 10 III

If you are using Sony Xperia 10 III, follow the guide.

If you have Android 13 follow this guide.

@emva I am buying a Sony Xperia 10 III with Android 13 already installed on it, does this mean I have to downgrade Android to v11 or v12 BEFORE installing SailFish ?

1 Like

That’s what the instructions say.

@attah I see no Android 13 nor downgrade mention in these instructions, that is why it was not obvious for me.

I want to be really sure before buying this Android 13 device.

A bit up from The baseband version table.

Several days ago I’ve flashed my 10 III with Android 13 (62.2.A.0.525) using EMMA and then SFOS on top of it. Result? A considerably better working device than on Jolla’s recommended Android 11. None of the people I spoke with confirmed hearing any echo, and the display’s green/yellow tint issue is also gone, without any kind of fix being used for that. At the same time, I haven’t noticed absolutely any negative effects. So I can actually RECOMMEND flashing SFOS over Android 13.

9 Likes

Good work trying it!
I suppose it would be too much to hope for, that it improved flight mode current drain?

i’m curious if you have sound disappearing issues

Oh my god that green tint of the screen is horrible… Really??? A13 works better over SFOS???

Please check the audio recording? Sounds loud? Thank you.

Sadly, I haven’t noticed any difference when it comes to power drain. Maybe power consumption related stuff is in the Sony AOSP binaries.

Yes. I haven’t seen it a single time with Android 13, without any kind of fix.

No, no change here. I still need to boost the mic level to get reasonably loud recordings. I suspect it is a SFOS thing, not related to Android.

Too little time to say. And also with Android 13 I only had it 2-3 times in 1,5 years, and only after using GPS. So it is not easy to reproduce.

1 Like

But regarding the binary vendor, you’ve used the same Jolla’s tutorial suggests? So the latest a11 binaries?

I was able to flash SW_binaries_for_Xperia_Android_13_4.19_v2_lena.img AOSP binaries and SFOS booted and worked with them, EXCEPT for that mobile data (and thus also VoLTE) didn’t work. So I keep using Android 11 AOSP binaries (SW_binaries_for_Xperia_Android_11_4.19_v9a_lena.img).

So you did manage to flash a13 binaries but coudn’t get VolTe working and mobile data, while, flashing latest a11 binaries made them work?
I am trying that right now, first flashed latest stock android 13 on the 10 III, then flashing SFOS with a11 binaries :wink:

Mobile data and VoLTE have always worked for me with Android 11 binaries, which are the ones recommended by Jolla. I was actually surprised that SFOS boots and works with SW_binaries_for_Xperia_Android_13_4.19_v2_lena.img, but sadly mobile data did not work with those binaries. So I went back to SW_binaries_for_Xperia_Android_11_4.19_v9a_lena.img.

Regardless of the binaries version, with stock Android 13 I was able to get rid of the echo and color banding issues, so I’m still more than satisfied. Maybe Android 13 based AOSP binaries would bring further improvements, but without functional mobile data using them doesn’t make sense anyway, so I didn’t even bother to further test them.

2 Likes

Well, I’ve tried. Flashing prior to SFOS the latest A13 or the EMMA one from SONY definitely fix the green tint of the screen/banding issue, however, with my mobile provider WindTRE I’ve got Echo, putting on the loudspeaker is one piece of criminality, because it will repeat the latest thing you’ve said and will turn the volume up as crazy. Echo not fixed, but, you can use quite ok with the earpiece. To me flashing A13 binaries make WLAN broke :frowning: have to use the Jolla’s suggested ones

The 10 III echo issue is that during normal calls (via earpiece, not speakerphone) the other party (the person you’re talking to, not you!) hears echo, the stronger the higher volume level you have.

See @flypig’s post from May '22 when Jolla introduced support for the 10 III. It describes some of the issues, including the echo cancellation problem:

With Android 13 it seems to be gone, at least no one I called in the last 4-5 days reported hearing any echo, even though I have call volume set at the max level.

2 Likes

Then yes, maybe has been fixed by later version of binaries from SONY of A13, or even with A12… it has all to be tested. I’ve done some fixes to have mobile data with my italian provider, set to 3G, and I don’t have echo now. All good seems

In my case it is the stock Android OS upgrade that fixes it, not AOSP binaries. I’ve had it on Android 11 but it’s gone on Android 13, with the exact same AOSP binaries…

4 Likes

I understand, well, I’ve got some echo unfortunately, not on all calls, anyway seems pretty solid. Even if Jolla suggests to flash A11 it’s seems ok with A13 too.
And most important, it fixes the green tint of screen
Regarding how you flashed stock A13, you’ve used EMMA right? But I assume it’s ok too using Xperifirm to donwload the really latest stock version and then use Newflasher to directly flash it to Xperia… what do you think?