No Autofocus on Xperia 10 III

Would you kindly point where is this recommendation?


My problem is solved. Or kind of.

When I turned off Android App Support my Autofocus works again.

When I turned Android app support on again the autofocus doesn’t work again. Could MicroG be causing problems?

Just tried it now, (x10iii4.5.0.24) I have aas and ug on, and AF is working.

I have found that incredibly slow picture taking is caused by AF. If it doesnt think it has focus, it wont fire the shutter

Yes, that has been a problem for a long time. Extremely irritating to never be able to take an action shot. When my children are playing football or I am on a buss/train, it won’t take the photo.

However, more recently the AF has not worked at all. It never focuses, even though it says it does. There is the blue circle but the image is really blurry. When I turn off Android app support, the auto focus works as normal.

yes, it want that the focus is set otherwise it just won’t take a picture.
I get a bit frustated by this behaviour actually.

You could call it a community recommendation, but it fixes a significant aesthetics problem with the screen.

First 3 are taken with the 10iii. Other 9 with the XA2.

But I’m sure you know better. :smile:

And the echo issue, too.

Okay, i totally get your point. But don’t get me wrong…

I just see positive outcome only from one user, which is already kind of neat. Great job @wetab73 !

Just for what it’s worth, in my opinion it takes a little bit more to become any kind of recommendation.

1 Like

The auto focus isn’t great because it is quite slow. But the real problem is that it can’t handle non-static scenes at all.


Try to take a picture from something you see outside while riding in a car or train. Auto-focus will fail.

Try to take a picture of something moving, like a group of people, or a carnival ride or a float in a parade. Can’t focus.

Try to take a picture in changing lighting conditions, like in a party with coloured lights that turn on/off or rotate. Can’t focus.

Finally there is a bug where sometimes the autofocus will get ‘stuck’ for a minute or so, and you can’t really interact with the photo app. After a minute it will take a picture at random, maybe focused maybe not. Usually your camera is pointing in a random direction at this point so you get a picture of the floorr.

The autofocus problem also happens if it’s simply too dark… Try taking a picture where most of the screen is dark/black… and you’ll notice it’s impossible to take the picture, nothing happens when you press the ‘shoot’ button.

Move somewhere where you have more light, and it starts working again. Very annoying.


even though it sounds different, this is likely a dupe of Camera refuses to take picture on 10 III (focus hangs) (among other threads. very popular issue, complicated to pinpoint exact issue, and therefore easy to make multiple threads)

that problem is with the camera1 api. it is broken on 10III in sony stock android, in AOSP, and in SFOS, and is only technically fixable by sony.
the solution is to use the camera2 api, which works in SFOS right now using the android app OpenCamera, if you have android-app-support.

native SFOS camera2 support is being actively developed, but it is a work in progress and work seems to be slowing a bit on it.
camera2 issues: Issues · sailfishos/droidmedia · GitHub
camera2 commits: GitHub - sailfishos/droidmedia at camera2


It’s up to you. As far as I could tell, there was very little Jolla emphasis on v11. It was just the one they did proper testing on as it was the one available when they started porting.
Further, the community as a whole said, prior to this discovery, there is no apparent difference between the versions. @wetab73 has also shown themselves to be a reliable, respected user of the forums with an aptitude for and deep understanding of Sailfish. Nobody has yet put up a counter argument.
Lastly, later versions of Android use later manufacturer drivers. It’s a standard thing in computing to have the most up-to-date drivers with very few exceptions. Sony, as a trusted partner of Jolla, would aim to at least maintain compatibility with Sailfish. If they failed to do so, I would have expected Jolla to communicate that by now.

I don’t have the bug and I don’t have a problem photographing from a car or train. Nor photographing moving things any more than a camera without manual focus would. Disco lights is pretty damn niche.

Advanced Camera has 5 autofocus modes. 2 of them do a quick zoom-in/out first, meaning the shot is taken 1s later. Manual mode just takes the shot.

The camera will often sometimes focus on the wrong thing but that’s what the selectable autofocus is for.

The difference between Camera API 1 and API 2 may be relevant. I mostly use an HDR Android app called Snap Camera and it’s probably API 2. I also use Advanced Camera (native) for low contrast shots and am testing Open Camera to see if it’s better at properly-exposing darker shots.

Snap Camera uses a slow autofocus but it’s taking 3 shots so that’s OK. The manual HDR processing screen crashes Android’s Camera function (but saves the shot), so that’s my main problem at the moment.

If you are using an android app with api v2 and I am using the standard sailfish camera with api v1, and if there are indeed different bugs between the two api versions, then we’re comparing apples and oranges.

Of course, this is merely my very own private report based on having personally used SFOS over Android 13 for some 4-5 weeks and not having experienced any problems, while at the same time really enjoying no trace of echo during calls and no display tint/color banding, both of which were troubling me on Android 11. I can’t say for sure or guarantee that there aren’t absolutely any issues as I certainly haven’t tested everything, but in normal daily use I didn’t encounter any problems. But of course as long as Jolla doesn’t officially recommend it, using it is obviously “at one’s own risk”.


yes, like you say, apples and oranges. just to reiterate:

  • it is just one bug, and it is only in camera1 api. this one bug affects sailfish apps and android apps on sailfish, AND android apps on android, including stock sony (it is baked into the sony binaries, and is only fixable by sony)
  • HOWEVER, the vast majority of android camera apps (both in SFOS-app-support and in android) use camera2 api (or use both but default to camera2), and therefore do not have this bug.
  • unfortunately, upgrading to android 13 does not fix this bug in any way (at least for me, but i am willing to bet that David ALSO has this bug, when using camera1 api)

Easy bet for me to take and the second time someone’s claimed telepathic abilities for my camera usage. Shall we call it $100 and you donate it to Jolla?

All of you complaining about problems are being vague. You are the ones with the problem. I am not obliged to fix them. I am trying to help and I’m not sure I have the patience.

You haven’t said which apps you’re using. You haven’t said which bug you’re talking about.

It was said quite clearly in the thread that the apps don’t use the infrared sensor. Therefore, noticeably substandard autofocus behaviour is to be expected.

Are you saying your bug exists on a fresh installation with Android 13 & the 11 AOSP binaries, ie without installing any other software (bar possibly Advanced Camera)?

this is a known bug, confirmed and tracked by jolla. also, it’s impossible for you (or them) to fix, as it is in sony’s firmware, so you can rest easy in your obligations. (the workaround is to use camera2 api, and jolla devs and community members are actively trying to do that instead, which will make this bug irrelevant)

yes, exactly. the bug exists on actual android, not just on sailfish. the bug, to be precise, is that the camera1 api will not focus while there is more than the slightest bit of movement in the viewfinder. this makes focusing very slow or impossible in non-controlled environments like concerts or action shots, and can make you select the wrong focus level even in a normal setting.

to reproduce, open jolla-camera (or AdvancedCamera, or OpenCamera with camera1 api selected, etc) and move the camera in small slow-ish circles (so that a large percentage of the viewfinder is changing over the course of, say, a half-second). hit capture while moving the phone, and the camera will not immediately capture a photo. you can delay it for literally minutes if your circles are smooth. when you stop the circles, the phone will suddenly finish focusing and snap a picture without having to touch capture again.
if you tap-and-focus, the white circle will not become green until there is no motion in the viewfinder again. once its green, you can take pictures quickly, and any pictures you take will be at that focus level.

EDIT: note that in AdvancedCamera, to reproduce the delayed capture, you must select auto-focus.
OR you can select manual-focus, and then tap the screen, and see the focus delayed. also, the movement does not need to be large, just constant and smooth. if the screen is still for a half-second, it will focus