[AlienDalvik / AAS] Typing characters after deleting typed text often inserts the deleted string



If someone comes up with a better title, please change.

I encountered this in chatapps like threema or element (matrix) if you type something that is replaced, e.g. an emoji in matrix by typing :duck and then select the emoji, the :duck text disappears. But after you type the next letter it is inserted again.

I assume this is a SFOS related problem.


Have element (android) or threema installed, be setup for chat.


  1. Open a chat in threema or element.
  2. Depending on the app you are using:
    a. Threema: do a mention by typing @username
    b. Element: create an emoji by typing :duck
  3. select some entry from the list that popped up
  4. see the result (a mention or an emoji
  5. start to type something else


it is only showing the mention or emoji and the text you typed afterwards


it also shows what you typed after the : or @



This was produced by typing :duck selecting the duck emoji and then typing a space

1 Like

I can reproduce it on Signal on my X10 II.

1 Like

The same has been happening in Teams, when you type someone’s username. Definitely not a new bug, has been happening for probably 3 years, since I started using Teams on SFOS phone.
Might have been a regression from Android compatibility 4-5 to 8, could have been there from the beginning


Even i was annoyed by this for a loong time. Interesting that noone reported it earlier… Probably everyone thought that it is already reported :wink:


Yes, it does.
And it is not at all limited to Android chat apps, if have seen in in Android text editors, when typing in text fields of web-pages in Firefox etc. It is reported and discussed a few times (= in a few threads) at TJC, but I cannot remember any sailor ever replying or acknowledging this issue. Still, Jolla has addressed this issue multiple times (silently, as so often, observable by changes in details of this behaviour) and reduced its severity / impact much; at times it was literally impossible to type a few words in most Android apps, if you ever needed to use <Backspace> (i.e., correct something you typed).


My preliminary, abstract assessment is, that it always (i.e., all these years > 7) takes a new word (i.e., introduced / prefixed by a space character), then a delete operation (regardless, if by oneself hitting <Backspace> multiple times, or automatised, see example in OP above: the string :duck is deleted and an emoji inserted), followed by typing <any key>: Then the deleted string is inserted again.

It appears that Jolla has employed workarounds, which let this happen less often, but never found the root cause of this issue.

Mind that there are different kinds of text fields, I only remember this happening in free text fields. OTOH, I have never tried to reproduce this systematically outside of free text fields, e.g., in a password entry field etc.

P.S.: @thigg, you might adapt the title of this thread to the fact that this is about text strings (“commands” is a bit misleading, even for your emoji example) and potentially affects all Android apps. Plus that this is related to Alien Dalvik (“Android app support by Jolla” is its new marketing name; I never heard a Waydroid user complaining about this issue).


Thanks for the report @thigg. I’ve logged this internally and tagged it as “tracked”.

1 Like

There is also some strange behaviour when editting a text in the fennec android app, (for example om this forum) but also in other android apps. If move the cursor back to another point and start typing again, it jumps back at the previous point. As a workaround I have to swipe the keyboard down and select a point in the text everytime I want to correct some mistakes. Sometimes it works correctly, but most of the times it jumps back.

1 Like

Did anyone observe this while using another keyboard (okboard?)
wondering if this is keyboard specific or a problem of the android container

I think the bug must be on the android side in com.jolla.inputmethod.remote.
But I guess this is closed source, thus we cannot really help jolla to fix this, right?

1 Like

I’ve noticed this behavior with the Obsidian android app, it’s very annoying and makes it practically unusable. The only workaround I’ve found is uninstalling predictive text but that means losing useful functionality in other apps. It would be nice if there was an easy way to toggle predictive text, I found a patch for it but it is long out of date now.

1 Like

That could actually mean the bug is in predictive text… This is interesting

No, does not make a difference for me. Bug is still there. However i just uninstalled it and didnt restart anything. Will report back if a restart solves this

This is also what I remember from tests years ago:
The issue occurs regardless of Jolla’s predictive text suggestions being switched on or off.

Yes, it happens with OKboard as well.

1 Like

Pressing space allows you to move the cursor wherever you want afterwards


I’ve found that doing “select all [text]” from the menu and then clicking the cursor where you want to insert will properly reset the position. I’ve tried to understand when this happens, to no avail — it only seems to happen when it is the most inconvenient, so I’m suspecting AI interference.