Alien Dalvik & Captcha issues (gapps) 4.0.1

Hello Sailors.

I don’t know if my topic is in the good category, i guess it can’t be considered like a bug.
And maybe that problem doesn’t appear in previous releases, or will be fixed when exiting EA.
(I didn’t tried thoses android apps before)

So,on a clean install, i updated to 4.0.1.
Installed aliendalvik, working normally. But tried to use Discord, or Nicehash app, and i just can’t use it because of captcha. I guess it’s related to google play service.

  1. Is there a trick to prevent captcha check from apps ?
  2. I suppose there’s no “official way”, and only google services can make it work , right ?
  3. And in the last try, is there already a way to install gapps ( or microg ) on 4.0 ?

Thanks, nice day to you !

(Rhetorical) What kind of apps force their users to go through captchas? Sheesh!

I screwed up my update, so i too started on a clean 3.4, and upgraded to 4.0 before installing the Android Runtime.

Installing microG works just as well as before. (no idea if it supports captchas, and not intent on finding out)
So, either just grab the APKs off their site, or add their repo to F-Droid and install through there.
Enable signature spoofing in settings (understand why, blablabla), and don’t forget to symlink /home/nemo to /home/defaultuser and it should work.

Thanks for your answer :slight_smile:
I never used microG before, i tried, and it’s not working at the moment.
What i’ve done :

  1. Downloaded & installer the four apk.
    Services Core / Services Framework Proxy / Store (FakeStore release) / DroidGuard Helper
  2. Putty as root : ln -s /home/defaultuser /home/nemo
  3. Opened microG settings, in “auto-check” tab : checked the second line “The system allows signature spoofing” but the 3rd 5th and 7th checkbox can’t be checked.
    4.(re)installed Discord from “Store”
  4. Still the same issue with recaptcha check & google services.

Did i do something wrong ? Thanks … :stuck_out_tongue:

Sounds very much like what i did. It is a mystery which checkboxes will throw a permission request when pushed, and what the remaining ones do.
If you haven’t already, do a full reboot after having granted microG spoofing support.
(I now have boxes 1-8 checked)

Thanks again for your answer !
Same after reboot, already tried.
I hope i didn’t miss an obvious thing … ^^’

3.4.0 introduced a bug where the Signature Spoofing feature of Alien Dalvik didn’t work correctly since it was searching for the nemo home directory, not the defaultuser directory for new installations of 3.4. Could this still be the problem?

I guess this command is to fix the bug you’re talking about. No ?

Has anyone tried https://gitlab.com/artur_gaspar/aliendalvik-systemimg-patcher with 4.0?
Maybe replace OPENGAPPS_API=8.1 with 9.0?

I’ve done it. Flashed 3.4, and then updated to 4.0 (after being on android for the past year or so). Working like a charm, Playstore downloading and everything… :+1:

Hi! Maybe some guide for noob how to do it? :wink:

https://together.jolla.com/question/205890/howto-install-google-play-services-on-baseport-8-devices-from-the-phone-itself-tested-working/

Ok thanks for the info. Did you download Open GApps for 8.1 or 9.0?

9.0 :slightly_smiling_face:

Ok I did it too. Had to manually download the zip and hard code the downloads variable in the script.
Android setup wizard is popping up and I can’t finish it for some reason. Now I tried:
devel-su
lxc-attach aliendalvik – /system/bin/sh
settings put global setup_wizard_has_run 1
settings put secure user_setup_complete 1
settings put global device_provisioned 1

Let’s see if that helps.

1 Like

Anyone got chromecast and banking aps working with 4.0.1?

I also downloaded the open_gapps-arm-9.0-pico-20210217.zip from The Open GApps Project.
I changed OPENGAPPS_API=8.1 to OPENGAPPS_API=9.0 and place the files together in the Downloads folder.

Then:
[nemo@Sailfish ~]$ devel-su
Password:
[root@Sailfish nemo]# cd Downloads
[root@Sailfish Downloads]# ./install_opengapps.sh
Copying original image /opt/alien/system.img to /home/.aliendalvik_systemimg_patch/system.img.orig.20210217T140352
-bash: can’t open ‘xdg-user-dir’: No such file or directory
Searching for Open GApps zip at /open_gapps-arm-9.0-pico-*.zip
find: : No such file or directory
Opening Open GApps download page
-bash: can’t open ‘xdg-open’: No such file or directory
Waiting for download to start
-bash: can’t open ‘xdg-user-dir’: No such file or directory
find: : No such file or directory
-bash: can’t open ‘xdg-user-dir’: No such file or directory

This loop continues long time. Please help how to fix it

could you provide the working code?

Hi,
easy brutal fix is to replace line 102
downloads="$(runuser -l nemo – xdg-user-dir DOWNLOAD)"
with
downloads=/home/nemo/Downloads/

I managed to install play services BUT I constantly receive notification that device is not certified by Google Play Protect. I cannot reach account settings, or all Android settings. I cannot download or login or use any Google play connected service.
Do you have such trouble or is there a workaround?

I don’t have those kind of issues.
Maybe removing everything Android related could help. From https://together.jolla.com/question/205890/howto-install-google-play-services-on-baseport-8-devices-from-the-phone-itself-tested-working/ :

  1. Stop Android Support from Settings -> Android Support. Run devel-su rm -rf /home/.android/* ; this will uninstall all your current Android applications and remove their data. This is useful to avoid weird things happening.