[][10II] Whatsapp media not readable/not storeable (solved)

HARDWARE: Sony Xperia 10II


In Whatsapp I can only see blurred images from media which was downloaded before the upgrade.


Given Sailfish with version 4.4 installed
and Android AppSupport installed
and WhatsApp installed
Whatsapp message with an image
and image downloaded in Whatsapp


  1. Update to SailfishOs
  2. Open WhatsApp
  3. Click on the message with the image


image should be viewable


Message(translated from DE) appears saying “Download failed. No internal storage exists. Please deactivate it as an external drive und retry it”


When installing my Phone I transferred the WhatsApp folder from my old device, but it was already on 4.2.


I have a real sd card with exfat

The workaround works until reboot. Then it has to be applied again.

I’m unable to reproduce it using v. How is your SD Card configured? Is it mounted? Are the pictures stored in your SD Card?

The same happened to me. You just have to assign writing permission to the Whatsapp media folders (android_storage->WhatsApp->media) again. This has to be done via console, unfortunately…

Can you tell me what is the right user and group? On my system it is user 501023 and group is appsupport-media_rw

I’m having the same issue on my phone. Same permissions and user/group.
Also, the SELinux context and permission make sense to me:

root@Xperia10II-DualSIM:/home/defaultuser/android_storage/WhatsApp$ ls -lZ
total 24
drwxrwxr-x    2 501023   appsuppo u:object_r:media_rw_data_file:s0      4096 Feb  4 02:00 Backups
drwxrwxr-x    2 501023   appsuppo u:object_r:media_rw_data_file:s0      4096 Feb  4 02:00 Databases
drwxrwxr-x   13 501023   appsuppo u:object_r:media_rw_data_file:s0      4096 Nov  6  2021 Media

Please see the comment [][10II] Android App Audible is unusable saying SD Card required - #11 by Mazoon - that brought the media gallery of WhatsApp back as well. Be sure to follow all the steps to get the correct user/group on your device.

1 Like

For me it worked when granting 777 access to all files starting from ~/android_storage, but all apps are now working, by doing the steos from the Whatsapp Thread.

Added to internal bugzilla

I have the same since installation of all android apps do not have write permission:

  • Whatsapp cannot load received pictures
  • Aurora is not able to download updates for installed apps
  • Firefox is not able to download files

Permissions had changed by the update at least for Whatsapp by which I had to use:

chown -R media_rw:media_rw android_storage/Whatsapp

Permissions are as follows:
drwxrwx— 14 501023 appsuppo 4.0K Feb 11 09:41 android_storage
drwxrwxr-x 9 media_rw media_rw 4.0K Jul 21 2022 WhatsApp

The solution is provided by Caluna in this post: release notes struven ketju
followed by:
chown -R media_rw:media_rw android_storage/Whatsapp

Trick has worked here, but (maybe after reboot ?), WA can’t open pictures again.
Delete .storage_migrate_done + restart Android worked again.