OsmAnd + Magic Earth on and then

I am not a developer or a computer scientist, just a user who can do a command line if I am told what to do with precision and why !

This 4.5 installed well on both my x10ii and my wife’s XA2. Overall, no problems and woks fine. But it has generated on my X10ii (and certainly also on the XA2) two very big regressions for two Android applications:

  • OsmAnd no longer accesses my µSD card where my maps and favourites places are.
    I understand that the solution can be found here.

But I don’t really understand what to do or what commands to give in a clear way. There should be a real “how to” in Jolla’s Zendesk to give a solution.

  • Magic earth: this application also has all its maps on the µSD card of my X10ii.
    Unlike OsmAnd, Magic Earth accesses the maps! Why is the behaviour of this Android application different from OsmAnd?

Unfortunately the application takes much longer to open than in Sailfish OS 4.4. Then it freezes and tells me: “insufficient disk space, free up some space on your disk then try again”! But when I check with the lighthouse application, I still have some “ram” space !

In short, for me these regressions are quite incomprehensible. And I’m going to need these two applications very soon, especially Magic Earth which I find easier to use in the car than OSM And.

Thanks for your help and sorry for my english (i used DeepL to help me !)


When i run the ls -l command in the /Android/data folder on the µSD, I find the following values for the net.osmand.plus folder:
drwxrwxr-x 4 defaultu appsuppo 4096 Feb 18 19:24 net.osmand.plus

All other folders are at drwxrwxr-x 4 defaultu media_rw 4096

I understand that the anomaly is on the defaultu appsuppo values which should be at defaultu media_rw ?

Moreover the rights of the net.osmand.plus folder are at drwxrwxr-x

Is this sufficient or should we change them too?

I think that this is done with the chmod command (for the rights) and chown to change the appsuppo value to media_rw if I understand correctly.

I’m not a developer nor a computer scientist but I don’t understand why these problems.

Also, regarding Magic Earth, the application works but it is much slower than before with version 4.4. Worse, it is sometimes unstable and the application indicates a lack of memory (ram)! But the values on the SDCard seems corrects. The folder Maps (for Magic Earth) is at the racine (root ?) of it :
drwxrwxrwx 3 defaultu defaultu 4096 Oct 5 2020 Maps
So why this problems of memory and this slowness ? Is there a way to have a better “feeling” with this app, Magic Earth ?

Thanks for DeepL.com that help me for writing this post :wink:

I wonder if I won’t end up opening a bug to get a solution as this problem seems “close” to mine!

I used to have the same issue on my x10ii with and Magic Earth.
After update to, now just after “successful” install I do get the following error:
“the operation could not be completed because of an I/O error. Please retry later”

Anyone else experiencing the same?

1 Like

This is for 64-bit only. 32-bit works out of the box or is easy to fix.

Do you have a vfat (FAT32) SD card? Any fix you make is instantly overwritten by Appsupport.

Workaround (to use apps using internal storage):

  1. turn off Android support
  2. rename or delete the Android directory (or just the app’s subdirectory) on the SD card
  3. create a file with the name of the directory, easiest way is
    touch Android
  4. restart Android support
  5. Magic Earth and OsmAnd start working

For ext4 and others there are more options to sabotage the broken appsupport-root handling of Android data on SD card: chmod, chown and ln -s


First of all, thanks for the reply of yours!
Yes, my SD is using ext4.
What are my options?

WoW !!! Thanks a lot !
But as @trial_x10ii , our sdCard are crypted and in ext4. I said “our” because i have exactly the same problem on my x10ii but also on the XA2 of my wife.

I think that we can have a beginning of the solution in this thread. I understand that Jolla open an internal bug.
I think that the good how to is this one :[][10II] Android App Audible is unusable saying SD Card required (solved) - #13 by xneo
But i’m not sure.

Well , i open a terminal on my mageia laptop PC on the X10ii via SSH.
I navigate to the folder Android on my sd card.
The values are for the net.osmand.plus : drwxrwxr-x 4 100000 501023 4096 Feb 18 19:24 net.osmand.plus
Or all others folders (i choose net.osmtracker) are at : drwxrwxr-x 3 100000 1023 4096 Mar 10 2021 net.osmtracker
What did i must change via the chown command ? And as i said at the beginning, i’m not a developper or a computer scientist).
Thanks a lot for your help !

XA2 doesn’t have this problem (I checked both OsmAnd and Magic Earth). I have nemo:media_rw and 775 and it just works.

Let’s keep this 64-bit.

The easiest way to force Magic Earth to use the phone’s internal memory:

  1. stop Android support (Settings)
  2. on the SD card rename or delete (root in terminal, or file-browser with root) Android/data/com.generalmagic.magicearth
  3. create a file with the same name (root in terminal):
    touch com.generalmagic.magicearth
  4. start Android support (Settings)

Vfat (FAT32) doesn’t have permissions so root and terminal aren’t needed: instead of touch just copy any file and rename with file-browser.

Oh thanks. I will try today your idea. To do that, what is the best way ?

  • with File Browser ?
  • in a terminal as user ?
  • in a terminal as “root” ?
  • with an other tool ?

Thanks a lot