[][Xperia 10 III] The sound disappears and video freeze

REPRODUCIBILITY: 100% After some time


Since a few days I have a bug that makes the phone totally unusable.
The sound disappears, and when I try to play a video it is very slow and freezes.
The videos have this problem whatever the application, YouTube on web browser, in gallery or via Piepmatz.
I have to restart the phone, and this problem can come back a few minutes later.


Not so clear, the problem appears suddenly without me understanding what triggers it.


  1. Use phone normally


The sound should not disappear, and the video players should remain usable


No sound and video freeze


I mainly use the app from the jolla store and I have some app and their dependencies installed via chum repository:

  • Advanced Camera
  • Argon2
  • Machines vs. Machines
  • ownKeepass
  • Quartermaster
  • SailfishOS:Chum GUI
  • SailHub
  • Sodium Library


The journalctl log gives many errors:

juin 12 00:03:49 Xperia10III kernel: afe_callback: cmd = 0x100fa returned error = 0x1
juin 12 00:03:49 Xperia10III kernel: afe_apr_send_pkt: DSP returned error[ADSP_EFAILED]
juin 12 00:03:49 Xperia10III kernel: [aw882xx_smartpa]aw882xx_monitor_set_vmax: dsp_msg_write error
juin 12 00:03:49 Xperia10III kernel: [aw882xx_smartpa]aw882xx_monitor_set_vmax: set vmax = 0x0
juin 12 00:03:49 Xperia10III kernel: q6asm_callback: cmd = 0x10db3 returned error = 0x3
juin 12 00:03:49 Xperia10III kernel: __q6asm_open_write: DSP returned error[ADSP_EUNSUPPORTED]
juin 12 00:03:49 Xperia10III kernel: msm_audio_ion_free: dma_buf invalid
juin 12 00:03:49 Xperia10III kernel: msm-pcm-dsp soc:qcom,msm-pcm: ASoC: platform prepare error: -12
juin 12 00:03:49 Xperia10III kernel: soc_pcm_prepare: Issue stop stream for codec_dai due to op failure -12 = ret
juin 12 00:03:49 Xperia10III kernel:  KONA Media1: ASoC: prepare FE KONA Media1 failed
juin 12 00:03:49 Xperia10III kernel: [aw882xx_smartpa]aw882xx_mute: mute state=1
juin 12 00:03:49 Xperia10III kernel: [aw882xx_smartpa]aw882xx_smartpa_cfg: flag = 0, power status = 2
juin 12 00:03:49 Xperia10III kernel: [aw882xx_smartpa]aw882xx_monitor_stop: enter
juin 12 00:03:49 Xperia10III kernel: [aw882xx_smartpa]aw882xx_stop: get_sysint=0x0000
juin 12 00:03:49 Xperia10III kernel: afe_close: port_id = 0x1000
juin 12 00:03:49 Xperia10III kernel: [aw882xx_smartpa]aw882xx_mute: mute state=1
juin 12 00:03:49 Xperia10III kernel: afe_close: port_id = 0x1001
juin 12 00:03:49 Xperia10III kernel: [aw882xx_smartpa]aw882xx_startup: capture enter
juin 12 00:03:49 Xperia10III kernel: [aw882xx_smartpa]aw882xx_set_fmt: fmt=0x4001
juin 12 00:03:49 Xperia10III kernel: msm_mi2s_snd_startup: set sysclk failed, err:-524

I am not sure, but the problem seems to appear when using the GPS. I installed sailfish on the Xperia 10 III the day it was released, and this problem appeared at the same time as my need to use the GPS. When I deactivate the localization I don’t have this BUG anymore. It is very annoying when it happens because there is no sound, impossible to hear the notifications or even make calls without rebooting the phone.

This bug happens to me without using GPS.

1 Like

I also have had this annoying issue 4 times, and I assume it has something to do with GPS. At least the previous 3 cases have happened after using PureMaps.

I’ve had this happen once. I used GPS during the day for a few hours, then some in the evening, and some time after that I noticed the issue. My gut feeling is “it can’t be GPS” but now I’m starting to doubt that…

For me this is totally random. It can happen directly after a reboot, over night without using the phone,after a phone call…i never figured out a reproducable situation to trigger this bug.

But i will reboot now and check if the bug occurs without using GPS at all.

I don’t have this issue since 3 days by deactivating the GPS.
Do you have the same errors in journalctl?

2days and 18 hours without using GPS, audio is still working.

I can confirm that the same happened to me yesterday, while attempting to setup my Xperia 10 III.

After installing all my apps and copying all my data to the device, I tested audio and video, which worked fine.
Next step was to download maps and check GPS with OSM Scout. After enabling the GPS, audio was gone. A restart solved it for the time being.

There are two other similar cases, one you can find here:

Instead of restart you can in the terminal type the following:
pulseaudio --check && pulseaudio -k && pulseaudio --start
It is also possible to type the middle part:
pulseaudio -k


I had the same bug after using GPS/Pure Maps. However, I did not notice that it might be related to GPS/Pure Maps but I lost sound the day I was travelling with Pure maps’ assistance

1 Like

It seems to me that I have already tried without solving the problem. I will try again this weekend.

The answers in this thread seem to confirm that the GPS is related to this issue.

Do you know if it is possible to use the location from a watch with a GPS function and compatible with Amazfish?
I don’t have one, but I can consider it if it can be a temporary solution to use OSM Scout when I go with my bike

I am 99,7% sure that the watch cannot feed GPS signal to the phone…

Somehow, I managed to get rid of this weird bug (?conflict?) where the audio is suddenly gone after enabling and using the GPS.

After getting no data connection from my SIM (placed in SIM slot 1), I decided to copy my mSD content to the internal storage, remove it, place the SIM card to slot 2 and check if mobile data is usable this way (found this solution in the forum).

So, after placing my SIM card to SIM card 2 slot, mobile data is working perfectly fine (up to now, 3-4 days in a row). I then tried to reproduce the aforementioned problem, enabling the GPS and checking with the sound. THIS BUG IS GONE TOO! (at least up to now)

1 Like

It’s a bit inconsistent, too… I have used GPS every now and then for 10-15 minutes for testing this, and so far I haven’t been able to reproduce it with short sessions…

It may also have something to do with OOM killer, because I have only been able to reproduce it with Here WeGo navigator, which eats up quite a lot of RAM. It’s not a trivial task to hunt this down…

I’m having this issue again. I could collect some logs, what would be useful? I can survive this for a few days at least :slight_smile:

PS. I did use GPS for 1.5h two days ago, this could be because of that, not sure, but certainly possible.

1 Like

Perhaps collect all log since device has booted and then filter.

I have seen this a couple of times now too. Seems to happen even during inactivity, or maybe at the end of usage.

After using the GPS, which i barely do, i always restart the phone. The bug didn’t occur for weeks now, so i think it is definetly GPS related.

Did any of you check miau’s solution? [Xperia 10 III] Audio suddenly completly gone - #7 by miau
It did fix this issue for me, unless I have been extremely lucky so far.