[4.4.0.58] No SIM-Card (Phonecard) inserted

REPRODUCIBILITY: 100%
OS VERSION: 4.4.0.58
HARDWARE: Sony XPeria 10 DUAL-SIM
UI LANGUAGE: German

DESCRIPTION:

In version 4.3.0.12 and 4.3.0.15 my SIM-Card (Phonecard) works and also the SD-Card. As soon as I upgrade to Version 4.4.0.58 and also re-flash my SIM-Card no longer works. It is a SIM card from handyvertrag.de - i.e. one with network operator 26203 and SIM provider code 26207. To test the Phone, I inserted other SIM card, which works with Penny-Mobil (Congstar; Telekom).

My cell phone with my SIM-Card (Phonecard) and SFOS 4.4.0.58 brings the following error message:
No SIM card inserted

To test it, I flashed Android to the XPeria 10 Dual SIM. Everything really works.

ACTUAL RESULT:

RE-Flash SFOS-Version 4.3.0.12 to use the Smartphone with SIM-Card


3 Likes

Temporary Solution:

Stop the ofonod-Service and restart ofonod as root.

Kill the running ofonod process with kill -9 pgrep ofonod and restart it with:

/usr/sbin/ofonod -n --nobacktrace --noplugin=,he910,dun_gw_bluez5,hfp_bluez5,cdma_provision,isimodem,n900,u8500,qmimodem,gobi,cdmamodem,isiusb,nwmodem,ztemodem,iceramodem,huaweimodem,calypsomodem,swmodem,mbmmodem,hsomodem,ifxmodem,stemodem,dunmodem,hfpmodem,speedupmodem,phonesim,telitmodem,udev,udevng,bluez4,dun_gw_bluez4,hfp_ag_bluez4,hfp_bluez4,dun_gw_bluez5,hfp_bluez5

I have the same problem(using Xperia XA2 H3113), tried the temporary solution but does not seem to work:

I have killed the ofonod process and it does not run anymore but It hangs when I try to start it back:

[root@XperiaXA2 nemo]# pgrep ofonod
[root@XperiaXA2 nemo]# /usr/sbin/ofonod -n --nobacktrace --noplugin=,he910,dun_gw_bluez5,hfp_bluez5,cdma_provision,
isimodem,n900,u8500,qmimodem,gobi,cdmamodem,isiusb,nwmodem,ztemodem,iceramodem,huaweimodem,calypsomodem,swmodem,mbm
modem,hsomodem,ifxmodem,stemodem,dunmodem,hfpmodem,speedupmodem,phonesim,telitmodem,udev,udevng,bluez4,dun_gw_bluez
4,hfp_ag_bluez4,hfp_bluez4,dun_gw_bluez5,hfp_bluez5
ofonod[7826]: oFono version 1.28
ofonod[7826]: Excluding udev hardware detection
ofonod[7826]: Excluding Novatel modem driver
ofonod[7826]: Excluding Sierra modem driver
ofonod[7826]: Excluding ZTE modem driver
ofonod[7826]: Excluding Icera modem driver
ofonod[7826]: Excluding Huawei modem driver
ofonod[7826]: Excluding Calypso modem driver
ofonod[7826]: Excluding MBM modem driver
ofonod[7826]: Excluding Telit modem driver
ofonod[7826]: Excluding HSO modem driver
ofonod[7826]: Excluding Infineon modem driver
ofonod[7826]: Excluding STE modem driver
ofonod[7826]: Excluding Dialup modem driver
ofonod[7826]: Excluding Hands-Free Profile Driver
ofonod[7826]: Excluding SpeedUp modem driver
ofonod[7826]: Excluding Phone Simulator driver
ofonod[7826]: Excluding CDMA AT modem driver
ofonod[7826]: Excluding External Hands-Free Profile Plugin
ofonod[7826]: Excluding Dial-up Networking Profile Plugins
ofonod[7826]: Excluding CDMA provisioning Plugin
ofonod[7826]: Initializing RIL binder transport plugin.
ofonod[7826]: Initializing AML plugin.

It hangs on Initializing AML plugin.

Any advice on that? It’s annoying as I am unable to use my phone after the latest update.

Hello,
It doesn’t work for me, on XPeria 10 Dual SIM. DBus name already in use …

[nemo@Xperia10-DualSIM ~]$ devel-su
Password:
[root@Xperia10-DualSIM nemo]# killall ofonod
[root@Xperia10-DualSIM nemo]# /usr/sbin/ofonod -n --nobacktrace --noplugin=,he910,dun_gw_bluez5,hfp_bluez5,cdma_provision,isimodem,n900,u8500,qmimodem,gobi,cdmamodem,isiusb,nwmodem,ztemodem,iceramodem,huaweimodem,calypsomodem,swmodem,mbmmodem,hsomodem,ifxmodem,stemodem,dunmodem,hfpmodem,speedupmodem,phonesim,telitmodem,udev,udevng,bluez4,dun_gw_bluez4,hfp_ag_bluez4,hfp_bluez4,dun_gw_bluez5,hfp_bluez5
ofonod[31096]: oFono version 1.28
ofonod[31096]: Excluding udev hardware detection
ofonod[31096]: Excluding Novatel modem driver
ofonod[31096]: Excluding Sierra modem driver
ofonod[31096]: Excluding ZTE modem driver
ofonod[31096]: Excluding Icera modem driver
ofonod[31096]: Excluding Huawei modem driver
ofonod[31096]: Excluding Calypso modem driver
ofonod[31096]: Excluding MBM modem driver
ofonod[31096]: Excluding Telit modem driver
ofonod[31096]: Excluding HSO modem driver
ofonod[31096]: Excluding Infineon modem driver
ofonod[31096]: Excluding STE modem driver
ofonod[31096]: Excluding Dialup modem driver
ofonod[31096]: Excluding Hands-Free Profile Driver
ofonod[31096]: Excluding SpeedUp modem driver
ofonod[31096]: Excluding Phone Simulator driver
ofonod[31096]: Excluding CDMA AT modem driver
ofonod[31096]: Excluding External Hands-Free Profile Plugin
ofonod[31096]: Excluding Dial-up Networking Profile Plugins
ofonod[31096]: Excluding CDMA provisioning Plugin
ofonod[31096]: Initializing AML plugin.
ofonod[31096]: Initializing RIL binder transport plugin.
ofonod[31096]: Unable to register D-Bus name: Name already in use
ofonod[31096]: Exit
[root@Xperia10-DualSIM nemo]#

Same here on a XA2. Every online update has worked before. But after updateing from 4.3.0.15 to 4.4.0.58 the SIM card is not recognised. Killing and restarting ofonod has the same result as with david.hoeung.
Unable to register D-Bus name: Name already in use

What can be done?
Best regards, Uwe.

Hi Uwe. I am interested in: From which provider is your sim card? Is their SIM toolkit on the SIM card? You can see this in 4.4.0.58 when there is a SIM card icon in the list of apps. Or until 4.3.0.15 tap on Apps in the settings and you see an SIM-Icon light Grayed out. See the Screenshot in Post SIM configuration app (Konfiguration) can't be deleted and won't stay in folder after reboot
Sorry for my bad English. Mit fruendlichen Grüßen Uwe

Hi, I stay in English, so others can read this too.
(Short in german: WLAN hat funktioniert, SIM-Karte nicht. Das adaptation-common Repository war noch von 4.3.0.15. Geholfen hat dann der Austausch auf das korrekte Repository.)

In my case WLAN was working but the SIM card (Vodafone) could not be detected. The solution I found in

(Thanks to everyone there.)

“ssu lr” showed an adaptation-common repository from 4.3.0.15, all others were from 4.4.0.58. Since WLAN was working from a computer I used Putty logged in as nemo and then devel-su. I did:

ssu re 4.4.0.58
ssu rr adaptation-common
pkcon refresh
pkcon install ofono-ril-binder-plugin

A reboot was not neccessary. Immediately a pin code for the SIM was requested on the XA2 and everything is fine again.

(“ssu lr” shows the adaptation-common repository from 4.4.0.58.)

Best regards (viele Grüße), Uwe.

The block after the “After 4.4 upgrade …” in my post above came automatically by inserting the link. I did not inserted the text in this block…

I have testet today the very long ofonod-command: It shows as Result: Unable to register D-Bus name: Name already in use: Exit*.

The SIM-Card was detected after 10 seconds in my 4113 XPeria 10 DUAL-SIM


ssu lr
Enabled repositories (global):

Enabled repositories (user):

Disabled repositories (global, might be overridden by user config):

Disabled repositories (user):

ssu re 4.4.0.58
Changing release from 4.4.0.58 to 4.4.0.58
Your device is now in release mode!
ssu rr adaptation-common
pkcon refresh
Zwischenspeicher wird aktualisiert Starten
Software-Liste wird aktualisiert Fertig
pkcon install ofono-ril-binder-plugin
Auflösen
Abfragen
Änderungen werden getestet
Fertig
Schwerwiegender Fehler: ofono-ril-binder-plugin-1.2.6-1.4.2.jolla.armv7hl is already installed

I have the same issue… sim card stops working. then i changed to slot 2. it worked. after a restart i put it back in slot 1 and worked again. after a while stopped working again… Xperie 10 II with drillisch als provider.
Edit: 4.4.0.64 The Problem with SIM Cards still exists. after Update SIMcard was not recognised in Slot 1 so i moved it to slot 2. after restart moved it back to slot 1 as it was showed as available. what a mess!