[4.1.0.24][Xperia 10ii] Android apps cannot use mobile data

REPRODUCIBILITY (% or how often): 100
BUILD ID = OS VERSION (Settings > About product): 4.1.0.24
HARDWARE (XA2, Xperia 10…): Xperia 10ii dual sim
UI LANGUAGE: German
REGRESSION: (compared to previous public release: Yes, No, ?): Yes

DESCRIPTION:

Most Android apps claim to be in offline mode when mobile data connection is active.

PRECONDITIONS:

Mobile data enabled

STEPS TO REPRODUCE:

  1. Enable mobile data
  2. Disable Wifi
  3. Start Android app that connects to the internet

EXPECTED RESULT:

Andoid app can access the internet

ACTUAL RESULT:

Andoid app claims that the phone is offline

ADDITIONAL INFORMATION:

It seems Whatsapp is the only Android app that can access the internet when connected via mobile data.

All other apps tested say there is no internet connection available (Spotify, Strava, Nextcloud, …).
All native apps can access the internet without any problem, so mobile network settings seem correct.

Network access permissions of the Android apps are set correctly, it seems. Sim card is Telekom Germany. Sim slot is sim1.

I am on 4.1.0.24 too with a 10ii, and I can say that all Android apps seem to have internet access for me.

I am also on Xperia 10ii dual sim …
Sometimes – for unknown reasons – I also had no internet connection for Android apps after the switch from WIFI to mobile data.
I always could resolve it by stopping and re-starting Android support from the settings.

1 Like

I have already tried that, and also tried to switch to flight mode, and back to online mode. Behavior stays the same.
Even network restart from the Sailfish utilities does not help.

I basically have the same issue (reported here)

Hi,

I have Sony Xperia 10 Plus dual sim after upgrade to latest version same issue with mobile data only WhatsApp have connectivity. All other android apps doesn’t connect saying offline. Native Sailfish browser is fine. Any idea for a fix.

Not a fix but hopefully a workaround:
Go to Settings > Android App Support. Tap Stop. Wait. Tap Start as soon as that button gets enabled.
Try using Android apps via mobile data.

I have to add to this that now it also happened to me twice; no internet for android apps. I could, however, recover from that by stopping android support and starting it again, as advised in this thread.

10ii / 4.1.0.24.

Restarting Android App Support is working for me as fix.