[4.1.0.24][4.2.0.21][Xperia 10 ii] [XQ-AU51 Single-SIM]: Pulseaudio dies with coredump. No sounds in device

REPRODUCIBILITY (% or how often): 100
BUILD ID = OS VERSION (Settings > About product): [4.1.0.24]
HARDWARE (XA2, X10, X10 II, …): [Xperia 10 ii]
UI LANGUAGE: Español
REGRESSION: (compared to previous public release: Yes, No, ?):
Don’t know. The device is new.

DESCRIPTION:

After flashing Sailfish to my Xperia 10 ii, the device does not play any sounds.

PRECONDITIONS:

Android version previous to flashing is 59.1.A.2.145
It cannot be rolled back.

STEPS TO REPRODUCE:

  1. Unlock bootloader.
  2. Tried Android for 2 days. All hardware works OK, including audio recording/reproduction.
  3. Android version is 59.1.A.2.145
  4. After flashing Sailfish, pulseaudio dies with coredump.

EXPECTED RESULT:

Audio should play normally.

ACTUAL RESULT:

No audio at all.

ADDITIONAL INFORMATION:


I notice you are using 4.1. Version 4.2 is out; try to upgrade to that…

If you are comfortable with a commandline you can try downloading a file and replace the missing cirrus_sony.cal file from a forum post

1 Like

Hi.

Thank you for the file:

I downloaded it, copied it, changed permissions (according to info I got from the Spanish TG SF users group)…but that did not work.

There’s something else which is wrong…

Edit: I also tried with the file you provided with version 4.2 the first time I flashed the device, and it didn’t work either… (This is the second attemp flashing Sailfish on it)

Best regards.

Then you need someone more knowledgeable than me.

1 Like

Hi.
Thank you anyway.
Can anyone please point me to the sourcecode for pulseaudio in Sailfish? Gitlab? Github?

Thanx in advance.
Best Regards.

1 Like

4.2 images are out, so I would try reflashing the device with it.

1 Like

Hi.

Thank you all for your responses.
I have upgraded to 4.2.0.21 and the result is the same.
I’ll change the title to reflect this.

Best Regards.
Pasko.

Hi.

I made a few more tests but the problem persists.
I have detected four systemd units failing after reboot:

failed

I suspect that the mounting of some filesystems is either wrong or broken.

Restarting the affected systemd units didn’t help, by the way…

Best Regards.

Upgraded via the menu? (or another way) or reflashed.
Two different things.

1 Like

Hi.

I tried both ways: via menu and reflashing. It makes no difference regarding this issue.
My device is single-SIM variant:
Can anyone please confirm that XQ-AU51 works ok for them? I’ve used the device with Android for more than two weeks with no issues…

Best Regards.

As we enter “the mystical era”, I suggest downlading the image files again and double checking the checksums. (I had issues with a memory stick corrupting files, that was fun…) Also try, if possible, to use another computer and/or OS to flash the device, as the fastboot-device-pair can be real picky at times… Also double check the device model and variant for the correct images and blobs (been there, done that, too)!

Well, it’s good that in Android sound works! The device should be fine then!