[4.0.1.48] Notifications from Android apps not shown

REPRODUCIBILITY (% or how often): 80%
BUILD ID = OS VERSION (Settings > About product): 4.0.1.48
HARDWARE (XA2, Xperia 10…): XA2
UI LANGUAGE: German
REGRESSION: (compared to previous public release: Yes, No, ?): 3.4 NO

DESCRIPTION:

Notifications from Android apps are no longer displayed automatically since the update to 4.0.1. Regardless of whether the app is closed or running in the background. The application is activated in apps as “Allow background services to start when switched on”. Sometimes notifications appear with vibration but no sound. I can’t see a pattern.

PRECONDITIONS:

STEPS TO REPRODUCE:

  1. Install Android App with Notifications e.g. Blabber.im
  2. Mark App “Allow background services to start when switched on” in Apps Tab in Settings
  3. Trigger a Notification event
  4. No Notification was shown in events view.

EXPECTED RESULT:

If notifications from Android apps occur, they are displayed with the settings (sound + vibration) in the Events view.

ACTUAL RESULT:

No notification was shown. Sometimes a notification was displayed rondomly.

ADDITIONAL INFORMATION:

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)
I’ve tried to solve it by reinstall Aliendalvik, but no luck. I played around with the AndroidNofication App from openrepos, but also no luck. The app chrashes when started a second time after make the settings.

(Sorry for bad english, i’m trying)

1 Like

There may be hiccups with some apps but generally speaking, the notifications are not broken.

The screenshot is from my XA2 running 4.0.1.48.

Same here - Signal works consistently and I do recall seeing notifications from the android store.
Does this only happen with blabber?

Hey guys,
I also have difficulties with the android notification. In my case the LED doesn’t turn on with apps like elements. The message is received, the notification at the top of the screen appears for some seconds and disappears again. In the past (with sailfish 3.4x this problem was not existend).

I have already reported this issue for version 4.0.1.45… It is still not solved yet.

Greetings

I’m getting no notification on Incoming calls via Telegram. Anyone else?

Sorry for late answer, I’m very busy these days.
I’ve watched it again for a while now.
I can confirm, notifications from Android apps are shown in eventsview.
My problem is, I don’t notice them because the phone isn’t always in front of me. It will appear in banners at the moment of the event. If I don’t look at the display at the moment, I will miss the notification. There is no sound and the LED does not flash. That was different with SFOS 3.x.x.
I missed many of my messages, because I am not one who constantly looks at the cell phone, I need sound and LEDs.
I will open a Ticked on Zendesk.

Greetings from Thüringen, daniel

did day give you any solution?

No, the problem continues. Or better again. I had a workaround from Jolla Support. The file /usr/share/lipstick/androidnotificationpriorities to supplement an entry for my messanger blabber.im. That worked. The upgrade has reversed the change to the file again.

1 Like

Perfect!!! This workaround works perfect! This is exactly what I’ve been looking for!

In /usr/share/lipstick/androidnotificationpriorities I added the lines
Delta Chat;chat,chat_exists
package:chat.delta;chat,chat_exists

And voilà: The notification on the lock-screen and the LEDs work perfect!

Thank you very much for sharing!

1 Like

Do you know how can I identify in which package my Android App is? I want nextcloud talk to add it to lipstick. Thank you!

Hey Calinutzzz,

after installing you can find the app package name here:
/android_storage/Android/media

in case of Nextcloud talk it should be: com.nextcloud.client

So the whole entry should look like this:

Nextcloud Talk;chat,chat_exists
package:com.nextcloud.client;chat,chat_exists

Please do not forget to restart your device to let this change take effect.

Please give feedback if it worked!

Good luck!

1 Like

Thank you very much! That was it!!!