[4.0.1.45] Whatsapp does not get accounts from Nextcloud CardDav Xperia X

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product): 4.0.1.45
HARDWARE (Jolla1, Tablet, XA2,…): Xperia X
UI LANGUAGE: English UK
REGRESSION: (compared to previous public release: Yes, No, ?): yes, working in 3.4

DESCRIPTION:

After upgrade to 4.0.1.45 Whatsapp does not get the contacts if they are synced from Nextcloud Carddav. Contacts saved locally are fine. Contact app has been started beforehand to accept the new permissions.

PRECONDITIONS:

Have a Nextcloud accounts configured with contact sync.

STEPS TO REPRODUCE:

  1. Sync contacts from Nextcloud.
  2. Have Whatsapp installed
  3. Start Whatsapp and only see the numbers.

EXPECTED RESULT:

Contacts should be shown with name from People app.

ACTUAL RESULT:

Only numbers are shown.

ADDITIONAL INFORMATION:

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

1 Like

Same with Google account, also tried my previous workaround, but didn’t helped:

devel-su
rm /opt/alien/data/data/com.android.providers.contacts/databases/contacts2.*

My issue is most likely different, but does your WhatsApp work e.g. after you reboot the phone? I can’t close WhatsApp or it breaks, but the contacts show up just fine. I had to remove WhatsApp, reinstall it, register my number and restore the latest backup on order for it to start in the first place.

Yes, works fine apart from the synci thing.

Actually for me none of the Nextcloud contacts are visible in the people app, consequently not available in Whatsapp.
@PeperJohnny, @direc85: do you see contacts which are not stored on phone in People app?

Edit: I needed to enter manually the relative URL for the address book in the NC account advanced settings, then the contacts showed up in People app - I figure this is a bug/regression.

Weird for me the default paths worked fine.

I reported similar problem with MS Exchange accounts:

https://forum.sailfishos.org/t/4-0-1-45-whatsapp-does-not-get-contact-information-from-microsoft-exchange-account-xperia-x/4661

I tested with Telegram Android client and it works there. Seems to be Whatsapp specific.

Same problem here. After upgrade to SFOS 4, all contacts in Whatsapp are gone. Using MS Exchange sync for contacts and calendar. In Threema all contacts are still there. A manually added local contact in phonebook also does not sync. Please help!

Hi!
Same probleme here with my Xperia X. No contacts available in Whatsapp and I don’t see name in existing conversations, just phone numbers.
I don’t use sync with anything.

I worked around this by exporting my contact from Nextcloud and importing them into the Phone via Settings -> People app and it’s working fine with that. Although my sync is not needed then :confused:

1 Like

I have encountered the same issue with my Xperia X, contacts from nextcloud are not synchronised to the phone (but the other way around, yes), so that they are not recognised by whatsapp/android. So only contacts that I have added on my phone show up in whatsapp (and show as both on the phone and in nextcloud)

Thank you for the post. We created a bug report for this.

1 Like

Hello,
I am not sure creating a thread just for my case is necessary, but it looks like I am the only one that don’t see his contacts on whatsapp since the last SFOS update.
For people I have already chated with, I can only see there numbers. But I cannot start a new conversation with someone new and I cannot create a new group. There are no people in my contacts list.
By the way, my contacts’ name does not appear on whisperfish (native signal app) either, could it be related?

Are you using some cloud service to store your contacts and sync them from there to your phone?

If that is the case then no, you are not the only one. This problem seems to affect only older Android compatibility layers (i.e. Xperia X with Android 4.4 and older). And it affects only WhatsApp, not other Android apps.

And contacts that are stored only locally in phone’s own address book do show up in WhatsApp’s address book. So do contacts that are created on the phone and THEN synced to cloud service (because that way a copy of contact information is created in phone’s own local address book).

It’s a regression that happened with update to Sailfish OS 4.0.1. And according to comment in this thread an internal bug report has been created.

Thank you for your answer. But no, I am not using any cloud service to store my contacts. They are all stored locally in phone’s own address book but don’t show up in Whatsapp. I might have synchronised once with google account but not anymore.

Have you tried the workaround that @samule posted earlier in this thread?

Yes, I did try it but it did not work. I’m a bit lost…

For me the workaround also didn’t work :frowning: