[3.4.0.22] XA2 phone calls no audio

Hi all,

I also have this problem since yesterday. Same problem and similar setup (4.0.1 + XA2 single-sim) as @Induhvidual, except for the power cycle.

After recharging, and rebooting the problem is still there.

I have had cases where multiple reboots were necessary.

Did you try to reboot without the sim card and putting it back inside?

I will try later. Thanks for the idea.

After some restarts, it appears to work again.

I hope it lasts…

Starting the first call with headphones plugged in seems to trigger the problem.

This happened to me first time in Sailfish 4.0. Thought the phone broken so to test it I mounted Android back…no problems …I rebooted many times the Sailfish and nothing happened. Waiting for the next phone before I test Sailfish again Sad but cannot have a phone with such a problem

As it seems the problem is a rare one.

Maybe rare by devistating in these times when you wait a call from your Doctor and do not know that it can happen. Did not think that you must look at your phone at all times. Cannot think the meaning with this OS is to have a spare phone with you all times. it has to be adressed.Ihave used Sailfish from the beginning and MeeGo before that so I can take many gliches but this is no good.

4 Likes

I never had this problem before.
But after upgrading a XA2 (Plus) from 3.4.0.24 to 4.0.1.48 there was no audio in telephone calls. The ringing was ok and a connection was established, but the telephone partners could not hear the other one. Restarts did not help.
By chance I stopped WLAN and restablished it. Afterwards the audio in telephone calls was working.
But of course I’m not sure if this is a always working workaround or just a “one-hit wonder”.
Best regards, Uwe.

1 Like

I do also have this problem for the first time. It happens quite often since 4.0.1.48 update. Sometimes several reboots are needed to fix it. I use a XA2 H3113.

I’m hitting this bug so often now that it’s driving me nuts. I have my phone often in “Flight mode” and when I deactivate flight mode, I cannot get audio on a call directly leaving flight mode. I have to reboot (once or sometimes more) to be able hear something on the other end of the call again. I’m now getting used to call to voicemail first, just to avoid the embarrassment of not being able to communicate during a call with a cellphone. I believe I had this bug already since around version 3.0 on my XA2 single sim.

Any update on this, Jolla? I really hope you can squash these basic phone functionally bugs!

4 Likes

Has this topic been discussed at the community meeting?

I don’t believe this was discussed during the last community meeting. I don’t believe it’s the right place to discuss individual bug there.

In the meantime, I’ve tried various things to try to get a reproducible version of this bug. So far I had most success with (1) switching the phone to flight mode, (2) reboot, (3) listen to music over the headphones & wait for a couple of minutes, (4) turn off flight mode. Then, try to make a call, if you don’t hear the dial tone, you got bitten by the bug.

I have experienced the same issue at time to time. Calling through Signal/WhatsApp works ok but making telephone calls requires one or two reboots. My phone is XA2 and using the latest SW 4.0.1.48 but the issue has been there at least a year.

Nice to see this made it in the newest image I just downloaded. :slightly_smiling_face:

I am also having this problem, on a freshly installed XA2 (build 4.1.0.24).
A reboot fixes the problem, but this is not an acceptable solution !

I paid 50 bucks for this OS, I am expecting that this kind of functionnality works out of the box !

1 Like

Does killing adsprpcd bring back audio wo reboot?