10III crashes with beep when plugged into docking station

REPRODUCIBILITY: 100%
OS VERSION: 4.4.0.68 (Vanha Rauma)
HARDWARE: Sony Xperia 10III (XQ-BT52)
UI LANGUAGE: En
REGRESSION: ?

DESCRIPTION:

Plugging USB-C into display with power delivery or smart hub with attached display causes crash IF a computer has been plugged into it before.

PRECONDITIONS:

I have now tested this with a selection of hub with a display attached.

STEPS TO REPRODUCE:

  1. Plug your computer into your docking station with display, or display with power delivery
  2. Unplug computer
  3. Plug in Xperia 10III

EXPECTED RESULT:

The phone will start charging (and possibly detect the auxiliary devices plugged into the hub), like my previous Xperia 10II phone does.

ACTUAL RESULT:

The phone dramatically crashes, “power-attached” bleep sound turns into extended scream.

MODIFICATIONS:

Added F-Droid, Aurora, Chum, Storeman repositories and apps from these.

ADDITIONAL INFORMATION:

I suspect the 10III is trying to do something with the display, as the crash does not occur if there is no display attached to the docking station. I’ve tried this with the Dell 7-in-1 DA310, and some other random Dell docking stations and power delivery displays at work (sorry, didn’t write down types of those).

4 Likes

Reproduced something similar at least twice. I think the crash was from there being a display, and the beep-of-doom, when there was also charging.

1 Like

I use a Targus USB-C 4K dock with Power, I cannot reproduce the problem. My device (Xperia 10 II) does nothing, no charging, no recognition at all.

I’ve just this morning figured out this dramatic crash happens also to a freshly booted Xperia 10III, the docking station need not have had other devices plugged into it before. Will attempt to investigate further.

1 Like

I have a Lenovo USB3+TB3 docking station and I experienced this while I ran out of USB ports and wanted to charge my X10III quickly… I have two DisplayPort-connected monitors, an USB dock with a keyboard, a mouse (dongle) and an USB microphone connected to it.

I can reproduce this bug with an EIZO EV3895 display (integrated docking station), Dell P2720DC display (with integrated USB-Hub) and Lenovo ThinkVision P27h-20 display (integrated docking station).
Before I flashed my Xperia 10 III to Sailfish OS, I connected it to yet another Dell monitor (U3421WE with integrated docking station), and it was able to charge and use the monitor as a display (Although the resolution didn’t really match). On the same monitor, the same device crashes when running Sailfish OS.

1 Like

Thanks for all of the testing everyone has done here, and for raising the issue. To summarise, it seems that at least the following are causing problems (please correct me if I’ve got any of this wrong):

  1. Dell 7-in-1 DA310.
  2. Various other Dell docking stations.
  3. Lenovo USB3+TB3 docking station.
  4. EIZO EV3895 display (integrated docking station).
  5. Dell P2720DC (integrated USB-Hub).
  6. Lenovo ThinkVision P27h-20 (integrated docking station).

I’ve recorded all this in our internal bug tracker and have tagged this topic is “tracked”. If there are updates to share on it I’ll do my best to post them here.

I suspect anything with video capability causes issues. A very generic USB-C-to-HDMI adapter does it too.

2 Likes

Thanks for the clarification @attah. That’s definitely the impression I was getting from the discussion here, but good to have it reaffirmed.

1 Like

One thing which may be worth adding: I can reproduce this on my EIZO EV3895 with a primitive USB 2-charging cable from IKEA (no USB 3/alternate mode lines connected, only power delivery and USB 2.0/1.1, verified using the C2C caberQU cable tester).

Thanks @Cmdr_Zod, that’s useful to know; I’ve copied over your comment to our internal bug report too.