10 iii and ii touchscreen events? Difficult to click URL's, v-hard to click-n-hold/double-tap for new-tab/copy-text operations

REPRODUCIBILITY: 100% (for multiple users)
OS VERSION: 4.4.0.64 / 4.4.0.68
HARDWARE: Xperia 10 iii / Xperia 10 ii
UI LANGUAGE: English (plus possible other)
REGRESSION: Yes (Compared to my old XA2 Plus)

DESCRIPTION:

The general performance of the Xperia 10 iii is evident in the silky way the desktop/webpage responds to scrolling up and down with a finger slide, but touch interactions with the web browser are extremely problematic:

They ignore/miss regularly, require incredible precision.
I frequently have to zoom in massively, repeatedly stabbing at the hyperlink to get the browser to respond to a command.

And I really struggle doing the following two operations (that work flawlessly on my old XA2 Plus - despite struggling a bit performance wise):

1. Click and hold on a hyperlink to prompt for “Open in a new tab”
Can get it to work on big hyperlink buttons, but not on reddit style text hyperlinks.
I can see the hyperlink highlighting under my finger, but screen is still jittering and mostly fails to prompt the pop-up.

2. Double tap on text to prompt for copy-n-paste functionality
This can be done if I really try, but in day to day operations it often simply fails to respond.
And if it does respond by opening the copy quotes on text, i can’t seem to get the follow through to accept the selection for copying.
The quotes just sit there on the screen, allowing me to adjust the amount of selectable text forever.

n.b. I should say that my generally pleasant web navigation experience on the XA2 Plus has been using Firefox, but in writing this I have tried the same operations on both phones using the Jolla browser, and the user interaction is easier and more reliable on the old XA2 Plus.

PRECONDITIONS:

Using the Sailfish browser.
This behaviour isn’t seen in Firefox from Aptoide

STEPS TO REPRODUCE:

  1. Open Sailfish browser
  2. Navigate to a text-link heavy page
  3. Attempt any of the following; tap-to-click / tap-n-hold / double-tap

EXPECTED RESULT:

tap-to-click - hyperlink opens.
tap-n-hold - bring pop up offering “open in a new tab” options.
double-tap - to bring up copy-n-paste function.

ACTUAL RESULT:

tap-to-click - tap is ignored - requires large screen zoom and excessive concentration to actively clock the desired link.
tap-n-hold - tap is ignored - requires excessive care to activate the pop up.
double-tap - tap is ignored - or if it does work, may not follow through to offer the copy options

MODIFICATIONS:

Fresh install to 4.4.0.68

ADDITIONAL INFORMATION:

Lots of discussion from other users from both .64 and .68 as well as 10 ii and 10 iii handsets:

Affected users include:
PeegeeTips - 10 iii / 4.4.0.68
Thigg - 10 iii / 4.4.0.68
pmelas - 10 iii / 4.4.0.68
Seven.of.nine - 10 iii / 4.4.0.64+4.4.0.68
d.geelen - 10 iii / ?
wetab73 - 10 iii / ?
Schniki12 - 10 iii / ?
gaidheal - 10 iii / ?
Linuxman - 10 iii / ?
Mohjive - 10 ii / ?
silta - 10 ii / 4.4.0.64+4.4.0.68
direc85 - ? / ?

Some suggestion that this relates to inappropriately long screen interaction time-outs, and that this particularly affects the newest handsets due to the slippy nature of their screens - causing the screen to detect ‘continued movement’ during the overlong timeout period before interaction is initiated by the phone in response to user input.

2 Likes

I have the same experience on Xperia 10 III. I had assumed it was just a poor UI of the stock browser, so it’s good to hear that it actually is working on other devices as that implies its a bug that can be fixed.

1 Like

I have the same experience. Since the Xperia 10 III is my first device where I use SailfishOS as a daily-driver, as I tried performing these tasks and they did not work, I was just assuming the stock browser doesn’t have this functionality (tap-and-hold for opening links in new tab)

1 Like

Can confirm on Xperia 10 II. Selecting text in browser is really challenging my patience. :grin:

1 Like

Mine is also 10 iii / 4.4.0.68

1 Like

Noticed this since migrating to 10iii from my XA2+

1 Like

I made (and make) similar experiences only on Volla / 4.4.0.64, but on Xperia 10 / 4.4.0.68, everything runs fine.

1 Like

Xperia 10mk3, the same problem with url links.

1 Like

Thank you, all.
Getting to be quite the list now in the OP.

Tap-n hold: you have to tap 3 seconds to mark a word in the Browser. A bit to long for my taste.
sometimes I move the tab a bit to hit the link better.

2 Likes

As I wrote in the other thread, IMO the problem is caused by two factors:

  • much too long time one has to hold the finger still for the gestures to start working
  • the X10 III screen being very slippy.

XA2 Ultra’s display is much less slippy, which makes it much easier to hold the finger dead still, hence no such problems on the XA2. X10 III display is so slippy that holding the finger still that long is a real challenge. You try to hold it still but you can literally see how it slips.

In Fennec/Firefox, the timeout of tap-and-hold gestures is much shorter, like 1 second or so. So it is much easier to avoid finger’s movement. Hence no such problems in Firefox. In the native browser the time it takes to hold the finger still is twice (or even more) longer, so the finger simply slips in the process, which cancels the gesture.

As there is no way to reduce the X10 III’s screen slip (other than putting some foil on it that might reduce slip), I guess the only solution is to shorten the time it takes to hold the finger still for the tap-and-hold gesture, so that it is similar like in Firefox (i.e. abt 1 second).

1 Like

So the very interesting question is: Where is the 3 seconds defined? And, where is the next delay defined, when SFOS begins to enlarge the selection (more words, whole sentence)? This time is too short for me, this will be my next tweaks.

1 Like

I’m not available at the Aug 4th meeting, would anyone be available to front the discussion of this bug?

“These IRC meetings are for real time participation and live discussions, otherwise you can post the topic on here and get responses that way.”

Re: the above - if no-one is available then perhaps we can post it there anyway…

I’m also thinking that the touch events are handled in some unfortunate order by the internal browser. When trying to qoute in this forum, after I have marked the text and try to press the “Quote” element, the text selection is almost always removed. It seems that the browser handles it as a touch event outside of the selection rather than a press on the “Quote” element.

2 Likes

Same here on x10 III.

1 Like

I also have all the same Browser link click, hold and text selection issues on the Volla with 4.4.0.64 and with the 10ii (4.4.0.68).