Stock Browser App Unresponsive to Screen 'Clicks'

REPRODUCIBILITY (% or how often): 50%
BUILD ID = OS VERSION (Settings > About product):
HARDWARE (XA2, X10, X10 II, …): XA2, X10 ii, X
REGRESSION: (compared to previous public release: Yes, No, ?): Yes


I now have two XA2s running SFOS - one freshly flashed, the other UI upgraded without issue from 4.3.

On both, and on the stock browser app only, the touch screen is very unresponsive. Sometimes it takes four or five clicks on a link to get it to work. This seems to happen more with links behind pictures or icons than it does with pure text links. The browser often crashes and automatically reloads itself (and the current web page) after multiple clicks to get a link to load.

This is not a screen hardware problem as it happens on both phones and only in the browser app.




  1. Open any web page
  2. Try to click on a link - Sometimes this will work immediately, Sometimes it will take four or five ‘clicks’ for the click to be registered and the linked page opened.
  3. The linked page does always open eventually


The linked page opens on the first ‘click’ 100% of the time


The linked page only open on the first ‘click’ around 50% of the time


(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

The same behaviour has been reported by multiple users across multiple devices - see Browser Screen Unresponsiveness

Thanks for reporting this. It would be helpful if you could test with a fully clean profile.

Since all the browser profile data is stored in /home/defaultuser/.local/share/org.sailfishos/browser/, you can do this by moving this folder to a different location and then rebooting your device.

cd /home/defaultuser/.local/share/org.sailfishos/
mv browser browser.bak
devel-su reboot

All of your browser data will be lost, but you can restore it once you’ve finished testing like this:

cd /home/defaultuser/.local/share/org.sailfishos/
mv browser browser.bak.bak
mv browser.bak browser
devel-su reboot

Note that this isn’t without risk: you may end up losing all your browser-related data. So if this concerns you then best not to try these steps. Also note that the rebooting is a necessary step.

However, if you are in a position to try it, it would be helpful just to rule this out.

Lucky for you Jolla guys that I now have two XA2 phones running :smiley:

With all the reported Sailjail and failed 4.4 upgrade issues and the worry that they would prevent a key app I needed form working, or indeed screw the phone completely, I flashed a clean on my spare Android XA2 to see if everything worked OK first, rather than upgrade my 4.3 Daily driver XA2.

As it happened there were no issues with the flashed XA2 so I then UI upgraded the 4.3 XA2 - which went just fine as well. So now I have two fully working XA2’s on

I will try what you suggest on my backup XA2 and report back.


Nope, makes no difference.

All my bookmarks have disappeared - I assume now in browser.bak - so profile appears to be clean.

  1. Googled BBC News
  2. Tried to click on first entry for BBC News website
  3. Only the third click worked
  4. Tried a different website -
  5. Took five clicks to accept the cookie dialogue
  6. selected a news story - took seven clicks
  7. etc


Will put my profile back again now.

Confirmed on XA2 Utra (, on this forum page, I ran into the same isue trying to hit the reply button. It only worked after swiping the keyboard down.

Thanks for checking. I’ve logged this internally. Unfortunately it’s not something I’ve seen before which makes it harder to diagnose. Would you be willing to collect some logs in case that throws up anything?

I can help by collecting logs too if another configuration could help.
I’m encountering the same issue on my Xperia 10 ii.

Sure, just provide instructions on how.

I have to confirm the same misbehavior of stock browser on two Xperia 10’s and also on a Volla phone.

I confirm this behaviour. If it can help, I noticed that the toolbar easily appears when trying without success to tap a link. It seems as if the tap was detected as a drag and not like a click.


This seems like a likely scenario. The browser is still definitely sensing touch, because the screen is still responsive to movements, just not specific click actions.

Edit: just happened again while trying to post this. Swiped the keyboard down and the click was responsive again.

FWIW, as I have an Xperia X exhibiting this problem which only supports Android 4.x, I went searching for Android browsers to use.

There are versions of Kiwi Browser & Brave Browser available tareted at 4.x, both fairly ancient (obviously), that work OK, except bizarrely the App icon doesn’t display (BUG) on the applications screen. Via Browser works too, with icon.

Thanks for all the feedback and offers to collect logs.

If you execute the following from the command line as defaultuser you should get plenty of log output printed to the console.

EMBED_CONSOLE=stacktrace MOZ_LOG="EmbedLite:5" QT_LOGGING_RULES="org.sailfishos.embedliteext=true" sailfish-browser

It’s hard to say whether this might throw up anything relevant, but if you think it does, it would be good to have a copy of the logs. You can collect the output to a text file “log.txt” using this slightly amended version of the command:

EMBED_CONSOLE=stacktrace MOZ_LOG="EmbedLite:5" QT_LOGGING_RULES="org.sailfishos.embedliteext=true" sailfish-browser >log.txt 2>&1

Ideally it would be good to have two sets of logs: first the output from opening the browser, loading the page, tapping a link so that nothing happens. Second from opening the browser, loading the same page, and tapping the link until it responds.

If you’re willing for these logs to be shared internally at Jolla, please message me with the log output. You should check yourself that there’s no sensitive data contained in any of the logs before sending them.


Where does the system dump the log.txt after testing?

For the second command it’ll store the log.txt in your current working directory (use the pwd command to output what this is).

1 Like

Have the same issue on an XA2+ but did not find out how to reproduce it for the moment.

I launched the browser with the proposed command line.
I was very surprised to notice that the problem totally disappeared!!!
So I relaunched the browser from the app launcher to compare and no problem anymore too!
As if something in the browser config has been reset by this command.

In addition I noticed that copy/paste cursors were unusable before and now it has also been solved by this manipulation.

Hope it helps to understand the problem origin.
At least, it’s a workaround!

That wasn’t the expected outcome, but I’m glad it’s working for you now, and thanks for the information. It all helps.

I’m just bumping this thread in case anyone was able to collect any logs in relation the issue. Unfortunately I’ve not been able to reproduce the issue on any of my devices.

I’ve been getting this issue for ages - especially on cookie settings pop-ups. I was going to start the logging commands above, but initially ran the browser from the command line, and it seems much more responsive to button presses than before. I’ll keep an eye on it, and initiate the logging if/when I get any issues with any sites - it might come back after restart?

But I did wonder if the command line start is relevant?

1 Like