"Your device is corrupt. It can't be trusted and won't boot." after reflashing

Flashed version on an Xperia XA2. I tried to Reflash, and the flashing process itself didin’t promtp any error in the console.

Did you open the boot loader? (or better checked in running android that it is really opened)

Yes, I attempted to reflash my device after Sailfish was broken.

Check once more with adb commands,.
e.g. How To Check If Bootloader Is Unlocked

You haven’t mentioned whether using Linux or Windows, but may need to use Sony’s Emma to restore bootloader unlocked device to Android and start again.

1 Like

I only have Linux or if really necessary Mac available, so I’m currently trying FlashTool, though its setup process really sucks.

I confirm that doing a complete flash with Emma solved this issue on my side. Then you’ll be able to flash Sailfish again.

1 Like

I had the “won’t boot” problem, and for lack of a windows PC, the xperifirm and newflasher tools (see xda-developers forum) were lifesavers. Check the forum posts there if you have troubles with the tools, there’s lots of good info.

1 Like

I have Xperifirm. Is newflasher diffrent from Flashtool?

Resume: I used Flashtool - Xperia device flashing (FOSS) and XperiFirm (not sure) to flash Android on my Phone. I case anyone reads this: To not need to run Flashtool as root, add this udev rule I wrote:

ACTION=="add", ENV{SUBSYSTEM}=="usb", ATTRS{idVendor}=="0fce", ATTRS{idProduct}=="*", MODE="0666", RUN+="/usr/bin/logger [udev] Sony device detected, changing access rights to allow all users."

Then run udevadm control --reload && udevadm trigger.

Now you can start with Flashtool.