Xperia XA2 Ultra bluetooth pairing with BMW

I’ve been trying to get my new (to me) XA2 Ultra working with Sailfish X 4 koli lately (unexpected shutdowns issues detailed here), and one of the issues is Bluetooth pairing with my BMW handsfree. I didn’t try it before I flashed Sailfish X, which was a mistake. :frowning:

I could put the car handsfree setup into discoverable mode and the phone would see it, but could not pair. A little searching here suggested it was a pairing code problem: the phone was expecting it to behave as a headset with 0000 password. So I went all terminal mode on the Bluetooth as described here, but still no success.

My old Xperia X with Sailfish X could pair with the BMW. So can my OnePlus One running UBPorts (Ubuntu Touch) And the new XA2 Ultra pairs just fine with my wife’s Toyota. Also smartwatches like Amazfit and LG Urbane, headsets, and other phones – all seem ok so far. Just not the Bimmer.

So now, I’ve reflashed (thanks newflasher and Xperifirm devs) it back to Android :frowning: and no luck there either! (But it hasn’t done a random shutdown yet . . .) Android says it doesn’t see the car Bluetooth at all! It’s the phone itself? It pairs with anything but my i3 – the watches, headsets, other phones . . . I’ve tried Android 8 firmware ver 50.1.A.5.59-R1A (commercial and journalists) and also Android 9 firmware ver 50.2.A.3.77-R3B (customized HK). What kind of problem would transcend all three OSs? Hardware? It’s such a specific failure . . .

Any suggestions for further debugging/investigation either in SFOS or Android?


I have an XA2 Plus with Koli & it pairs with my M4 for phone calls no problem. It will pair for audio from the media player but no sound comes out when trying to play music.

In summary: phone calls yes, music no.

1 Like

Well, after some mostly fruitless googling, I did see a mention of deleting some other pairs from the car’s list. And even though I’d only used 3 of 4 available slots, I went ahead and removed one. Then I tried pairing and it still didn’t work (still on Android). But I was stuck for another 20 minutes waiting to pick up the kids from school, so I kept retrying it and it worked on (I think) the fifth try. Will have to see if that works on Sailfish, too. I have zero theories to account for that. Update to follow, win or lose.

1 Like