Sailfish X on XA2 Ultra frequent random shutdowns

I got a second-hand Xperia XA2 Ultra Dual SIM to install Sailfish X on. The device seemed physically ok, with minimal wear and tear.

It had been factory reset, so on booting up I did the Android updates, installed the Amazbit app that I needed to create an account, and then started the Sailfish X installation process.

Sailfish X install went fine, everything just as the install instructions said, and the phone operated for a day or two with no problems other than Bluetooth pairing with my car (and only my car) and getting MMS settings right.

But then it started randomly shutting down. Sometimes it would run for hours, sometimes wouldn’t get any farther than the password for the encrypted storage on boot.

Of course I’d installed some of my favorite apps after flashing, so I guess any of those could be to blame. Also, I can’t be 100% sure the hardware isn’t defective. It ran Android for several hours with no issues, but it’s run SFOS X for that long without crashing, too. Like I said, it looked physically fine . . .

So what’s the next step to determine if I’ve got defective hardware or a SFOS software problem? The shutdowns can occur while using the device or while it’s sitting alone on a desk. When it shuts down in my hand I haven’t noticed any excessive heat. It has shutdown while running on battery and while attached to a charger.

Any troubleshooting suggestions would be appreciated. Right now, I can’t use it as a daily-driver phone, so I need to determine if I need to sell it for parts or if I’ve got a software problem that can be resolved.

Thanks!

I had a similar issue, in my case the network ids such as mac address and imei were vanishing and causing the device to reboot, sometimes randomly, other times constantly. The cause of such behaviour it could be: a bad s/w upgrade (some of the OEM upgrades caused random shutdown issues), a badly calibrated battery, or a bad battery. Maybe the android updates caused the trouble for you?

the way I managed to resolve it is not very scientific and might not work for you. Keep the device warm and fully charge the battery, while the device is still warm use emma tool and reflash to the earliest available OEM release, or at least that worked from me.

the official way to resolve it, is by sending the phone to sony service, not sure they will accept liability with an unlocked bootloader.

1 Like

Random shutdowns are almost always a symptom of a hardware problem. This might be as simple as the battery wearing out, or it could be some broken solder joint. Since it’s second hand, replacing the battery should not hurt anyway.

1 Like

How did you diagnose that?

I was afraid of that. Just watched a super tedious battery replacement video. That production music makes my ears bleed, and they sure seem to disassemble the device further than seems necessary just to get the battery out. Almost tempts me to take it to a technician, but they probably wouldn’t really do a better job that I would.

If you still have SFOS try to access settings -> about it shows your MAC bluetooth and IMEI numbers, in my case some or all of those numbers could disappear and the system will reboot shortly after that. I had similar behaviour with Android even in safe mode. In Fastboot and TWRP mode the device was stable no rebooting.

At the end I “grilled” the phone on a heating radiator and reflashed it, that worked, I had few failures using Android10 when temperature was dropping at night, then I relashed the phone to Android9 and it’s solid stable since then. Again not a very scientific way, and tbh I’ve lost confidence on that device, bear in mind that an outside guarantee repair will be expensive, most likely they will replace m/b if you cannot relock the bootloader.

1 Like

I’ve been trying to figure out how to “emma” my device back to android to test it there some more and then possibly reflash SFOS later. (I also ordered a replacement battery in the meantime.) Unfortunately, I get stuck. I found an old PC I could resurrect to Windows with a manufacturer restore disk, and I installed the Emma software and the windows fastboot drivers as mentioned https://jolla.zendesk.com/hc/en-us/articles/115004283713-Reverting-Xperia-device-to-Android-OS-and-reinstalling-Sailfish-OS, but when I connect the phone I get the message “no matching services” which I understand to be that emma can’t find the firmware for the device. It sees the phone, and identifies it, but then pretends it’s never heard of such a thing as H4233. Emma doesn’t have any options to check for “service” updates or anything, any ideas on what to do here?

That’s strange, make sure the device is NOT in fastboot mode, hold Volume DOWN key down and connect the data-connected USB cable ensure that the LED at the top of the display area is lit in GREEN colour.
EMMA should detect the device and display the model and IMEI correctly, EMMA then will search and find available stock ROMS that you can flash the device.
An alternative to EMMA is XperiFirm tool and Newflasher, the first one downloads the ROMs and Newflasher will do the flashing.
My advice before flashing the phone is a) charge phone battery >80%, b) keep the device relatively warm ~30+ degrees, c) flash the device with the oldest possible ROM you can find. On boot run the setup and keep configuration to minimum, check how the device performs, e.g. install an android terminal emulator and run the command uptime -s will show the last boot time, the system about page will display both MAC and IMEI numbers correctly. In my case as I had lost confidence on the device, I kept it running for several weeks like that before flashing back to SFOS.

1 Like

The LED does come on green, and EMMA does show the correct model and the first IMEI, but something seems to break down in the finding the ROMs step.

I’ll try hunting down those applications while the phone rests on top of a PC’s power supply.

Oh good grief. Xperifirm developer had to migrate to a new server (not free for him this time) and is in between hosts at this time. Did send some $ his way for the good work.

1 Like

My main PC has much warmer exhaust – phone sitting on top now at a toasty temp. Lightly brown toasty, not burnt, but not soggy either.

OK, XperiFirm has migrated to new backend servers and the new version that points to them is out – link on xda developers website. Nota Bene, on Ubuntu 16.04, mono (required to run the windows exe) from the Ubuntu repos doesn’t support https connections! Use the version from the mono repos (see mono-project.com). Not an issue in 20.04 because mono isn’t packaged anymore. 18.04 situation unknown. Once I got that sorted out, it worked.

Newflasher does not work when run as normal user in Ubuntu. Says it can’t find usb device with ID 0fce:b00b when lsusb definitely says it’s there. Another NB, run newflasher as root . . . Again, after much head-scratching and useless googling, that’s what worked.

I’ve rebooted now after flashing to early press release of the Xperia XA2 Ultra firmware. 10 minutes in and hasn’t unexpectedly shut down . . .

So I leave these Notas Benes here for “tomorrow me” or anyone else in a similar situation. Hoping device runs ok for indefinite time. Thanks for all the suggestions.

2 Likes