Xperia XA2+ Not charging properly

Howdy, I had an issue pop up last night and just wondering if anyones experienced something similar?
I noticed when I plugged my phone in although it appeared to be charging as normal it wouldnt actually build charge and just stay at the same percent or even drop over time. Ive tried a few different cords and adaptors and heaps of different power outlets but nothing seems to work. Although the one thing that seemed to actually charge it up a bit was the charger/ac adaptor for my nintendo switch, have no idea why that one out of everything worked.
I just also noticed a brief notification that said “not enough power to charge.” Dont get why all of a sudden itd think all my cords and adaptors dont have enough power?

If anyones had a similar issue would love to hear how you fixed it! Thanks in advance.

1 Like

Did you check the hints given in those topics:
https://forum.sailfishos.org/search?context=topic&context_id=9402&q=not charging&skip_context=true
? Especially this?

Cheers! Ill give cleaning it a try just doesnt seem like thats what causing it though. I just noticed today that a cord the didnt work in a wall adaptor for some reason worked in my car.

most threads on this issue always just suggested a hardware problem, but that is definitely not the case. I just had the same problem after using this phone for about a month on android/lineageos, and 1 day of using it on SFOS.
I thought I’d charge it up over night, it just stopped at 47%. unplugged and plugged it in again in the morning, than it would charge up to ~74% before I had to unplug an leave for work.
Plugged it in again this morning at 3% and it just ran empty and refused to charge ever since.
I booted the phone into fastebootmode, now it’s charging as it should. So no, not a hardware issue.

I’m guessing you didn’t get the “not enough power to charge” notification, in which case it might be a different problem.

I had this problem and it was a USB cable that became faulty.

There’s another problem which I think is a loose USB port. If the charging becomes interrupted enough times through a loose connection at your XA2, it decides not to charge. For reasons I don’t quite understand, running SystemDataScope along with CollectD usually fixes it.
This problem happens so much that I have to check my phone is charging if I need it.
To be fair, this could be a problem specific to Sailfish.