Xperia X Won't Charge

Apologies if this is not the right location, but I’m looking for some advice.

I have a Xperia X running Sailfish (several years old now), and the charge port on it has been slowly getting looser for a few months (so the cable would just fall out). I was hoping to wait until the Xperia 10III was supported by Sailfish before upgrading, but I suspect I’ll have to plump for a 10II now.

Anyway, yesterday the phone did not charge properly overnight, and hit 4% and powered off about midday. I needed to know the time quickly, so I powered it back up, saw the time, saw it was on 2%, and then off it went. I plugged it in to charge a few minutes later, but it would not charge normally.

I have various chargers, all of which cause the phone to behave differently. A dumb charger causes the phone to power on the screen, show the low battery indicator with a lightning bolt above it, and the notification led flashes on and off. I left my phone in this state overnight, and now the notification led goes and stays green sometimes when plugged in, but it still won’t power on. the battery indicator still says low battery. Emma does not pick the phone up.

If I plug it into an old 1A Apple charger, then the red notification LED just flashes briefly, then goes off. If I plug it into a Samsung quick charger, the same happens.

If I try booting the phone with the cable out I’ve managed to get the bootloader screen a few times, once I even made it to the Sailfish homescreen, only to see the battery was on 0% and it then reset.

Any suggestions for getting this thing out of deep discharge mode? I’ve read about effectively jump-starting the battery by taking it out and manually charging it, but that’s obviously less than ideal given the stupid adhesive holding the back on. I’ve tried all the various reset button combos - I get the three vibrations but phone comes back in exactly the same state.

I’m in a bit of a pickle as I’ve lost access to all my 2FA whilst this is out of commission, which isn’t ideal!

Minor update.

After posting this I went hunting and managed to find the original Sony charger. Through whatever random combination of plugging/unplugging it and powering it on I got to the home screen again, and it said I had 6% battery. It also said the phone was charging, but as I tried to export my 2FA keys I noticed the battery percentage dropped to 5%, then 4%, then I powered it off cleanly to see if that made a difference to the charging. It does not seem to. :frowning:

When I plug it in now the phone largely sits there with a green notification LED, and a USB meter suggests no current is being pulled. If I plug it into a dumb charger I get the odd flicker of 0.45A before it seems to restart, then tries again. I’m minded to leave it on a dumb charger for a several days to try and see if I can fill the battery up to a decent level and then extract what I can and call it a day.

Have you try to clean up the charging port?
In my case, the charging port was dirty so that the plug no longer fit deep enough into the charging socket.
Cleaning with a small brush could not remove the dirt from the corners.
So that I had to carefully scratch it out with a thin needle and blow it out.

1 Like

I did try that a few times yesterday, yes. There was a surprising amount of lint in there given it looked mostly empty, and it looked really clear when I’d finished. The plug still seems to not “lock” in place, though. Thinking about it, it never really did. I wonder if that was a design thing with the port Sony used. I’ve managed to resurrect my old Jolla 1 with its broken touchscreen so I have something, and that holds the cable properly. It also powered on first time after several years in a box. I bloody love the Jolla 1 - such a great bit of engineering. Breaks my heart my touchscreen went!

My Xperia X sometime have a similar behaviour. A workaround is turn off the phone and press and hold the ‘Volume up ’ button before connect the charger. A blue light will light up, and phone will charge normaly.

1 Like

I think you’re on to something there - in recovery mode it doesn’t reset and continues charging (abet at 0.5A, but that’s better than nothing, and much, much better than intermittent 0.5A!)

1 Like

Can you inspect the USB charger port. I bet it is broken and when you manage to get contacts match and fit to one other it charges.
I had to replace the USB charger port one myself on a bricked phone I bought cheep for testing. I guess those ports are not very robust and if you do not handle them with care they become loose and break.
In the mobile shop they could replace, but I am not sure if it is worth

Looks ok to me - when I looked last the pins were straight and flush, and the plastic tab they’re sitting on looks straight and intact. I don’t have any magnifying tools though, so I’m just squinting down the port with an LED torch :slight_smile:

Over the last few months I did find angling the cable seemed to improve the connection, so I suspect the solder joints could be a bit dodgy. Over the last day I’ve used a couple of elastic bands to hold the cable in place and I’ve had no connection issues, at least when dumb-charging. I guess if the data pins aren’t connecting but the power pins are, that could explain that behaviour.

When trying to use Emma it does recognise it briefly enough to start loading (you know how it waits on the splash screen until a device is connected). It never showed it in the actual tool properly though, and Windows tells me the device is unrecognised.

My Xperia X had the same kind of problem. For a few months to a year, it was solved by cleaning out the port with a wooden tooth pick (less possibility of damaging the port). After a while, it wouldn’t keep the cable in the port (issue was with the port, I tried a whole lot of cables). I solved that by gluing a magnetic cable into it, which was a bit annoying, but I have used the phone for a few months after that. It still does work, I use it now and then for testing app builds.

Just went and checked in - battery is up to 26% thanks to the recovery mode charging. Still won’t charge properly outside of said recovery mode, though, so most likely the port or the charging circuit, I guess. At least this way I can get the data off and use it in emergencies.

The decision now is whether to find an Xperia 10 II now, or try and grab a 10 III on Black Friday and wait for SFOS support next year…

Thank you all once again. The Jolla community is wonderful.

1 Like

I’m having similar symptoms although getting out the lint from the port has helped. some cable connectors work, others don’t or only after ‘wiggling it’ into the right position

There’s a Chinese manufacturer selling replacement ports for the Xperia X. I got one last year but am hesitant to open the case of my only daily driver.
I’ll see if I can find the vendor again and post a link. For Germany you could find some remaining stock of the port on

1 Like

It is tricky to replace.
You need

  • a hot air pistol
  • a set for repairing mobiles (includes some plastics to open the cover)
  • tweezers
  • a special glue to pick back the cover
  • patience
  • watch some videos on the internet

IMO it only means that some of the connectors are damaged and only little contact is given, so that you can not transfer more current to the battery/phone.

Another option would be that the hardware is somehow damaged. In such cases it should be replaced.

It could be also as suggested filled with dirt - you could use cotton with alcohol to clean up.

Not really that tricky. The hard part is opening the cover, which you can do by heating it (with a hairdryer for example) and some tools (like guitar picks, but there are stainless steel foil tools that make life easier).
Once you’ve done that, you just need small-size screwdrivers. No soldering required, the connector is itself connectorized and can be exchanged fairly easily. It is available e. g. on Aliexpress.
The cover should stick in place with the old glue.

1 Like

Well, with home tools you can also break things easier. And regarding the glue it does not work after. It is first hand experience.

The glued back part is also readily available. The bad part for me when taking apart my X was the battery. But you do not have to touch it. Changing the USB board is pretty easy. Be careful with the amount of heat you apply on the back cover. Good luck.

Grab a 10 III and use it thoroughly until SFOS comes out.

From my experience a Sony Xperia phones are very “sensitive” as far as cables are concerned. Some of them doesn’t charge from the begining, some stop to charge after some usage.
Try another one, for me short ones (10-15cm) always work.

I had bought some sticker frames on Aliexpress, but IIRC I did not need to use them since the cover stuck back in place.
The battery is tough due to the sticker. It will most surely break during removal. However, I saw some video where isopropyl alcohol was used to detach the battery sticker (on a Huawei Mate 20 IIRC).

1 Like

My new Xperia 10 III arrived this morning. I also picked up a replacement charge port for the Xperia X so I can have a go repairing it at some point even if the parts become unavailable.

I’m still using my old Jolla 1 with a busted lower touchscreen as my daily until Sailfish for the 10 III gets released, though. Ignoring the old touchscreen fault, aside from the dramatically slower boot time, it still holds up surprisingly well. :slight_smile: