Xperia X: fingerprint sensor inoperative when device encryption is ON

REPRODUCIBILITY: 100% (experienced three times)
OS VERSION: onward
HARDWARE: Sony Xperia X f5121
UI LANGUAGE: French or English


After flashing/reflashing a “virgin” device, on reboot user is asked to scan fingers to save at least one fingerprint. Doing so produces no effect. No fingerprint saved.



  1. Factory reset
  2. Flash the device (SFOS >= with device encryption
  3. Reboot


During first reboot, user scans a finger and saves her/his fingerprint.


During first reboot, user scans a finger but no fingerprint is read.


“Virgin” device (zero setting, zero app, zero patch)


This problem can be avoided if the device is NOT encrypted (SFOS3.2 Nuuksio or earlier), then upgraded to newer stop releases without activation of device encryption.

1 Like

Your bug report is about Have only tested with this version, or is this bug still present on

Not sure, actually: after I noticed three times I couldn’t save my fingerprint (3.3 Rokua), I decided to reset the device again then restart the process from a saved copy of Torronsuo (without encryption), then to upgrade to 4.4 through all stop versions without device encryption. Not really curious enough to try again with other OS releases :wink:

Most important is the latest one or the last one before the bug appears.

And what about on a fresh install of 4.4?

The latest OS release before the bug was 3.2 (Torronsuo or Nuuksio, not 100% sure)

I have reflashed so many times (maybe seven) since last month, difficult to be 100% sure. I think I made one 4.4 fresh install, then could not read my finger (I even tried with my wife’s finger to make sure my finger wasn’t the culprit), then back to factory reset.

Hello, after a mishap with 4.2 to upgrade I have flashed 4.2 on the phone.
The FP reader worked both with the “old” 4.2 (old incremental upgrade, not encrypted ) as well as with the freshly flashed 4.2 (encrypted).
I can’t correlate the FP failure with the encryption activation, at least not on my Xperia X.

On a 4.4 flashed on the same device ( upgrade failed too) FP-related programs get an error Can't open /dev/hwbinder: No such file or directory .
For me it’s a 4.4 specific problem. I’m suspecting some driver/kernel mod failure - but without any proof.


I experienced it three times with SFOS3.3.

What you want to avoid is encryption or fingerprint use (or both?)?
To avoid encryption, (found here), you just can boot into recovery right after flashing, mount /dev/mapper/sailfish-root /mnt and delete /mnt/var/lib/sailfish-device-encryption/encrypt-home. I tried right now and it works.

If you only want to avoid fingerprint because your reader has a problem, can you not just skip the fp step at first boot?

None: encryption and fingerprints are both valuable security tools. However, my experiences since several months tend to indicate not only that those tools are not completely reliable yet, but also may conflict. So, my preference at the moment is this: no device encryption, in order to conveniently lock/unlock the phone with fingerprints.

I will gladly activate device encryption when it will no longer conflict with fingerprint usage, when I know for sure which apps or patches triggered the serious issues I encountered with encrypted device in the past, and when LUKS implementation will use something more serious than a simple five-digit key

I have this exact same issue on mine. Its happening everywhere it looks like

1 Like

I had the fingerprint reader and encryption both working on the Xperia X flashed with 4.1, then upgraded to 4.2.

Once I re-flashed the phone with a clean 4.4 the fingerprint reader wasn’t working anymore.

With 4.1, was encryption enabled after an upgrade? Perhaps flashing with the last version without encryption and then upgrading until the phone is encrypted may give some hint.

Is it possible that your username was nemo and after you flashed it is now defaultuser?

Yes, the 4.1 → 4.2 install was encrypted and the user was defaultuser.

I believe there is a regression with the FP reader (not related to encryption) between 4.3 and 4.4. It feels like there is a file now missing from the rootfs which used to be present in 4.2 (and is hence carried through when people upgrade).

P.S. I went from 4.2 (upgraded from 4.1) to a clean flash of 4.4 because my phone reset itself during a sfos-upgrade to 4.3.

I share a similar upgrade path with @vaskas01, in that the upgrade from v4.2 to v4.3 failed:

  • old install (3.x) upgraded to 4.2, without encryption (“nemo” user): FP worked
  • failed to get 4.3 running ( upgrade => bootloop)
  • 4.2 flashed, with encryption (“defaultuser”): FP worked
  • failed to get 4.3 running ( upgrade => bootloop)
  • 4.4 flashed, with encryption: FP not working (missing /dev/hwbinder, see here)

I think @vaskas01 is on something here: the 4.4 image may miss some FP components/configs compared to 4.2. As the 4.3 upgrade failed and obliged to flash v4.4, the problem became apparent .
Or we both have phones from some defective batch, incompatible with 4.3 and preventing FP to work in 4.4. Or…

is anyone within Sailfish team working on this, it would be good to have the FP sensor working again