[][X, XA2] Continuous reboot

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product):
HARDWARE (XA2, X10, X10 II, …): Xperia X Dual SIM
REGRESSION: (compared to previous public release: Yes, No, ?): No


Update OTA from 4.2. to 4.3 it went well, the device started properly after the first restart, but after a few seconds it automatically reboots and does it all around, it can’t be stopped, it didn’t even help to turn-off. In those few seconds, I uninstalled all applications other than standard SFOS. Before running the update, I uninstalled all the applications that the SFOS installer notified me - Pure Maps, OSM Scout Server, Fernschreiber - and disabled all Storeman repositories.


Update → OTA


  1. Download
  2. Uninstall recommended app
  3. Install


Normal running


Continuous restart without the possibility of stopping it


(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

1 Like

I can’t help as far as knowing why tgat happened, but I wonder if you could force power-off, (press and hold power+volume up until 3 vibrations), and download and flash manually, and see if it’s ok…

Thanks, I suspect something went wrong with the permissions on the file system. In those few seconds after the reboot when the system is “functional”, I tried to delete some file via Filemanager (GUI) as well as in the terminal, unsuccessfully even though it seemed to be done.

Edit: The update was successful, I have version installed, but it is unstable because it is looprebooting.

After several hours of unsuccessful boot attempts, I applied a flash update. SFOS works, but the backup failed to restore, failed to restore the error Notes, so I lost all personal information, including contacts (cca 1000) :frowning:

Same phone, I had the same issues during EA ( reboot - reported here and problems on backup restore).
For reboot, no solution found other than reflash (I’m still on 4.2 for this reason).
For backup restore: see here what worked for me (specifically notes and contacts). My backup was taken with the “legacy” nemo, because I had only applied OTA updates since the 1st Sailfish X version on Xperia X. Recent OS images switched to “defaultuser” (/home/defaultuser instead of /home/nemo) and the backup seems to include some absolute paths referring to “nemo”.

Thank you very much! I was able to restore my backup data. :slight_smile:

Same here. Log attached. Btw, I did have boot normal once after I disable aliendalvik in recovery. However, It happen only once. Maybe coincidence.

1 Like

The exactly same happened to me on an X and an XA2 during

but I was just too lazy to report (as I do not expect any official note/comment to this topic!).

Do you really think reflashing and loosing all installations/modifications/(or even personal data) is a “solution”?
Reflashing, IMHO, is always only last measure to overcome a problem that will not see a solution by @Jolla!
So, would you think of removing the solved flag?

@peterleinchen yes, after a few hours of continuous rebooting, I gave up and reflashed 4.3. Of course, I lost some unbacked up data (documents, downloads, history of some applications), but I need the phone, it’s my main one. :frowning:

Edit: flag removed

1 Like

Tried many times. Still can’t reproduce the normal boot.

It seems nothing abnormal in the log. Is there anyway to gather more information?

If I want to do a fresh install. How to backup and restore data in recovery?

On my Xperia 10 Plus, the phone also reboots without stopping.

found some clue…
Masked sailjaild boot normally.

app require sailjaild cannot open after mask

Don’t know why have boot normally one and only one time before mask sailjaild

it seems there is problem to load the camera at boot. Lock sereen camera always show.test pattern

Masked sailjaild boot normally.

Was the sailjail masking allowing to complete the boot?
if yes, how can one mask sailjail?

I was hoping that would address this reboot issue I faced on - sadly not the case.
I’d want to find a way to upgrade ( as opposed to reflash) to the current 4.4 . The root partition is 8GB (plenty of free space)

Is there a way to have a minimal, boot just enough to ssh the phone ? I can edit config files while in recovery mode, but I don’t know what to start with.

In my case it boot successfully. But the phone freeze and reboot within one minute.

in recovery concole. chroot to /rootfs, systemctl mask sailjaild

(or just within the bootloop time-frame…in terminal use: devel-su systemctl mask sailjaild)

Just updated to, it seems fixed the reboot problem

I have a phone that goes to ‘rebooting’ mode some times. I cannot identify the issue, seems to me more of a h/w issue than s/w.

@michaelmhk thanks for the reply.
I gave up and flashed 4.4 over the broken 4.3 install, I can’t test anymore what masking sailjail gives on my phone.