Xperia X - bluetooth watch problem

Hi all, I have Xperia X and Amazfish app for my Amazfit bip watch. Problem is (according to app author) in disconnecting bluetooth whenever phone falls to sleep. Is any way how to solve this?

??? noone knows this?

You could try:
mcetool --set-suspend-policy=early

You might need to install mcetool first with zypper:
zypper install mce-tools

But I’m not sure this will help. If it doesn’t, or for another reason you’d like to revert back to default settings, use:
mcetool -senabled

Maybe it’s related to this.
Bluetooth turning on doesn’t work

Hi, thanks for reply. What does this command specificcaly does? I have mcetools installed, so I can try :slight_smile:

As I understand it, but I might be wrong:
There are 2 suspend states on sailfish, early and late suspend. In late suspend, some communication is killed, to save battery usage. With the command I found, you disable late suspend, so it might keep communication with your device alive. Or it might not. But it is worth a try.

https://sailfishos.org/wiki/Sailfish_OS_Cheat_Sheet#Blocking_Device_Suspend

Ah, okay. Sounds reasonable. Is necesarry to restart device after executing this command?

I can’t find information on this. Just reboot just to be sure.

So, I have set it up, I will see tomorrow at work :slight_smile:

Hi friend, it looks like you hit a nail on his head :slight_smile: Today at work my watch worked flawlessly, so I suppose you found a solution :slight_smile: THANKS A LOT :slight_smile:

I’m so glad I could help. It was merely a guess, but I’m glad it was a good one.