Xperia X and Rakuten LTE network

Hello all.
As indicated in the title, I have an XPeriaX under SFOSX I’m trying to have it work in Japan on the Rakuten network (which is LTE / VoLTE)
From what I’ve gathered, although VoLTE isn’t supported so far, it IS possible to use LTE networks. The problem is that I just can’t find how to configure it (to make sure the issue didn’t come from there, I used a friend’s phone to fully activate the sim card).

The network parameters, as given by Rakuten are as follow:

  • APN name :
  • APN :
  • MCC : 440
  • MNC : 11
  • APN type : default, supl (also, dun on some devices)
  • APN protocol : IPv4/IPv6
  • APN roaming protocol : IPv4/IPv6
  • PDP : IPv4/IPv6

Pretty much the only thing I’ve been able to configure are the APN name and choosing the protocol through the MMS setting (I believe). I can’t figure out where to configure everything else.
Could anybody point me in the right direction ?


What exactly you do not find to configure?

Settings - Mobile network
Data access point
MMS access point

And you are right, speech (VoLTE) will most probably not work. Else they still have 3G/2G coverage.

The 4G/LTE network itself.
As stated, I’ve configured the 3 elements you mentioned, but it still doesn’t work depite tweaking everything I could.
I might be wrong, but I expect it is linked to the APN types and/or the MCC/MNC, but can’t find a way to change that.

Beyond that, no, they don’t have 2G/3G. Rakuten is slightly ahead of the curve, but the switch to VoLTE is expected to happen worlwide within a few short years. Jolla would do well to get their act together and support it out the box very quickly (I had hope for 4.1, but alas…)

1 Like

But I still do not really get what you are looking for. Or what does not work?

The settings mentioned are for mobile data acess as well as settings for MMS.
And those settings contain all your above mentioned parameters (except MCC and MNC which define the network itself).

Are you connected to that network at all?
For that there is no ‘setting’, just the SIM

I might be blind, but I see nowhere to define the APN types (in rakuten’s case: default, supl and maybe dun).

You are right, I can’t see an “APN type” field too. So without that, I am assuming you are unable to connect to mobile data with that configuration. Might be worth a try to select “Alaways allow” under Roaming.

Also assuming you have tried restarting the device after adding the configuration.

Yes, exactly.
I did what you suggested already, unfortunately with no success.

Maybe something to configure as root with the command line, but I have no idea where.

So, does anyone know which in file or files I could tinker with directly in order to input what I can’t within the graphical interface ?

But you can find the network?

The settings you are trying to change won’t help with that part, only making use of it.
If not, maybe it is on a band that your phone does not support.

If I try to manually select the network, the phone does see it. But that’s as far as it goes, as the access is denied.
Since there was a similar problem on my friend’s android phone until she changed the APN options, I’m hoping I can get a similar result.

Okay, good. As long as you have a SIM-card that should allow you access to it, and they aren’t blocking your phone model for whatever reason, that sounds like it should do it.

Well, it doesn’t. Which is why I want to try and see if tweaking the options will do it.
I’ve finally got an idea of where to look for it, so I’m going to see if I can have any success with it.

Well, that wasn’t very useful…
After changing the options from ‘internet’ to ‘default,supl,dun’, still no luck (even after activating and deactivating plane mode). So I tried a reboot and nothing.
I realized the system has rewritten the APN type to ‘internet’. So, no way for me to change that. There might be one last chance with the MCC and MCN values (if I find a way to tweak them), but I’m not very optimistic.

I’m starting to think this might be the end of the line for me using Sailfish, which is a shame but I need to be able to use my phone.

I don’t think changing your apn type from internet to default should do anything for your possibility to use internet.

MCC and MNC are something your phone can just read from the system information received, not a configuration you make. (They identify the network) Maybe some user interfaces lets you set them, and then make settings related to it, so you can configure settings for networks you are not currently connected to…

BTW: these settings Rakuten Mobile: Initial settings for Prepaid SIM does not seem to match what you have listed.

The settings you’ve found must be those Rakuten uses as an MVNO. The sim I have is to be used exclusively on the genuine rakuten network that’s being deployed right now (and which is LTE/4G, using VoLTE)

So, attah’s remark about the setting gave me an idea: there are no identifiers issued by Rakuten for the sim, so I had always set authentification as ‘none’. But it got me thinking, and I set it as ‘PAP or CHAP’.
'lo and behold, after turning it off and on again, it does connect (as in, it tells it’s on 4G), but drops it a few seconds later.
I’m guessing it’s accessing the network but dropping for lack of identification.
Next step… Beats me so far.


I would try Jolla support. In my experience they do try to help! :+1: That might even help that they give more priority to VoLTE support. :wink:

Thanks for reporting your tests and results!

1 Like