Xperia 10 III support

I use it and it behaves the same for me. (Unlike WhatsApp, which always has its background services active, no matter what I try.)

Using it for a few days now.
Huge improvement coming from a 10 v1, much(much!!) faster, battery life doubled. Was never happy with the 10 I in that regard(Android support started with whatsapp and Signal active), was hard to get a full day on a charge with moderate use. Now with the 10III( higher capacity battery of course) this will(should) never be a problem.
Also, the audio quality seems fine, at least for the few calls i’ve made(I specifically asked).

It’s not perfect though , my SIM card only works in cardslot 2(luckily it does have 128GB storage), and browser still occasionally crashes. Activesync still is buggy.
However, overall very happy with Sailfish again. It seems the extra horsepower makes the experience much better overall, at least for me.

I have the ugly situation that there is no audio and camera support in Aliendalvik for Signal and Conversations.
I can’t record audio messages and take photos directly.
Is there anybody else with this faults?

Works fine for me(in Signal). You should probably check if Signal has the correct Android permissions(camera and mic).
Sometimes these permissions get denied automatically i’ve noticed .

Permissions are ok. I checked it twice.

Not strictly Xperia 10 III related question, but … I will be switching from Jolla C and would like to take opportunity to transfer SMS history.

Catch – I would like to combine SMS history from 2 phones – from Jolla (1) and Jolla C to Xperia.
Also, backup function to SD card on Jolla (1) produces unusable archive, cant’ be imported.

I guess I have to do that “manually” and I don’t know how :woozy_face:

Anyone gone through this before?
Thanks,
b.

So I used backup from 10 to 10 III, and some things got moved, but some not, like notes, mentioned in other bug reports already.
Fortunately SMS history worked just fine, apart from the fact that they now show up with just the phone numbers and not contact names, which might be a problem for you.
Not sure though if backup will work from an older SFOS version, you might want to update your Jolla C to SFOS 4.4, and then try to merge records to that backup from Jolla 1. How? I have no idea. Also, maybe you want to create a separate topic for that, it might be useful for a lot of people!
Edit: Yeah, really sorry but I don’t think you can merge message history in the backup, it is a dump, that isn’t text based. I don’t think it is possible.
Screenshot_20220822_143106

backup messages from command-line on both phones
commhistory-tool export -groups messages-phone-1.exp

then try to import both files on your Xperia, use “import” instead of “export”
maybe it’ll work

1 Like

ok so it would be great to monitor this as it can be a blocker for X10III similar to this one:

TBH, echo during calls hasn’t been an issue to me, as long as I keep the volume low. At least nobody has ever mentioned it during a call…

1 Like

it’s not a problem for you but for the other side and they maybe do not complain because they think it’s like that and it’s also very personal as some people may find it problematic while others won’t bother.
That’s why I personally do not use BT headphones because the voice quality is much lower compared to when I’m using wired headset so the caller hears me better.

Right now it’s a plague and with the remote work it’s even bigger problem that people thinks that wireless headset is ok while it’s not and it’s difficult to hear the other side very often, even when they’re in the room.

True indeed. I also prefer wired headaets because of the poor quality calls via Bluetooth (which is a known problem and some proposals to fix it exist).

Actually, I don’t know why I wrote what I wrote, I shouldn’t have posted it at all. Sorry about that. I’ve had a few notes on that in a few calls, and lowering volume fixed it. Lowering volume is not possible on noisy environments, so echoing is an actual issue. (It seems to be AOSP specific, Android isn’t affected.)

Actually, I don’t know why I wrote what I wrote, I shouldn’t have posted it at all. Sorry about that.

Nah, no worries at all :slight_smile:

This may have been mentioned, but you can apply multiple backups. At this time, SFOS has zero redundancy checks. I know this from experience trying to apply backups with the current Notes bug. Whatever parts of the backup get restored are done. If you opt to run the backup again, nothing stops it from doing so.

My XA2 has THREE duplicate sets of messages from the course of a year, and three attempts to restore my backup. Very tedious and annoying.

So nothing dramatic should occur so long as you are selective with the backup procedure from both phones. Try to backup and restore individual parts instead of making a single massive tarball (the Notes bug will break your restore as stated already).

I cannot wait! I couldn’t gave up on jolla… :slight_smile:
Today! It comes today! I was using 10 mk2 for a while but finally decided that XA2 suits me better. So I come here from XA2, and, from what I read I can expect quite performance boost, right? I really hope it will meet my demand

Anyway I know I’ll see it for myself today but is it really that powerfull that jolla market it that way? :slight_smile:

Camera works in Signal. However, trying to link a device, the (rear) camera does not focus (to scan a QR). The face-facing camera did work (maybe because the focus was already good enough to read the QR).

As well, auto-focus of the camera does not work with PrivacyIDEA.

To link a device with Signal Desktop, point the camera (which doesn’t focus) at the QR-code and just wait a little bit. After a short time, it will recognize the QR code

I had similar problems, scan after restart could work better.

I just checked the camera in signal again: after a fresh start of restart of android app support I am able to take exaclty one photo.
If i try to change camera or take a second one signal tells me “camera not available”/“no ccamera” All permissions for signal ar given.

Hello guys, I have tried to find some info about it, but no Luck. It is not an huge issue (even though it seems to eat the battery bit faster), but I have issues with notifications LED. I have only modified the colors (in /etc/mce/20hybris-led.ini), but the LED does not blink, but stays ON all the time. Weirdly enough, LED does blink, if the phone is on charger (not charged yet). Anybody has same issues? Did you correct it ? Any link or manual what to do ?

Thank you

EDIT: Obviously I forgot to mention, Sony Xperia 10 III :slight_smile: