Xperia 10 III -- fastboot oem unlock 0x... FAILED (remote: Command did not succeed)


[UPDATE] It appears I’ve missed the step reverting to some 0ld Android version – there are probably 2 reason why this happened: (1) font size is small and contrast is (IMO) very bad in that instructions page (the link is almost invisible) ;/ and (2) I cannot understand why such a step is needed and why that fastboot would just not have worked (the usual fixes for “same problem” is to “use usb hub” (therefore I tried that 10-year old machine) (this reminds that 5 years ago when I installed SFOS to Xperia X I might have also install an old os image, but I just could not have remembered that this time) (rest of the message here unmodified (so far…) (let’s see if I succeed now).

Got Sony Xperia 10 III, purchaced SailfishOS licence and now trying to install it.

I think I’ve got all steps in the doc done as instructed (have read it so many times and double checked many times)

First time I tried w/o installing any updates, but after it failed every time, eventually installed all updates (like 4-5 of those, taking hours to complete)

Now the device had android version 12 and informs device has already the latest system updates (Laitteessa on jo uusimmat järjestelmäpäivitykset)

For running that fastboot oem unlock the relevant information (afaic) are:
“OEM:n lukituksen avaus” and “USB-vianetsintä”) which both are enabled, and

Also this “Service Menu → Configuration” shown by that ##…## entered in dialer shows that “Bootloader unlock allowed: Yes”

Now I have tried to run the command fastboot oem unlock 0xC0DE… many
times, first on Fedora 36, 5-year old dell, then Ubuntu 20.04, 4-year old ThinkPad
and finally on Ubuntu 18.04, 10 year old thinkpad…
all of those output the same message:

$ sudo fastboot oem unlock 0xC0DE…

FAILED (remote: Command did not succeed)

(blue led on, usb-c cable connected)

Ubuntu’s have fastboot version 1:8.1.+r23, fedora 31.0.2
– I also downloaded upstream tools, which print out

$./platform-tools/fastboot --version

fastboot version 33.0.3-8952118

all give the same response

It is almost 2’o-clock In the morning, and out of ideas, will go to sleep; hopefully someone have some hints what to try next.

btw: i wonder wether this is relevant:

openat(AT_FDCWD, “/sys/bus/usb/devices/1-2/serial”, O_RDONLY) = 5
read(5, “HQ623Q151F\n”, 255) = 11

I saw some other code in some of the pages i found in intternet…

BTW: you better revert to Android 11.

SO, is my “problem” now that my device (10 III) has “62.1.A.0.645 release-keys” installed, and w/ that version I get this “FAILED (remote: ‘Command did not succeed’)”
message as response from fastboot oem unlock command

( tells
“From Settings, go into Developer options and enable OEM unlocking . To do this, make sure your device is updated to the latest software .” – which may not be true after all ???)

… and I now need to to to a store to buy a windows license in order to run EMMA to install some older android version (hmm, can EMMA do that “unlock bootloader” in the list above, or is there some other command than “fastboot oem unlock” to unlock bootloader, as that is the place I a currenfly failing… so confusing…)

1 Like

Before you go down a rabbit hole; what is your sorurce for that correlation? That rounds very strange.
Now, if you have a “branded” release or whatever that does not allow unlocking, updates will generally not change that. And downgrading probably won’t be allowed either.

That’s apparently well hidden away at the device-specific instructions. Maybe some early versions were iffy. But i’m also not surprised that Sony will always push the latest update at every opportunity “just because”. Trust Jolla’s instructions.

(i don’t know how to quote (and how messy will those quotes of quotes go, so)

…rabbit.hole… → I forgot the question mark

I don’t think I have branded device, OEM unlocking and USB debugging are enabled in developer mode settings, and after entering those dialer commands with '#'s and '*'s and some numbers it shows “Bootloader unlock allowed: Yes”

… and I am still in square one in this case: “FAILED (remote: ‘Command did not succeed’)”

(and I wonder whether it is even possible (if even needed) to downgrade w/o able to unlock – perhaps EMMA can do (and I may be able to find a windows machine to do so if needed… just that all this is so confusing I don’t want keep hitting my head to too many walls while trying trial and error, but rather got some hints how to proceed first)

Do look up the infamous USB3 problem. In short: use USB2 (not just the cable), or a USB2 hub.
And indeed, i did not spot it was phrased as a question. Not making up correlations will indeed save you lots of head-against-wall.

That’s why I also tried using Lenovo Thinkpad T410, published 2010-09-16 (running ubuntu 18.04)

It does not have any USB3 ports, just 4 USB2 ports…

still no suck sess…

just found that when disabling oem unlock and usb debugging in
developer options I get '‘Command not allowed’ and when enabling
those I get ‘Command did not succeed’ (and nothing more to know
what actually is the problem)

haven’t yet got to use EMMA (I don’t know how to get computer for that (W10, admin rights), perhaps virtualbox to pollute a linux machine…). this Olf0 gitlab page may be most useful – at least at
the beginning it is not as vague what not to do while starting…

Triple-check you are copying the code correctly.
Did you use the correct IMEI when generating it?

I’ll check once again the code – have been doing it many times already (and I try the sony web page again for code generation)

in the meanwhile I used newflasher to downgrade from
62.0.A.9.645 to 62.0.A.9.11
– was bit worried after flashing it took time and claimed it cannot
boot – after choosing “factory reset” 2 times it took (again) a while,
then booted, a while and then back to initial install…
anyway, still in square 2. will try more…

got different code this time (it could be that there is some “nonce”)
– and with that:

localhost$ sudo fastboot oem unlock 0xC0DE...
OKAY [ 30.841s]
Finished. Total time: 30.841s

so, if that was it wasting me hours (although I tried to be extra-careful w/ the hex numbers), then…

OK. Now it worked. Probably the problem was misstyped IMEI code

Following the instructions got device flashed to SFOS, just had to

$ sudo fastboot reboot

to get it rebooted.

Thanks for everyone involved.



I tried once again to derive unlock key with my IMEI – and got the same key
which worked when unlocking the device.

So, there is no “time window” or (ecdsa verify style) “nonce” when generating
the key (which would made it impossible to know whether the given input was
incorrect in the first time)

The probable reason is that I failed to get all keypresses through when entering key (and failed to verify that the IMEI was correct in Sony’s web page (*))
– Sony’s web page highlighted [Submit] button one before the last digit so I
thought it was complete (probable reason – some IMEI keys are shorter ?)

So, in case one gets this “remote: Command did not succeed” one (of not the only)
reason is that mismatching unlock key was entered. (*) The best option to prevent
this happening is to take picture of the screen showing unlock key (and copy-pasting the key along the IMEI) – both IMEI and unlock key are shown there.
Then one can verify that the given IMEI was correct. Alternative (i.e. what I did
after a week) is to retry unlock key derivation in Sony’s web page to see whether
the unlock key changes this time (if not then something else is to be tried (**))

The good thing this happening to me is that I used Android 12 for a week. Found
its good and bad things. It was very slicky and snappy, but annoying in many places (perhaps when it asked voice commands “inadvertently” (please no!)…).

(**) all in all, w/ correct codes, SFOS installation went smoothly. just that “everything in computer science” is “exact science”, so any bit not exacty in straight vertical order, can make things break. perhaps tuning documentation
could help (or then not…)

Anyway, thanks for SFOS. 50€ is decent price for the “calmness” it gives me…