Sony Xperia III - Android 12

I could not downgrade and stuck, since there is no way to go back without unlocking bootloader. At least we need clear answer that if we are in Android 12 we must do a bootloader unlock.

Thank you for this, bookmarked.

@Pretzel4Life fwiw XperiFirm does have XQ-BT52:

Indeed doesn’t help as latest FW is Android 12 62.1.A.0.587
Does anyone perchance have the 62.0.A.9.11 firmware saved and could share?

I thought that you have to unblock bootloader anyway if you wish to install sailfish or am I wrong?

1 Like

Yes, it’s clearly stated in the installation docs: How to install Sailfish X on Xperia™ 10 III on Windows - Jolla

OK I finally managed to figure this out. As @kaari states, you need to unlock the bootloader anyway to install sailfish, so that’s not really an issue. It is a bit strange though that this is needed if one just wants to flash an official firmware. For me at least Emma (Xperia Flash Tool) complained that the phone was ‘locked’ and I couldn’t flash it. So it appears to be necessary to first unlock the bootloader even if you only want to flash an Android 11 image.

The latest Android 11 release is 62.0.A.9.11, but this appears to be unobtainium. So as a workaround you need to install a lower version first, I installed XQ-BT52 61.0.A.3.109 GLOBALEEA-A2 (which was an official release available through Emma. After that you won’t receive any OTA updates, because your bootloader is unlocked. So next you will need to re-lock the bootloader, and go through the OTA process to update all the way to 62.0.A.9.11. This is a long and slow process, taking several minutes for each successive update. When you have installed 62.0.A.9.11 you can stop. From here you can finally proceed to install SailFish. The whole process takes like 45m to an hour if/once you know it. To figure this out took the whole evening. Documentation could definitely be much, much, much more clear on this.


  • Unlock bootloader
  • Emma → 61.0.A.3.109
  • Relock bootloader
  • OTA → 61.0.A.3.131
  • OTA → 61.0.A.3.163
  • OTA → 62.0.A.9.11
  • Unlock bootloader (again)
  • Install SailFish

Note: there are rumours/warnings on the interwebs not to lock the bootloader unless your device is on an official firmware, lest it is bricked or gets stuck in a boot loop.


How do I downgrade to or reinstall Android 11 if I don’t have Windows?

1 Like

Using link in this thread and installing firmware with Newflasher should be viable, with folder needing to be decompressed upon Mac OSX with Archive Utility:

I had Android 12 in the 10iii and I have installed sailfishos without going down to Android 11.
I don’t see any operational failure for that.


I also installed SailfishOS after upgrading the phone to Android 12, without any problems.

The only thing I had to do was executing fastboot reboot to reboot the device after flashing (unplugging the cable or pressing the power button did not work)


Thanks for these replies! Tried it and most things went fine. I though had several “WTF” moments:

  • Flashing went fine. When I unplugged the cable the blue LED stayed on and pressing the power button seemed to have no effect. In the end I connected it again to USB and rebooted using fastboot reboot. That worked well. :relieved:

  • When I aborted the tutorial (long time SailfishOS user; since the Jolla 1), it suddenly no more accepted any gestures and the LED went red. It vibrated when it recognised my finger, but that’s all it did in that state. I managed to turn it and reboot of by pressing the power key for quite a while. :face_with_raised_eyebrow:

  • It then asked the PIN twice and the first time the vibration upon typing did not work (but also didn’t look like the normal SailfishOS login). It though seems to do that now with every boot. My XA2 did not do that, even not with the same version ( of SailfishOS. (Although I’m not sure how often I rebooted with that version.)

  • When restoring the backup from my XA2 from a microSD card it at the end stated (in German): “Error: Couldn’t load notes” with a √ behind. And indeed, the Notes application is empty. But not only the notes are missing, also all contacts and calendar entries, i.e. the most important stuff. :angry:

    This first looked like Manual backup to SD: failure to load playlists or notes but that seems about the actual backup failing, while for me the restore is failing.

Not sure if issues or if that’s “just as it is”:

  • The “Network mode” switch only offers 4G, not 5G. I’m not sure if there should be 5G support or not. Android definitely did work with 5G. :disappointed:

Probably “just as it is” and unrelated to any Android version:

  • The backup also didn’t seem to restore any UI settings or similar. (Never tried a restore before though.), but IIRC that never worked. Maybe also related to not having finished restoring the backup. :slightly_frowning_face:

Anyway, otherwise seems to work fine. Didn’t have a phone call yet (just a missed call :upside_down_face:), though.

1 Like

But according to Jolla documentation (, 62.0.A.3.109 should be fine, right? Or am I missing something? Emma gives me the option to flash to 62.0.A.3.17 or 62.0.A.3.109. No 61 versions appear, nor *.9.11.

How do I relock the bootloader, btw?


1 Like

Emma doesn’t show the latest update, but I guess something similar to a stop release? You get the latest updates from within android as an OTA update.

To relock the bootloader simply fastboot oem lock.

1 Like

Yup, same here. WTF, Jolla? This is indeed a dealbreaker, when the backup cannot restore the phonebook on another device!

Btw: I flashed SFOS onto the device when it ran Android 11.


This may help :slight_smile:


Thank you!!

I reflashed following your sequence and the screen wake-up problem ([] XPERIA 10 III - Screen wakes up for no reason -> Battery drainage - #7 by nephros) appears to be gone.

Apparently, selecting the proper Android 11 version from which to install SFOSX is a big deal.

1 Like

hi folks, I am stuck on connecting Xperia 10 III to windows 10 laptop. Emma doesn’t see the device. Also fastboot devices command in DOS returns empty. seems I am missing the right driver, but Windows says latest android usb is installed, also I installed Sony;s xperia drivers sa0114adb.inf from sony site. Tried USB 2 and USB 3 ports. still phone is not visible by windows. The sequence of the steps and software versions ?

Guys does anybody know any tips on how to keep volume up button pressed plus plug in the USB cable end into Xperia 10III at the same time in order to get a blue light? because I am always getting red light and never blue. (USB debugging and developer options are on. wifi is on) thanks.

It starts with red light and then turns blue few seconds later if you had the up volume button pressed while plugging usb in, so red light does not mean it went wrong, maybe this is what’s happening?

Thank you for reply! yes, I had it turn blue (first red and then soon blue) twice out of about 50+ attempts on connection. On a second time I managed to unlock bootloader successfully, but did not have a chance to Emma down the android version from 12 to 11, and now I can no longer get it blue to complete the process of android downgrading with Emma. It never turns blue again (another series of about 20+ attempts). It might be that I got a defective unit in this particular functionality. ?