Xperia 10 III charging issue

REPRODUCIBILITY: Yes, when i am trying to recharge the battery
OS VERSION: 4.4.0.72
HARDWARE: Xperia 10 III
UI LANGUAGE: English
REGRESSION: New

DESCRIPTION:

When i am connecting the changer, it will show as charging. but the percentage doesnot increases. Instead it will be draining in regular pace. Yesterday night, my battery was of 13%, i kept for charging, after 2-3 hours, it was still showing as charging but the battery percentage was 6%. So I switched off the mobile and connected to changer. Started mobile once after the charging has been done

PRECONDITIONS:

STEPS TO REPRODUCE:

  1. Nothing special, just connect to charger, it will shows as charging but it wont be charging

EXPECTED RESULT:

Battery percentage should increase. Phone should get charger, and while the phone is connected to charger.

ACTUAL RESULT:

Instead of battery getting charge it get drained.

MODIFICATIONS:

I had battery buddy, but i removed that

ADDITIONAL INFORMATION:

Right after you ‘change’ the issue to… let’s say “charging issue” :wink: (it seems autocorrection hit twice)
you should try different cables and chargers…that’s what helped me. (Even charger / cable combinations failed to charge my 10III, that woked nicely on 10II or 10 Plus - the issue is not new for me, happened on 4.4.0.68 already).

You can check, if other combinations work, by using e.g. ‘AIDA64’ or ‘Usage’ displaying charging/discharging current.

1 Like

Thank you @tobset . The usage is fine, i am getting good battery backup. Facing the issue, only while charging the phone while it is ON… Same cable and charger works fine, when i switch off the phone and connect to charger.

And during phone ON and charging, its does shows the charging icon. but it does not increases the percentage.

I noticed one charger of mine (samsung) working rather erratically on X III, 80% of the time it will only reach 400mA and it takes a while to even start, while others and laptops go to 1500mA almost instantly, have you tried checking what gets negotiated (battery buddy for example will show you), might be one of those super chargers with proprietary bits that ends up with safe voltage, if you had something intensive running could result in negative net charge maybe?

You can also see the charging current using the CSD tool (click the SFOS version 7 times in Settings).

I believe X10III supports limiting the charge current, but I can’t remember the filename off the top of my head. I doubt it survives reboot, though.

I have noticed problems charging too, and have been trying various things. What is clear to me at this point is that the problem is with the OS and not anything to do with either cables, chargers, or the phone itself. To verify this you can power off your phone from the menu next time it refuses to charge (without removing any cables). It will power off and then power on again into sony’s mini bootloader charging OS, where it will happily start to charge normally. I haven’t had a chance yet to test what happens if you do a reboot into Sailfish.

What I also haven’t found yet is a pattern, it just seems to randomly refuse to start charging, eventhough the battery indicator indicates it is charging (little block with the lightning bolt).

Correct. I too feels, its something related to OS, else it will not behave differently when it is switch off (Charging as expected when switch off)

I run into the same issue today, actually the misbehaviour started while I was charging the phone from a battery bank, it went up to 71% and stopped there. A couple of other chargers also failed to charge the phone battery. Battery buddy was also showing some strange current drain ~1100-1400mA which I do not think it was correct. At the end I had to … reboot the phone and now the battery is charging properly.