Xperia 10 III,, FI Elisa, 4G usually hard, 2G never, "VoLTE" calls only

REPRODUCIBILITY: 2G always, 4G usually
HARDWARE: Sony Xperia 10 III
UI LANGUAGE: Finnisn, En-US, E-UK ← tried ones, for screenshots
REGRESSION: not at least for 4G, worked w/ same version 2023-11 (2G untried for a while)


After booting device, or bringing mobile data back from flight mode, getting mobile connection
up usually does not work out of the box – have to manually retry connections 1-n times.

That is the usual case. sometimes it comes up w/o any manual intervention – sometimes even
almost immediately, sometimes it takes a minute or so…

But that ie 4G only – cannot get 2G to work at all – and most probably that is also reason
“4G Calling (beta)” has to be enabled, otherwise voice calls don’t work (surprisingly SMS message
telling missed call got through)

When I put the same SIM to my Xperia X, (with, both 4G and 2G worked – and calling
when 2G only worked.

I don’t know if that is a coincidence, but FI Elisa dropped 3G in my area around November-December
2023 – tried to find exact time, closer to that there was article dated 2023-12-19 telling 3G has shut
down and what one should do…



  1. reboot device
  2. expect 4G to come up automatically without too much delay


4G mobile date working – and can do phone calls w/o 4G calling enabled !


4G may be denied – and after manual connection retries got 4G connection but without
“4G calling” phone calls don’t work

^^ I am experiencing this in Elisa network in southern Finland. ^^


Patchmanager installed, but 0 patches enabled (could not figure out how to easily uninstall patchmanager)

Situations installed but not active (I used situations to put phone in flight mode over night to
make battery drain smaller – for some reason situations could not consistenly do that…))



^^ When manual attempt to activate Fi elisa failed ^^

^^ When automatic network selection was ‘Denied’ ^^

^^ When attempt to “2G only” just fails ^^

pictures created from screenshots:

1) convert -resize 50% shot.png scaled.png
2) pngquant -f -o opt.png scaled.png
3) optipng --strip all -o9 opt.png
1 Like

I can only say that for me with Vodafone in Germany i am also not able to get internet with 4G. I just can use 2.5G most of the time and sometimes 4G, but only for calls/sms not mobile network ':frowning:

I am getting the following results from testing my Xperia 10 III with the upcoming (“don’t ask when”) 4.6.0 release that contains the latest VoLTE/CLAT fixes. I have a Telia (Finland) SIM card in slot #1 of the phone. I am located in southern Finland.

As far as I can see:

  • VoLTE phone calls work fine
  • Internet access in 4G network works, too - also during VoLTE calls

After forcing the phone to 2G or 3G network (but Telia will ramp down 3G in the next months):

  • phone calls keep working
  • Internet access does not work. The status remains ‘Enabled’, it never gets ‘Connected’. Lack of Internet access over 2G may not be a major issue since 4G works.

I had a problem in munich airport not getting connection at all, no mobile data, no sms, nothing…

After I did that “ofono removal and reboot” i got 4g briefly but then lost it
– and finally I noticed the case was after I enabled mobile data roaming things broke.

(There is 'NO roaming for mobile internet connection" thread where I comment more of that)

And now, at home network I also have mobile data roaming disabled – and 4G is not so hard anymore.

2G is still never.

The interesting thing, probably coincidence, is that wherever there is no 3G network I have these problems. When I was in Austria, phone connected to 3G and 4G networks “as it used to be”. Here in Finland, there i Munich airport and last summer in Crete I never saw 3G networks (in ui, or in cellmon)… but I wonder how on earth that could make a difference…

Later in this post, you wrote that 2G does not work on your phone. If this is the case and if you have “4G calling” disabled and if your operator does not have the 3G service anymore, then it is clear that phone calls can not work.

Would it be possible to uninstall these two apps to see if that would change something? It is probably a fuzzy idea.’

Have you ever tried the builit-in CSD test tools?
You would go “All tests > RF function check > 2G”. Pass or fail?

Tried first CSD test tools 2G connection → Fail

(and 4G pass – immediately after 2G test)

then devel-su and rpm -e patchmanager and reboot

after reboot could not get (even) 4G up. rebooted again.
Tried CSD test tools, 2G Fail, 4G either fail or just kept searcing

After 5-10 minutes got 4G connected

CSD test tools: 2G fail, 4G immediate pass – but then suddenly it went to ‘Searching’ mode.
Waited a long while. when swiped back, saw both sim1 and sim2 and 4G came immediately.
Retried 4G test and pass came immediately.

When I stopped CSD tools use – suddenly, 4G disappeared – only sim1 enabled.
SInce saw that sim2 there, went to enable sim2 – 4G came immediately – disable sim2 – 4G disappeared (sim card in sim slot 1)

Uptime now 33 min – disabled sim2 – 4G disappeared. will wait a while whether I get 4G back witnout enabling sim2

I still have situations installed (but “backgtound application” disabled – will try removing it later – have to see how/whether that “background app” gets removed…)

uptime now 37 minutes – 4G not up yet (i resist temptation to do that “ofono files removal”)

[edit] 49 min: no 4G – will try enabling flight mode and then disabling it and continue waiting

[edit2] 10 sec in flight mode – immediate 4G after disabling flight mode (only sim1 enabled)

– to be clear I have only one sim card, that is installed in slot 1 – in “enabling sim2” i mean enabling the slot2 in settings even there is no sim –

Moved sim card to slot 2. Tried the same things as yesterday, and same behavior (in all cases!)…

The “new” thing is that I could not get VoLTE enabled (would not register).

Moved sim back to slot1, after booted and both slots enabled pretty soon 4G connection,
with VoLTE registered (I can haz fonecalls!) came up!

I also have issues with my network since a longer period of time. I am in germany and even switched my telephone provider to vodafone since someone in the forum wrote that this works for him. But this changed nothing and my phone also needs some time to reconnect to the network… :frowning:

@domo141 @J-One This is a general Xperia 10 III issue, also present on Android (actually all versions I’ve tried, from 11 to 13), not related to SFOS. I have no idea when it appeared and what caused it, but if a single SIM card is used (no matter in which slot) then the phone has MAJOR difficulties to register on 2G network. If “2G only” (GSM only) mode is selected, it sometimes takes many minutes to register (and often it is not possible at all), and even if it eventually manages to register then it drops network again after every communication (phone call, SMS, etc) and again it takes a lot of time to re-register to 2G network. It doesn’t depend on network signal level, it happens even with 100% signal strength. It only affects GSM (2G / 2.5G) connectivity, whereas 3G and 4G work perfectly fine.

I’ve found a simple (but really bizarre) workaround: you need to insert TWO SIM CARDS, in both slots (which unfortunately prevents the use of a memory card). The other SIM card can even be old and no longer active (or the cheapest prepaid card, not activated and not charged with any credit), and then you can even disable it in settings, but it just has to be placed in the slot. As soon as the second SIM card is inserted, “2G only” mode starts working (for either or both cards) and you get instant connectivity to the GSM (2G / 2.5G) network.

Please try if it works for you and kindly report it here if it does.

This is actually the most bizarre thing I’ve ever encountered with a mobile phone. As I said, I have no idea what’s causing it. It can’t be a hardware issue if it only affects 2G connectivity while 3G works fine. It can’t be a SIM slot / reader issue, because it doesn’t matter which card is in which slot. And it can’t be antenna issue if as soon as both SIM cards are inserted 2G network starts working perfectly fine for both slots. I’ve tested it with three different SIM cards from three different Polish mobile networks (T-Mobile, Plus, Orange) and all of them are equally affected. So it is not a network or SIM card problem, either. All those cards work perfectly fine in “2G only” mode on my XA2 Ultra. It looks to me like a software bug, maybe in 10 III modem firmware.

Can anyone else please also test it and report if his Xperia 10 III connects to GSM (2G or 2.5G) network in “2G only” mode with just one SIM card inserted?


I have never had any problems connecting to 2G or rather to 2.5G. The connection is established in ~5 seconds, with or without a memory card. I have only one SIM.

My carrier is DNA and I live in southern Finland.

I just tried this - I had no problems: after 2G Only was selected, I was registered and could make a call in a few seconds

Xperia III on Android 11 as per the standard installation instructions
SIM1: Vodafone UK Contract
SIM2: no SIM (and has never contained a SIM)

It is probably not relevant, but Vodafone UK were recently saying that they have completed their 3G shutdown

Thank you guys, so this is REALLY strange. I’m really trying hard to understand this phenomenon, but it’s beyond me. I’ve tested it with Android 11, 12 and 13, no change, always MAJOR problems with connecting to 2G network when only one SIM is inserted, whereas 3G and 4G connection is instant. The most bizarre thing is that the problem with 2G registration instantly vanishes as soon as the second SIM is inserted (and what’s the most strange is that it can be even an old and inactive SIM, and I can even disable it in settings).

One remark: that second SIM has to have PIN code either disabled or the code needs to be entered, or else it won’t work.

So far I was thinking that it was just my device’s peculiarity, but @domo141’s description looks identical, so it’s clearly the same case.

It would be great if @domo141 could test and let know if inserting the second SIM fixes the problem also for him, as in such case we might try to find some similarities causing such strange behavior of our devices…

Anyway, if everything else fails, I think I’ll send my 10 III to Sony service centre as it’s still under warranty. So I guess it’s up to them to make it work with 2G network with only one SIM, no matter if it is a hardware or software issue…

Xperia 10 III with the upcoming 4.6.0 release
SIM: Telia FI in slot #1

  • connects to the Internet over 2G, 3G, 4G
  • makes phone calls over 2G, 3G, 4G/VoLTE
1 Like

Huh, got lost with replies…

Anyway, I can “reproduce” this, spent 15 minutes trying with my
elisa sim on slot 1 and wife’s dna sim in slot 2

I got 2.5G constantly, may have took a bit of time, and
could connect to internet using the network via sim1 – network
via sim 2 did not work, don’t know why…

1 Like

Thank you for your reply! OK, just to make sure I understood you correctly:

  • with only one SIM card you can’t get 2G / 2.5G connection at all, only 4G and VoLTE calls work?
  • when you add the second SIM card, 2.5G network starts working on SIM 1, right?

If so, then it’s clearly the same case as mine, with the only difference being that in my case inserting the second SIM card makes 2G/2.5G work fine for both SIMs, not just SIM1.

Now, the question is, what the **** is it all about… How can 2G/2.5G network only work if two SIM cards are inserted…?

Yes, understood correctly based on my reply

– Network may have worked on SIM 2, too, I got it “connected”, just that it did not receive IP address during the period I waited (and run CSD tool while waiting which may have interfered – in one try I even had sim1 disabled (while card in); and sim2 internet was announced as it could be used (last pic))

-v- pic to show access works (tried ssh too, it worked) -v-

-v- pic of CSD tool trying to gather 2G info, Fail due it took too long for sim1 to refgister (where internet then worked)

-v- pic (in finnish), showing that when only sim2 active, and 2G only, “dna internet” could be used -v-