No roaming for mobile internet connection

REPRODUCIBILITY: 100%
BUILD ID = OS VERSION: 4.3.0.12
HARDWARE: X10 II and X
UI LANGUAGE: English
REGRESSION: No, this issue happened with earlier OS versions (3 and 4).

DESCRIPTION:

Roaming doesn’t work for mobile internet connection.
Roaming is active in my settings, and whenever I travel in Europe, the mobile data “doesn’t work” (a.k.a No internet connection). SMS and phone calls do work. Network automatically goes back to 3G with a triangle signal. No errors displayed by the system.

PRECONDITIONS:

Have roaming activated in the settings

STEPS TO REPRODUCE:

  1. Activated roaming in your settings
  2. Travel abroad
  3. Wait to get that nice SMS message from your provider about roaming in this new country

EXPECTED RESULT:

When arriving in the new country, the roaming should be done automatically, with your “home” carrier suggesting it’s local replacement.

ACTUAL RESULT:

A local replacement is chosen automatically, there is some signal, but no internet connection.

ADDITIONAL INFORMATION:

  • The network home and local (putted in parenthesis) are both recongnized.
  • I tried this with different carriers. In different countries, across Europe and further.
  • I always get that SMS from my home carrier telling me how many GB I can use in the country, how much additional SMS/phone calls would cost me, etc…
  • I tried:
    • restarting the phone
    • manually choosing the carrier (not the company selected automatically)
    • phone works with local SIM cards (yes, even the SIM cards from the automatically selected carrier by my “home” carrier)
    • selecting other preferred networks (4G or 3G)

What I didn’t try:

  • using a different url for the MMS and data access points (that would mean that my home SIM would try to connect to the local network which would refuse the connection, i guess)

Example:
I have a SIM card from Deutsch Telekom in my X10 II, I travel to Finland. Landing there I get the SMS from DT telling me that, because Finland is in the EU, I have 20Gb of mobile data, unlimited SMS and phone calls with the Telia carrier.
In my mobile network settings, roaming is activated, the phone recognized it and wrote “Network Deutsch Telekom (Telia)”, my prefered network type is 4G but in my upper home screen it’s written 3G (although Telia has a 4G network and that other phones are in 4G).

I don’t know which logs I could provide to help debugging, but feel free to tell me what to do and I’ll upload the logs.

You say, it is no regression. That makes me wonder because I never had this issue in France, Belgium, the Netherlands, Luxemburg or Sweden using my German Telekom SIM Card and my German Vodafone SIM Card. However, the last time I was in France was this Summer with SFOS 4.1 on an Xperia 10 ii and an XA2. There was no problem with data roaming. I have not tested data roaming with SFOS 4.3 yet.

Just a guess: What data access point (Datenzugriffspunkt under Settings → mobile Network) have you chosen? IP, IP6 or DUAL?
If I remember correctly, there were issues with IP6 (and thus DUAL as well). Therefore I have set the data access point to “IP”. Maybe that makes the difference.

Then I don’t understand why this happens if I’m the only one if I used different carriers …

I chose IP for the data and IPv6 for MMS

If you have chosen Protocol: IP, then i don’t no. I trust that all other details relating to DT SIM are the same on my and on your phone - and I had no issue so far. I don’t know when I learned to set the Protocol in Data Access Point to “IP”. The reason was some issue with mobile data connection quite some time ago. But if you manually set the Protocol in Data Access Point to “IP” like I did, then our phones should behave the same, I guess … (which apparently is not the case, though)

I tried IPv6 and Mixted just in case, but the result is the same…

Please read

and try with setting IP (which is v4) only.

Do you have the dot for allowing mobile data under Settings-Mobile network-Modile data glowing? And are you able to switch that off and on? (not talking about the roaming switch, in textual form).
Or is that setting greyed out?
I had that once and tested this SIM with other phone(s) and could not get data as well. A call (erm, two/three, different service personnel) brought up that my provider had a tick mark set for blocking mobile data abroad (for whatever reason :roll_eyes:). After they switched it and a reboot everything was fine…

1 Like

I did not travel much these days but on my XA2 with Vodafone Germany roaming in Poland works.

It’s literally the post just above it

Yup, dot for mobile data is glowing and I’m able to switch it on and off

Sorry, overread that, it seems.

Sorry, then I also do not know.