Xperia 10 ii - Unable to Flash Sailfish X

Hi,

I recently purchased a Xperia 10 II (XQ-AU51) and Sailfish X.

I followed the instructions here

I have followed the instructions and successfully unlocked the booloader.

When I try to flash Sailfish X I receive an error (anonymised below).

sudo bash ./flash.sh
[sudo] password for :
Detected Linux
Searching device to flash…
Found XQ-AU51, serial:QV724
**, baseband:, bootloader:
Found matching device with serial QV724*****
Fastboot command: fastboot -s QV724*****

fastboot -s QV724***** getvar secure
<< getvar secure: FAILED

fastboot -s QV72***** flash:raw boot_a hybris-boot.img
Sending ‘boot_a’ (18520 KB) FAILED (remote: ‘unknown command’)
fastboot: error: Command failed
Flashing failed (1)

Does anyone know what may be the reason for this?

I have previously flashed an Xperia X and XA2 without difficulties.

Have you downloaded SW_binaries_for_Xperia_Android_10.0.7.1_r1_v12b_seine.zip version exactly as per instruction page?

Yes, I have extracted the.img file to my Sailfish_OS-Jolla-4.1.0.24-xqau51-0.0.1.44 folder.

What does this elicit? fastboot getvar current-slot

It is a common issue, last seen here Fashing of Xperia 10 II fails - getvar secure: FAILED

You can try the getvar commands manually, if they only work intermittently, you are indeed hitting that issue. Try a port under another USB controller, preferably USB2, or a hub.

It just reads a variable from the bootloader config. I assume secure means locked.

OK, tried different USB ports and a USB hub - both of which made no difference.

I have now flashed the phone using a Windows 7 PC - which sucks for a Linux phone.

For future reference - flashing Sailfish X with Manjaro (Arch Linux) does not work.

It’s not an OS thing, don’t start rumours.

2 Likes

Please give it a try and see how you get on.

I have flashed several phones on my desktop, but none of the ports coming off the (X570) motherboard work.
If i use my Asmedia ASM1142-based add-in card it works just fine.
I use Linux Mint, but others here definitely use Arch-based distros and have it working too.

You have a sample size of one, and no A/B testing… come on!

2 Likes

I tried two different laptops, both with Manjaro installed, neither worked.

And until they work under another OS, you have proved nothing.

1 Like

I’m happy you had success with Linux Mint.

Yes, the getvar response ‘secure: yes’ means that the bootloader is not unlocked - which prevents installing an alternative OS to the device.

But in the report of @unruly, the execution of “fastboot getvar secure” failed which is a different thing.

Yes, the first part of my post was (an attempt at) answering that.
The second part, that you quoted, was for @aspergerguy.

Similar purple colors are confusing…

I’m reviving an ancient thread here. But it was the first I found. Ran into the same problem as OP. Using an USB hub solved the problem. Must be something to do with the USB-type.

1 Like

Seems like this thread revives itself from time to time. Have stumbled into the exact same problem. Also am running Manjaro and also trying to flash to an Xperia 10 II. Can anyone confirm a successful flash from Manjaro? Or is it the USB-interface type? I don’t have Windows around, so I’ll try different computers …