Use Android before Install

Flashing my phones is more than two years ago. I did NEVER test the phone with Android, out of the same reasons @MiKoNu mentioned. So I did in early 2019with a XA2, and in late 2019 with two Xperia 10’s. Everything works fine and always did, So I agree with @razcampagne , likely this is only to test the hardware.

1 Like

It is because you could have issues to claim warranty if there is a problem - I guess.

I checked briefly before flashing to the X 10 II.

It is up to you to decide what to do with that.

Your concerns, while fair, are already in Google’s grasp. Sony themselves obviously have to vet the device before shipping out, so QA may very well have interacted with your device prior to you getting it in your hands with the reset Android OS. Of course, because that’s not guaranteed either, it’s entirely on you to ensure all or most core functions work as expected first, to help both you, Jolla, and the community in the event that technical issues arise when using Sailfish.

Several systems of your phone, like GPS tracking, as well as Bluetooth, Wi-Fi and the in-built modem for cellular service, regardless of it being on Android or Sailfish, makes your location known and for data to be transmitted.

I know from my device that my XA2’s NFC capabilities are physically unusable since I am missing a pogo pin on the mainboard that connects to the pads on my back cover. This is a non-issue to me, and regardless, I couldn’t file for a warranty claim having bought it off eBay outright. But you can do you and just flash it outrigjt if you so choose. Just know the onus is on you if issues arise in SFOS that shouldn’t be there out of the gate.

Thank you all for the comments!
Now I feel more confident to flash SailfishOS without first transmitting all my personal details to Google.
I would even be inclined to flash SailfishOS before installing the SIM card into the phone - should be possible via USB cable and/or WiFi alone, shouldn’t it? - Has anyone done that?

1 Like

Is firing up the Phone with Stock Android (from Sony) giving away personal data to google?

i have no clue which data Google would receive - in particular if you do not have a Google/Android account. You can use an Android phone without such account

If its a phone you have never properly used on Android before (e.g. Set up email accounts, stored contacts, calendar entries, other accounts, done shopping, web browsing, installed optional apps, registered stuff, etc) then presumably it will just be an ‘empty’ Android phone as if you’d just bought it, with simply the Android OS and default apps on it. So it won’t have any of your personal data on it to send to Google. The most Google is likely to know is the phone’s physical location, make/model, software versions, etc when you first boot it up. As long as you test it without inputting any of your personal data then I can’t see how it would make this any worse.


Sure, as long as you haven’t done much on the phone, Google will only get a limited amount of data. But think about it what they can get, even if you boot up the phone only the first time. I just did with my new Xperia - with no SIM card inserted and no WiFi connection. But if you have the SIM in the phone and if you enable WiFi and connect the phone (which Android strongly suggests on boot up), then what can Google get?

  • Of course they’ll have your phone number - directly from the SIM card. And you can bet, that they have access to the official phone number registries, and if your SIM is registered under your name, then they’ll have your name and address right away.
  • They’ll have your device IMEI and probably other unique device IDs.
  • They’ll have your location and this will give them your address pretty accurately.
  • They’ll scan all the WiFi networks around you and upload that information and check that with their WiFi database. Chances are really high, that they already have all the data of your personal WiFi including exact location which was uploaded by all the other Google-device-carrying passers by.
  • Oh, and my phone suggested that I switch on and use the fingerprint sensor on the device. If I had done that and had been online, then they’d have my fingerprint information, as well.
  • If you load any web page with the web browser of the phone, then Google will also have your browser fingerprint, because they have their “google adservices” on 90% of the webpages.

And all that is completely independent of you having or using a Google account. And believe me, you don’t need to actively register with Google to have a (shadow) account there. Just as Facebook, they collect all the data they can get about everyone - if they are registered or not and if they want it or not. E. g. they even keep collecting your exact location data if you explicitly switch it off. (See e. g. - So, when you have a Google phone, Google will know when, how long and how often you visit your gynecologist. Google account or not.

And with this Corona bluetooth proximity sensor function they allegedly implemented in record time when Corona hit the world: I pretty much suspect, that this function has been there all along and that they only made the API for it public. So, they’ll have the MAC addresses of all your bluetooth devices around you, too. And they’ll know, that you currently hang out with some friend of yours (with his Android phone). Or they recognize the bluetooth devices around you and can allocate the new phone to your (shadow) Google account that way.

And, by the way, I don’t think that Apple is much better.

And, yes, I think this is a really big problem! You cannot have a free society, when everyone is supervised 24/7 by four or five global companies (Google, Apple, Facebook, Amazon, Microsoft and several others who are trying hard). This puts so much power over everyone in the hands of a few - that is an absolute no-go for a democracy.

We all heard Snowden - and it really doesn’t matter, if the surveillance is done by a government or by private companies (actually I am really not sure, which is worse). But unfortunately so few people listened to him. As long as they get their free WhatsApp and Google apps, they just don’t care.

I don’t remember who said it, but it seems to be absolutely true: There is nothing more dangerous for freedom than a horde of happy slaves.

But then, I probably don’t need to tell you here in this forum, because most of you are surely here for just the same reasons! Good to know, that there are at least some, who care about democracy and a free world. (That may sound pathetic, but exactly that is what is at stake!)


I still have the question: Has anyone ever installed Sailfish on a device without the SIM card inserted and then inserted it later? - This question is less because of data privacy, but because the SIM is still in another phone and I would like to completely prepare the new one before switching.

@MiKoNu Yes, I flashed 2 phones Xperia 10 out of the box without SIM card. Before flashing I did only power it on for one time for short test if it does something or does nothing - edit: and read out the IMEI Number. After it booted, I immediately turned it off without any connections and then flashed successfully. Phone is working fine since abt. 2 years. No problem.

@Seven.of.nine Thanks a lot for the info! But, “immediately turned it off”? - You must at least have enabled the developer mode and unlocked the boot loader, I assume.

Sorry, I forgot to write this in all details. Surely I went into the settings and wrote down the IMEI number for unlocking the device. And also I had a USB connection to a computer running Windows and connected to internet, also for unlocking the device. But I did not insert a SIM card or connect the phone to any WLAN before SFOS was flashed successfully.

Thanks for the clarification @Seven.of.nine!

Anyway, I started the Sailfish installation process now. (Checked the hardware on Android as far as possible without SIM card and WiFi connection. All ok.)
I then unlocked the boot loader with:

fastboot oem unlock 0x<my_unlock_code_from_Sony>

Seems to have worked, as the phone now complains about insecure boot at start up - but boots into the Android setup program then without any problems.

But the next step, flashing SailfishX, fails with the following error:

$ sudo bash ./
Flash utility v1.2
Detected Linux
Searching device to flash..
Found XQ-AU52, serial:QV725NGS3A, baseband:, bootloader:
Found matching device with serial QV725NGS3A
Fastboot command: fastboot -s QV725NGS3A
>> fastboot -s QV725NGS3A getvar secure
<< getvar:secure                                      FAILED (remote: 'GetVar Variable Not found')

Does anyone have an idea what could be wrong?

I am on Manjaro-Linux on the computer side and use the distros latest ‘android-tools’ package version (that package provides the fastboot binary) that matches the latest version of the tools you can download from the Sony website.

Ok, seems I found the cause: the problem in this thread looks exactly like mine:


I don’t have Windows around…
Looks like I’ll have to try on different computers …

There is a USB problem on the phones side with flashing.
Sony phone cannot connect to USB 3 port of the computer in flashing mode (hold Vol up + connect cable). Had the same problem some times. But modern computers always have USB 3 interfaces.
Therefore use of a USB hub with a USB2.0 port is necessary. In the end it worked successfully with inserting an USB hub between computer and phone. This USB hub must have an USB 2.0 socket. So the telephone successfully could establich connection and flashing succeeded.
Flashing the phone on computers USB3 port also led to an error as you described.

Short update: I’ve done it! It finally worked!

Thanks @Seven.of.nine for the tip with the USB hub, but I went a different path: grabbed my old Asus Eee PC from the closet and installed a current 32-bit Debian distribution on it. The fastboot version that comes with Debian is not the latest, but with that setup everything worked smoothly. So, now I have a brand new Sailfish X on my Xperia 10 II - without first connecting Android to the internet or giving it a SIM card. Until now everything works perfectly. WiFi connection works, camera, … - Only one thing missing, yet: I have not yet moved the SIM card to the new phone. We’ll see, if all the telephone functionality works, but I am confident.

Thank y’all for all the input!!! And have a nice Christmas still!


@MiKoNu Congrats!

And OT: Earlier I had also an Asus Eee PC and installed the last 32 bit Ubuntu on it. Later, I read something about 64 bit compatibility of the Eee PC and so I installed the newest Ubuntu 20.04 64 bit on it and it worked perfect on the first try!! So maybe you want to try the same and then you have a modern OS with LTS on your Eee PC.

1 Like

just in case you have the box and want to skip this step, the IMEI is always printed on the box somwhere :wink:

1 Like

Yes, it does: At least the cellular modem, as @nephros already pointed out.

People have been running into severe issues, when trying to use “roaming” abroad.
This step is supposed to avoid this.

I mean, the major point for me to use Sailfish OS is, that I do not want to feed the Google monster with my data.

There is no reason to feed Google with this information.
Actually this the reason, why I wrote this section of my extended install guide.

So if you run into issues to use “roaming” (e.g., abroad), “simply” re-flash to Android and do it all over again, utilising aforementioned guide.

1 Like

Or just boot a LiveCD/DVD/ISO from a USB Stick and see if a different Linux Distro works correctly in case you don’t want to reinstall your PC or Laptop just because you need to flash your phone! :wink:

1 Like